PBP Displayed Clock-Calendar Drops Hour Setting On Reboot.
#11
I'm also experiencing this. Default OS with the MrFixit and latest Debian updates installed. Clock holds the minutes correctly but always resets to 02xx (where xx = the correct minutes) upon reboot.
#12
I was able to fix this in the default image by setting the timezone in the command line:

Code:
timedatectl set-timezone Zone/SubZone


You can list all of them:

Code:
timedatectl list-timezones
 
and just check it:

Code:
timedatectl

My /etc/adjtime was correct (adjusted via the GUI in the date options), but this command was still showing the UTC as my timezone. After a couple of reboots, it seems to be holding, and /etc/localtime is correct as well (I'm not sure what it was before).
#13
(12-18-2019, 05:04 PM)xalius Wrote: Reading hardware clock from RK808 should work on the Debian images with BSP kernel, on the Manjaro image with mainline, hwclock currently can't read the time from the RK808, there is a bug somewhere...

It looks like that's a device tree issue.

From https://lkml.org/lkml/2020/1/21/551:

Code:
> +    rk808: pmic@1b {
> +        compatible = "rockchip,rk808";
> +        reg = <0x1b>;
> +        interrupt-parent = <&gpio1>;
> +        interrupts = <21 IRQ_TYPE_LEVEL_LOW>;
Interrupt GPIO is not correct, should be 10. This will stop the RTC from
working correctly.
#14
(01-22-2020, 10:16 AM)jackhumbert Wrote: I was able to fix this in the default image by setting the timezone in the command line:

Code:
timedatectl set-timezone Zone/SubZone


You can list all of them:

Code:
timedatectl list-timezones
 
and just check it:

Code:
timedatectl

My /etc/adjtime was correct (adjusted via the GUI in the date options), but this command was still showing the UTC as my timezone. After a couple of reboots, it seems to be holding, and /etc/localtime is correct as well (I'm not sure what it was before).

Thanks Jack... Worked very well, was always going back to GMT!
crocky
#15
I found a solution here: https://haydenjames.io/pinebook-pro-my-f...etup-tips/

Set your timezone (either in command line or GUI) then run the following (either as root or use sudo):


Code:
dpkg-reconfigure tzdata


You may need to reboot after running the command and setting the correct time.
#16
Thanks for the hot to @jackhumbert . It worked great.


Possibly Related Threads…
Thread Author Replies Views Last Post
  nvme drive disappears after about an hour of uptime codebreaker 25 10,696 02-09-2021, 11:32 PM
Last Post: dsimic
  Reboot, and halt and boot, are not the same regivanx 0 870 09-14-2020, 02:20 PM
Last Post: regivanx
  Memory clock speed: 800MHz vs 1600MHz? (NM, RK3399 won't run >800MHz DDR) Syonyk 4 3,185 06-26-2020, 07:22 PM
Last Post: Syonyk

Forum Jump:


Users browsing this thread: 2 Guest(s)