Did my Rock64 die?
#1
I've had a Rock64 since maybe June 2018.  Getting video out of it initially was a problem because it didn't recognize my old monitor's EDID.  Somebody on here walked me through using an EDID file, running update-initramfs and it worked fine.

Then winter came and the Rock64 was in an unheated basement so I didn't use it, but left it running.  At one point I tried to do something on it and it wasn't working so I tried a new SD card with a fresh image (but didn't do the EDID stuff), that didn't work.  This summer I used a Raspberry Pi down there then bought an Odroid N2, but I just found my Rock64 again.  Didn't boot with the SD card in it, which had files from 2018.  I salvaged some stuff from it and reloaded the SD with the latest stable Ayufan Debian.  Tried at least part of the
Code:
drm_kms_helper.edid_firmware=edid/1920x1080.bin

stuff from somebody else's post but no luck.  The red, green and white LEDs are on solid, no blinking.  I do have a serial debug cable with USB plug but I've never used it, don't know how.  I'm wondering why it quit in the first place and still doesn't work.  It's almost like it got a power line spike but I have a decent surge suppressor on it.

I'm missing the Mali and wanted to do some OpenCL and maybe OpenGL ES stuff on it.  The Odroid N2 doesn't have a proper XFree86 driver so there's no acceleration, just some OpenCL.  I remember the Rock64 doing glxgears and es2gears at hundreds of FPS.  Now I have a Pinebook Pro on order, wanted to practice, teach myself OpenGL ES.
  Reply
#2
In my experience the one sure way to rule out faulty hardware is to boot from Armbian https://www.armbian.com/rock64/

I've booted at least six boards that were supposedly dead this way. It's a works out of the box solution.
  Reply
#3
(11-16-2019, 10:08 AM)Rocklobster Wrote: In my experience the one sure way  to rule out faulty hardware is to boot from Armbian https://www.armbian.com/rock64/

I've booted at least six boards that were supposedly dead this way.  It's a works out of the box solution.

Yup, thank you, worked like a charm.  Went to write my Ayufan image over again and discovered I used a Rock64Pro image instead of a Rock64 one.

Well, the Ayufan image apparently still doesn't boot.  But I can't tell.  Nothing on the screen, monitor says no signal, and I can't ping it over wifi.  I suppose I could stick some script oneliner like
  touch booted.txt
in there somewhere and look for a booted.txt file.

I'm wondering if I still need to fiddle with an EDID file.  This monitor is newer, it's a Dell SE2216, works with more things.  I don't have hardwire internet but I suppose I could dig up a crossover cable.  I do know where my serial/debug cable is, I'd need to look up how to connect it.  Or it could be booted to some question and won't get past that until I answer it.
  Reply
#4
OK, my SD card wasn't latched in the socket.  Some don't so I had just pushed it in and tried to use it.

Now I'm trying to get logged in as root.  My usual trick of doing sudo chpass doesn't work.  But I have video.  I feel like I'm trying to root an Android phone or something.  I'm the only person who touches the machine and I'm behind a firewall and on NAT, this is excessive security.  I'll get it eventually.

OK, it's passwd on this, not chpass.  I'm in.
  Reply
#5
The Armbian image takes a lot of the guesswork out of troubleshooting. 50% of it in fact. The binary choice, is it hardware or software related is answered straight away.

I can't help on the Ayufan Distro front as my install is defacto Armbian but I'm sure others here will help. Glad to hear your board is working.
  Reply
#6
I don't like Armbian, or Ubuntu for that matter, because they do too much.  There are way more scripts and daemons running in even Debian than I like.  I like the idea of Linux From Scratch but last time I looked it was only for x86 and Raspberry Pi.  Arch, nah, too much like RedHat, everything's in the wrong place.

So I installed Ayufan's minimal Buster.  Could have saved a lot of time and trouble by copying in an interfaces file because I use only wifi.  The standard RTL8192 driver is a mess, I plugged in a Ralink one.  There's an 8192cu-dkms driver I have on my Odroid that's pretty good.  Started installing X programs into the minimal, ended up still missing mouse and keyboard under X.  So I went the overkill route and installed Gnome.  Very slow and pretty, but it got stuff working, now I'll go back to LXDE.  I must be using the wrong video driver, even the mouse pointer is slow.

-----

Got out of Gnome, set LXDE as the default.  But the mouse and keyboard don't work in X (except Gnome).  And I haven't figured out where to put a DontZap = False in my config files so atrl-alt-backspace can shut down the X server.  So I kill the power to get out.

If I do X -configure it says no devices found, I have a couple of video drivers for X.  I have to shut this Pi down to use this mouse and monitor and keyboard with my Rock64, so I can't do much online from it yet.  Installed Aptitude since I can't use Synaptic yet.  It mostly works but something's still missing.
  Reply
#7
I try to do X -configure and I get this:
Code:
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-arm64 aarch64 Debian
Current Operating System: Linux rock64 4.4.190-1233-rockchip-ayufan-gd3f1be0ed310 #1 SMP Wed Aug 28 08:59:34 UTC 2019 aarch64
Kernel command line: earlycon=uart8250,mmio32,0xff130000 swiotlb=1 kpti=0 no_console_suspend=1 usbcore.autosuspend=-1 rw panic=10 init=/sbin/init coherent_pool=1M ethaddr=de:0a:fc:15:fc:d9 eth1addr=de:0a:fc:15:fc:f9 serial=eb80203b044149b cgroup_enable=cpuset cgroup_memory=1 cgroup_enable=memory swapaccount=1 root=LABEL=linux-root rootwait rootfstype=ext4
Build Date: 05 March 2019  08:11:12PM
xorg-server 2:1.20.4-1 (https://www.debian.org/support)
Current version of pixman: 0.36.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 18 15:50:30 2019
List of video drivers:
modesetting
fbdev
No devices to configure.  Configuration failed.
(EE) Server terminated with error (2). Closing log file.

I think this is because no driver matches my hardware, but I'm not sure what driver I should install.  I was trying the mali-midgard dkms one until I looked it up and this Mali is an Utgard.  Didn't build anyway.
  Reply
#8
Thumbs Down 
Got it, some time I'll document the process better.  Seems like everybody makes a minimal image and usually a bloated one that still doesn't have what I want.  Basically I installed a few X applications like Firefox and Gimp, LXDE, xinit then started fixing what was missing by looking at the xorg log.

.gif   rock64_gui.gif (Size: 30.64 KB / Downloads: 5)

Unrelated but I thought I'd pass it along since I just tried it on 2 machines.  If you're sick of network interface renaming put this in your kernel command line string:
Quote:net.ifnames=0 biosdevname=0

How you do that is your problem, on my x86 laptop it had to go in via Grub, on my Rock64 it went in /boot/extlinux/extlinux.conf.

You get back to sensible network names like eth0 and wlan0.  I just had to type the long names (with MAC addresses) a dozen times or more to even get X running so I could copy and paste, so I looked it up.  And the long names are slightly error-prone in that situation. Angry

You may notice some CPU usage from dhclient trying to figure out the change, it stops once the old leases expire.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Remote desktop access Rock64 over Internet hg6806 2 53 11 hours ago
Last Post: default_user8
Question /dev/spidev0,0 on the Rock64 - Does anyone know how to enable it? Kappuchino 14 2,754 12-05-2019, 09:42 PM
Last Post: phuzy
  CentOS 7 for Rock64 pineadmin 1 518 11-25-2019, 05:11 AM
Last Post: bazooka07
  Headless installation of Real VNC server on Rock64 possible? hg6806 3 63 11-18-2019, 04:32 AM
Last Post: evilbunny
  Rock64 lost connection after high I/O traffic Rock68 3 108 11-13-2019, 05:14 AM
Last Post: Rocklobster
Brick Rock64 stuck in boot, please help! Malmgren 7 232 11-05-2019, 07:02 AM
Last Post: Malmgren
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 61 13,901 11-03-2019, 09:08 AM
Last Post: mara
  Help with OMV on Rock64 Lindzaur 1 129 10-21-2019, 02:55 AM
Last Post: gigagames
  reproduce mono bug on pine64/rock64 dontpostalot 1 115 09-23-2019, 06:34 PM
Last Post: Rocklobster
  Linux Images (ROCK64) pineadmin 156 77,954 08-30-2019, 05:08 PM
Last Post: kcirap

Forum Jump:


Users browsing this thread: 1 Guest(s)