pmbootstrap to sdcard
#11
Hi, last night i tried to install pmOS (plasma mobile extra) from pmbootstrap, but i recieved an error message:



Quote:(024312) [21:53:28] (native) % mkdir -p /mnt/install/boot
(024312) [21:53:29] (native) % mount /dev/installp1 /mnt/install/boot
mount: /mnt/install/boot: wrong fs type, bad option, bad superblock on /dev/installp1, missing codepage or helper program, or other error.
(024312) [21:53:34] ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
I tried the demo image and it's ok but how can i make the pmbootstrap work?
#12
(02-09-2020, 06:44 AM)albertz Wrote: Hi, last night i tried to install pmOS (plasma mobile extra) from pmbootstrap, but i recieved an error message:



Quote:(024312) [21:53:28] (native) % mkdir -p /mnt/install/boot
(024312) [21:53:29] (native) % mount /dev/installp1 /mnt/install/boot
mount: /mnt/install/boot: wrong fs type, bad option, bad superblock on /dev/installp1, missing codepage or helper program, or other error.
(024312) [21:53:34] ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
I tried the demo image and it's ok but how can i make the pmbootstrap work?

if you want to install on SD card, you shoudn't run
Code:
pmbootstrap install --sdcard /dev/mmcblk0
but pmbootstrap install --sdcard=/dev/sd*, where * can be a,b,c... for instance :

Code:
pmbootstrap install --sdcard=/dev/sdb

because mmcblk() is the emmc module, when sd() (for instance sdb, sdc..) is a SD card. Make sure you identifiy well your SD card. You may run :
Code:
ls /dev/

before inserting you SD card, and after, to see what is the name of the device. In my case, it is sdb, but for you, it can be something else.
* PinePhone BraveHeart Edition
#13
I think some clarification of device naming may be needed. Whether an DS card appears as /dev/sdX or /dev/mmcblkX depends on whether it's attached through a USB adapter or a native interface. For a native interface like in the PinePhone, boards such as the Raspberry Pi, or some laptops, the SD card appears as /dev/mmcblkX. A USB adapter translates between native interface commands and USB storage device commands, so the computer sees a usb storage device /dev/sdX. If you look at dmesg immediately after plugging in the card you should see which device was added.
#14
(02-10-2020, 02:48 AM)Gobelin Wrote: if you want to install on SD card, you shoudn't run
Code:
pmbootstrap install --sdcard /dev/mmcblk0
but pmbootstrap install --sdcard=/dev/sd*, where * can be a,b,c... for instance :

Code:
pmbootstrap install --sdcard=/dev/sdb

because mmcblk() is the emmc module, when sd() (for instance sdb, sdc..) is a SD card. Make sure you identifiy well your SD card. You may run :
Code:
ls /dev/

before inserting you SD card, and after, to see what is the name of the device. In my case, it is sdb, but for you, it can be something else.

but I've used lsblk to identify the media, I think is not a problem of the localization of the media but from some internal of pmbootstrap or some misconfiguration during the init, but i I don't know. If i want to restart the installation i have to use pmbootstrap zap?
#15
I've tried again but there is something with the partition, here the log:


Code:
(013263) [15:34:19] (native) partition /dev/install (boot: 69M, root: the rest)
(013263) [15:34:19] (native) % parted -s /dev/install mktable msdos
Error: I/O error during write on /dev/install
(013263) [15:34:21] (native) % parted -s /dev/install mkpart primary ext2 2048s 69M
Error: /dev/install: unrecognised disk label
(013263) [15:34:26] (native) % parted -s /dev/install mkpart primary 69M 100%
Error: /dev/install: unrecognised disk label
(013263) [15:34:32] (native) % parted -s /dev/install set 1 boot on
Error: /dev/install: unrecognised disk label
(013263) [15:34:37] NOTE: (1/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (2/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (3/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (4/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (5/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (6/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (7/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (8/20) failed to find the install partition. Retrying...
(013263) [15:34:37] NOTE: (9/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (10/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (11/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (12/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (13/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (14/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (15/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (16/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (17/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (18/20) failed to find the install partition. Retrying...
(013263) [15:34:38] NOTE: (19/20) failed to find the install partition. Retrying...
(013263) [15:34:39] NOTE: (20/20) failed to find the install partition. Retrying...
(013263) [15:34:39] ERROR: Unable to find the partition prefix, expected the first partition of /dev/mmcblk0 to be located at /dev/mmcblk01 or /dev/mmcblk0p1!
(013263) [15:34:39] See also: <https://postmarketos.org/troubleshooting>
(013263) [15:34:39] Traceback (most recent call last):
 File "/home/albertzdic/.local/lib/python3.7/site-packages/pmb/__init__.py", line 63, in main
   getattr(frontend, args.action)(args)
 File "/home/albertzdic/.local/lib/python3.7/site-packages/pmb/helpers/frontend.py", line 196, in install
   pmb.install.install(args)
 File "/home/albertzdic/.local/lib/python3.7/site-packages/pmb/install/_install.py", line 547, in install
   install_system_image(args)
 File "/home/albertzdic/.local/lib/python3.7/site-packages/pmb/install/_install.py", line 397, in install_system_image
   pmb.install.partitions_mount(args)
 File "/home/albertzdic/.local/lib/python3.7/site-packages/pmb/install/partition.py", line 52, in partitions_mount
   "1 or " + prefix + "p1!")
RuntimeError: Unable to find the partition prefix, expected the first partition of /dev/mmcblk0 to be located at /dev/mmcblk01 or /dev/mmcblk0p1!

 
this error don't understand (this from a log from 2nd time try):

Code:
Error: /dev/install: unrecognised disk label

now i tried to mklabel gpt directly with parted but gives me error
Code:
(parted) mklabel gpt                                                      
Error: Input/output error during write on /dev/mmcblk0

can it be the the sd itself?
#16
Ok it was the sd,  i've bought a new sd and the pmbootstrap was successful. It was strange, because dd a demo image with the old sd was ok... Huh
#17
Hello. Here's what I get from the install to the sdcard:

curt@pop-os:~$ pmbootstrap install --sdcard /dev/mmcblk0
[14:16:09] *** (1/5) PREPARE NATIVE CHROOT ***
[14:16:09] (native) install alpine-base
[14:16:10] NOTE: Valid pkgvers are described here:
[14:16:10] <https://wiki.alpinelinux.org/wiki/APKBUILD_Reference#pkgver>
[14:16:10] ERROR: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD
[14:16:10] See also: <https://postmarketos.org/troubleshooting>
Run 'pmbootstrap log' for details.

So, here's output from 'pmbootstrap log':

curt@pop-os:~$ cat pmbootstrap.log
(5/19) Installing alpine-conf (3.8.3-r6)
(6/19) Installing libcrypto1.1 (1.1.1d-r4)
(7/19) Installing libssl1.1 (1.1.1d-r4)
(8/19) Installing ca-certificates-cacert (20191127-r1)
(9/19) Installing libtls-standalone (2.9.1-r0)
(10/19) Installing ssl_client (1.31.1-r11)
(11/19) Installing zlib (1.2.11-r3)
(12/19) Installing apk-tools (2.10.4-r3)
(13/19) Installing busybox-suid (1.31.1-r11)
(14/19) Installing busybox-initscripts (3.2-r2)
Executing busybox-initscripts-3.2-r2.post-install
(15/19) Installing scanelf (1.2.4-r0)
(16/19) Installing musl-utils (1.1.24-r0)
(17/19) Installing libc-utils (0.7.2-r0)
(18/19) Installing alpine-keys (2.1-r2)
(19/19) Installing alpine-base (3.12_alpha20200122-r0)
Executing busybox-1.31.1-r11.trigger
OK: 8 MiB in 19 packages
(027632) [14:16:10] (native) % adduser -D pmos -u 12345
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-abuild-config /home/pmos/.abuild
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-abuild-config
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-ccache /home/pmos/.ccache
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-ccache
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/packages
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-packages /home/pmos/packages/pmos
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-packages
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/.cargo/registry
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/registry/index /home/pmos/.cargo/registry/index
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/registry/index
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/registry/cache /home/pmos/.cargo/registry/cache
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/registry/cache
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/.cargo/git
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/git/db /home/pmos/.cargo/git/db
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/git/db
(027632) [14:16:10] (native) calculate depends of cryptsetup, util-linux, e2fsprogs, parted, dosfstools (pmbootstrap -v for details)
(027632) [14:16:10] NOTE: Valid pkgvers are described here:
(027632) [14:16:10] <https://wiki.alpinelinux.org/wiki/APKBUILD_Reference#pkgver>
(027632) [14:16:10] ERROR: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD
(027632) [14:16:10] See also: <https://postmarketos.org/troubleshooting>
(027632) [14:16:10] Traceback (most recent call last):
File "/home/curt/pmbootstrap/pmb/__init__.py", line 63, in main
getattr(frontend, args.action)(args)
File "/home/curt/pmbootstrap/pmb/helpers/frontend.py", line 198, in install
pmb.install.install(args)
File "/home/curt/pmbootstrap/pmb/install/_install.py", line 493, in install
build=False)
File "/home/curt/pmbootstrap/pmb/chroot/apk.py", line 202, in install
packages_with_depends = pmb.parse.depends.recurse(args, packages, suffix)
File "/home/curt/pmbootstrap/pmb/parse/depends.py", line 146, in recurse
package = package_from_aports(args, pkgname_depend)
File "/home/curt/pmbootstrap/pmb/parse/depends.py", line 33, in package_from_aports
aport = pmb.helpers.pmaports.find(args, pkgname_depend, False)
File "/home/curt/pmbootstrap/pmb/helpers/pmaports.py", line 133, in find
apkbuild = pmb.parse.apkbuild(args, path_current)
File "/home/curt/pmbootstrap/pmb/parse/_apkbuild.py", line 312, in apkbuild
"' in APKBUILD: " + path)
RuntimeError: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD

Everything went smoothly before the actual install attempt. Any suggestions will be appreciated.
#18
(02-10-2020, 02:23 PM)curtvaughan Wrote: Hello. Here's what I get from the install to the sdcard:

curt@pop-os:~$ pmbootstrap install --sdcard /dev/mmcblk0
[14:16:09] *** (1/5) PREPARE NATIVE CHROOT ***
[14:16:09] (native) install alpine-base
[14:16:10] NOTE: Valid pkgvers are described here:
[14:16:10] <https://wiki.alpinelinux.org/wiki/APKBUILD_Reference#pkgver>
[14:16:10] ERROR: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD
[14:16:10] See also: <https://postmarketos.org/troubleshooting>
Run 'pmbootstrap log' for details.

So, here's output from 'pmbootstrap log':

curt@pop-os:~$ cat pmbootstrap.log
(5/19) Installing alpine-conf (3.8.3-r6)
(6/19) Installing libcrypto1.1 (1.1.1d-r4)
(7/19) Installing libssl1.1 (1.1.1d-r4)
(8/19) Installing ca-certificates-cacert (20191127-r1)
(9/19) Installing libtls-standalone (2.9.1-r0)
(10/19) Installing ssl_client (1.31.1-r11)
(11/19) Installing zlib (1.2.11-r3)
(12/19) Installing apk-tools (2.10.4-r3)
(13/19) Installing busybox-suid (1.31.1-r11)
(14/19) Installing busybox-initscripts (3.2-r2)
Executing busybox-initscripts-3.2-r2.post-install
(15/19) Installing scanelf (1.2.4-r0)
(16/19) Installing musl-utils (1.1.24-r0)
(17/19) Installing libc-utils (0.7.2-r0)
(18/19) Installing alpine-keys (2.1-r2)
(19/19) Installing alpine-base (3.12_alpha20200122-r0)
Executing busybox-1.31.1-r11.trigger
OK: 8 MiB in 19 packages
(027632) [14:16:10] (native) % adduser -D pmos -u 12345
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-abuild-config /home/pmos/.abuild
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-abuild-config
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-ccache /home/pmos/.ccache
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-ccache
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/packages
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-packages /home/pmos/packages/pmos
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-packages
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/.cargo/registry
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/registry/index /home/pmos/.cargo/registry/index
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/registry/index
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/registry/cache /home/pmos/.cargo/registry/cache
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/registry/cache
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/.cargo/git
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/git/db /home/pmos/.cargo/git/db
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/git/db
(027632) [14:16:10] (native) calculate depends of cryptsetup, util-linux, e2fsprogs, parted, dosfstools (pmbootstrap -v for details)
(027632) [14:16:10] NOTE: Valid pkgvers are described here:
(027632) [14:16:10] <https://wiki.alpinelinux.org/wiki/APKBUILD_Reference#pkgver>
(027632) [14:16:10] ERROR: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD
(027632) [14:16:10] See also: <https://postmarketos.org/troubleshooting>
(027632) [14:16:10] Traceback (most recent call last):
File "/home/curt/pmbootstrap/pmb/__init__.py", line 63, in main
getattr(frontend, args.action)(args)
File "/home/curt/pmbootstrap/pmb/helpers/frontend.py", line 198, in install
pmb.install.install(args)
File "/home/curt/pmbootstrap/pmb/install/_install.py", line 493, in install
build=False)
File "/home/curt/pmbootstrap/pmb/chroot/apk.py", line 202, in install
packages_with_depends = pmb.parse.depends.recurse(args, packages, suffix)
File "/home/curt/pmbootstrap/pmb/parse/depends.py", line 146, in recurse
package = package_from_aports(args, pkgname_depend)
File "/home/curt/pmbootstrap/pmb/parse/depends.py", line 33, in package_from_aports
aport = pmb.helpers.pmaports.find(args, pkgname_depend, False)
File "/home/curt/pmbootstrap/pmb/helpers/pmaports.py", line 133, in find
apkbuild = pmb.parse.apkbuild(args, path_current)
File "/home/curt/pmbootstrap/pmb/parse/_apkbuild.py", line 312, in apkbuild
"' in APKBUILD: " + path)
RuntimeError: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD

Everything went smoothly before the actual install attempt. Any suggestions will be appreciated.

You typed pin64 instead of pine64 into the device selection when running "pmbootstrap init". so it created a new device page for that device with some scaffolding in it that isn't complete. to remove it delete "/home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone" and "/home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/device-pin64-pinephone"

Then run pmbootstrap init again and type the correct name
#19
(02-07-2020, 08:57 AM)ksmithaz1 Wrote: From scratch on Ubu 18.04:

pip3 install pmbootstrap
PATH="$PATH:~/.local/bin"
mkdir ~/.local/var/pmbootstrap
pmbootstrap init
pmbootstrap install --sdcard /dev/sda
pmbootstrap shutdown

~20 min into install it prompts (after I'm in bed):

. . .
[21:13:57] (rootfs_pine64-pinephone) mkinitfs postmarketos-allwinner
[21:14:01]  *** SET LOGIN PASSWORD FOR: 'user' ***
New password:
Retype new password:
passwd: password updated successfully
[06:10:04] NOTE: No valid keymap specified for device
[06:10:08] *** (3/5) PREPARE INSTALL BLOCKDEVICE ***
. . .
[06:18:56] NOTE: chroot is still active (use 'pmbootstrap shutdown' as necessary)
[06:18:56] Done

So I selected kde + extras, set the password above to something simple ... pass1234

Boot it on the phone.  Sluggish, but it boots, play around breifly, plug in to charge.,  Now I have a lock screen, but it's only numbers, and I can't unlock the thing.

This is fun . . . Wink!  Not much on google search for a default.  Might have blown past it somewhere.  Probably should have started an installation thread.
try  Rob Braxmans install video on youtube , its not a "demo" flash, so will let you use all your "space" but you get the very latest phosh which may not have many apps, you can choose plasma, look for the advised inputs in  { parenthesis }  . good viewing for noobs ( like me)
#20
(02-11-2020, 06:44 AM)MartijnBraam Wrote:
(02-10-2020, 02:23 PM)curtvaughan Wrote: Hello.  Here's what I get from the install to the sdcard:

curt@pop-os:~$ pmbootstrap install --sdcard /dev/mmcblk0
[14:16:09] *** (1/5) PREPARE NATIVE CHROOT ***
[14:16:09] (native) install alpine-base
[14:16:10] NOTE: Valid pkgvers are described here:
[14:16:10] <https://wiki.alpinelinux.org/wiki/APKBUILD_Reference#pkgver>
[14:16:10] ERROR: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD
[14:16:10] See also: <https://postmarketos.org/troubleshooting>
Run 'pmbootstrap log' for details.

So, here's output from 'pmbootstrap log':

curt@pop-os:~$ cat pmbootstrap.log
(5/19) Installing alpine-conf (3.8.3-r6)
(6/19) Installing libcrypto1.1 (1.1.1d-r4)
(7/19) Installing libssl1.1 (1.1.1d-r4)
(8/19) Installing ca-certificates-cacert (20191127-r1)
(9/19) Installing libtls-standalone (2.9.1-r0)
(10/19) Installing ssl_client (1.31.1-r11)
(11/19) Installing zlib (1.2.11-r3)
(12/19) Installing apk-tools (2.10.4-r3)
(13/19) Installing busybox-suid (1.31.1-r11)
(14/19) Installing busybox-initscripts (3.2-r2)
Executing busybox-initscripts-3.2-r2.post-install
(15/19) Installing scanelf (1.2.4-r0)
(16/19) Installing musl-utils (1.1.24-r0)
(17/19) Installing libc-utils (0.7.2-r0)
(18/19) Installing alpine-keys (2.1-r2)
(19/19) Installing alpine-base (3.12_alpha20200122-r0)
Executing busybox-1.31.1-r11.trigger
OK: 8 MiB in 19 packages
(027632) [14:16:10] (native) % adduser -D pmos -u 12345
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-abuild-config /home/pmos/.abuild
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-abuild-config
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-ccache /home/pmos/.ccache
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-ccache
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/packages
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-packages /home/pmos/packages/pmos
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-packages
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/.cargo/registry
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/registry/index /home/pmos/.cargo/registry/index
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/registry/index
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/registry/cache /home/pmos/.cargo/registry/cache
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/registry/cache
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos mkdir -p /home/pmos/.cargo/git
(027632) [14:16:10] (native) % busybox su pmos -c HOME=/home/pmos ln -s /mnt/pmbootstrap-rust/git/db /home/pmos/.cargo/git/db
(027632) [14:16:10] (native) % chown pmos:pmos /mnt/pmbootstrap-rust/git/db
(027632) [14:16:10] (native) calculate depends of cryptsetup, util-linux, e2fsprogs, parted, dosfstools (pmbootstrap -v for details)
(027632) [14:16:10] NOTE: Valid pkgvers are described here:
(027632) [14:16:10] <https://wiki.alpinelinux.org/wiki/APKBUILD_Reference#pkgver>
(027632) [14:16:10] ERROR: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD
(027632) [14:16:10] See also: <https://postmarketos.org/troubleshooting>
(027632) [14:16:10] Traceback (most recent call last):
 File "/home/curt/pmbootstrap/pmb/__init__.py", line 63, in main
   getattr(frontend, args.action)(args)
 File "/home/curt/pmbootstrap/pmb/helpers/frontend.py", line 198, in install
   pmb.install.install(args)
 File "/home/curt/pmbootstrap/pmb/install/_install.py", line 493, in install
   build=False)
 File "/home/curt/pmbootstrap/pmb/chroot/apk.py", line 202, in install
   packages_with_depends = pmb.parse.depends.recurse(args, packages, suffix)
 File "/home/curt/pmbootstrap/pmb/parse/depends.py", line 146, in recurse
   package = package_from_aports(args, pkgname_depend)
 File "/home/curt/pmbootstrap/pmb/parse/depends.py", line 33, in package_from_aports
   aport = pmb.helpers.pmaports.find(args, pkgname_depend, False)
 File "/home/curt/pmbootstrap/pmb/helpers/pmaports.py", line 133, in find
   apkbuild = pmb.parse.apkbuild(args, path_current)
 File "/home/curt/pmbootstrap/pmb/parse/_apkbuild.py", line 312, in apkbuild
   "' in APKBUILD: " + path)
RuntimeError: Invalid pkgver '3.x.x' in APKBUILD: /home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone/APKBUILD

Everything went smoothly before the actual install attempt.  Any suggestions will be appreciated.

You typed pin64 instead of pine64 into the device selection when running "pmbootstrap init". so it created a new device page for that device with some scaffolding in it that isn't complete. to remove it delete "/home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/linux-pin64-pinephone" and "/home/curt/.local/var/pmbootstrap/cache_git/pmaports/device/device-pin64-pinephone"

Then run pmbootstrap init again and type the correct name
Thanks. Will try this out a.s.a.p.  Much appreciated.


Possibly Related Threads…
Thread Author Replies Views Last Post
  phone won't boot from emmc with sdcard inserted ssilvi 3 2,377 06-06-2021, 02:47 AM
Last Post: ssilvi
  Cannot boot from SDCard cube 2 2,255 01-31-2021, 11:47 AM
Last Post: cube
  pmbootstrap error lat 2 2,486 12-22-2020, 06:32 PM
Last Post: lat
  pmbootstrap issues IVp 3 3,955 09-24-2020, 02:24 AM
Last Post: Pinethom
  pmbootstrap build large keyboard not usable u20200719 5 4,960 07-25-2020, 02:31 PM
Last Post: u20200719
  Is it possible to pre-configure wifi and ssh with pmbootstrap? kelbot 2 3,420 07-06-2020, 01:55 AM
Last Post: ChriChri
  Dumb question: do I have to use pmbootstrap? quixote 5 5,177 06-11-2020, 09:23 AM
Last Post: plainenough
  pmbootstrap on Mac OSX srfne 2 3,847 02-29-2020, 04:15 PM
Last Post: srfne
  Does pmbootstrap install the latest image? mypine 4 4,577 02-20-2020, 01:02 PM
Last Post: mypine
  pmbootstrap - choose different ui after first run mypine 2 2,925 02-13-2020, 04:35 PM
Last Post: mypine

Forum Jump:


Users browsing this thread: 1 Guest(s)