ChromiumOS experience
(11-07-2019, 08:25 AM)tophneal Wrote: 2 finger tap for right click rarely works for me, I've resigned trying anymore. Every attempt registers as a single finger tap/click.

Right-click works for me quire reliably if I "spread my fingers" far apart enough. Maybe that will help you?
It definitely doesn't register as a right click for me when the two fingers are touching.
I'll give that a try!
Has anybody gotten the camera to work in Chromium?  I booted Chromium from SD and seems to be working fine except the Linux option and the far.
(11-13-2019, 01:44 PM)gabeeg Wrote: Has anybody gotten the camera to work in Chromium?  I booted Chromium from SD and seems to be working fine except the Linux option and the far.

Not yet. I've honestly been a bit clueless as to where to start for the webcam. I keep meaning to check if it was part of the compatibility chart from ayufan.
#15 and me both Smile
I booted ChromeOS from microsd on my PBP, got as far as the updating chromeos screen which failed to update. So I logged in as a guest to try out Chromeos. When I exited Chrome, removed the microsd and rebooted into Ubuntu + mate, I got error messages that it could not boot ("dependency failed for boot/efi" and "dependency failed for load file system", and went into recovery mode. Had to reinstall Ubuntu. Has anyone else had this problem?

BTW the same problem occurred when I booted andoid OS via microSD. Had to reinstall ubuntu + Mate a second time.
(11-13-2019, 02:15 PM)gabeeg Wrote: and me both Smile

I haven't tried it yet, because I've been playing with Manjaro lately, but I found this and have it on my list to see if it can help recover the use of the camera.
(11-08-2019, 05:52 PM)Arglebargle Wrote: RE u-boot: The script to patch u-boot on the eMMC is simple enough that it should just work, I don't think it's doing anything that would fail on chromeOS.

If for some reason it does fail I hacked a copy so I could flash to a specified device instead of the detected root; I used this to patch loopback mounted copies of ayufan's images so they're ready to use again if I need them. Just edit DEVID to point at the device you want to flash updated u-boot onto:

You don't want to be working in crosh, either switch to the debug shell (ctrl+alt+f2) or drop to a proper shell from crosh by running "shell" and then switch to root. I usually just "sudo -i bash" as cronos (default password is "cronos") and away you go.


I tried the ChromeOS build out for a bit last night and it seemed to work well. Netflix video playback seemed significantly smoother compared to Linux, is there better support for hardware accelerated video here vs the Linux builds? My only real gripe with the experience was the touchpad, otherwise the PBP makes a pretty decent chromebook.

I decided to write R76 the other day to compare it to R77 (and see if Linux VM would install) and I learned some things that may be handy to others down the line.

First, no, R76 VMs don't install, and in general R77 runs better. Ignore R76.

When I switched back to R77, I needed to reapply this uboot patch. There's an issue with using MrFixit's script, from a powered down state I could not get the PBP to boot unless I inserted an SD card. So in order to boot into CrOS, I first had to insert my Manjaro SD, then remove it once I saw the backlight come on.

This part is a bit of a facepalm learning experience. Once R77 was back on my PBP I downloaded the uboot .imgs and the modifiied script provided by Arglebargle. However whenever I tried to run the modified script, I kept getting problems, namely warnings about noexec, unexpected fi, and $'\r': command not found. After a bit of digging I realized the script file is saved with DOS-style endings. While looking for a way to resolve this (I don't suggest Text from the Web Store) I came across Chromebrew.

For anyone running CrOS on their PBP, I highly recommend it, since the default Linux tools don't work. With it, I was able to install dos2unix to quickly fix the script file (it ran correctly afterward,) and nano, because I hate vim and wanted a simple text editor that isn't likely to repeat this issue. I haven't dived too deep yet into what apps are and are not available through it, though.
Is it possible to run the ChromeOS from Sd with standard linux on the eMMC?
I am just curios to try chromes on the PPB without loosing it current OS
Of course, you can run all the systems from SD.

Forum Jump:

Users browsing this thread: 1 Guest(s)