How to connect with wifi ?
#21
(05-22-2016, 01:49 PM)Hi,Thanks for your reply. Yes I am using the official Wifi board. Also I am running the Debian Mate, how can I configure it? Without any modification, I can connect to the router, but cannot get online. Then I try to change the wpa_supplicant.conf and interfaces, but still fail.  jl_678 Wrote: Hi,

To be clear you are working with the official WiFi board, correct?

Are you running a desktop like Mate? That is the easiest way to to configure it.

If not then did you follow my instructions exactly? Where does it show unmanaged?

Sent from my XT1254 using Tapatalk
  Reply
#22
Can you provide the output of sudo ifconfig?

Sent from my XT1254 using Tapatalk
  Reply
#23
Here is the ifconfig:

Code:
debian@pine64pro:~$ sudo ifconfig
[sudo] password for debian:
eth0      Link encap:Ethernet  HWaddr 36:c9:e3:f1:b8:05  
         inet addr:192.168.0.112  Bcast:192.168.0.255  Mask:255.255.255.0
         inet6 addr: fe80::34c9:e3ff:fef1:b805/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:2064 errors:0 dropped:0 overruns:0 frame:0
         TX packets:960 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:2675638 (2.5 MiB)  TX bytes:87294 (85.2 KiB)
         Interrupt:114

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:65536  Metric:1
         RX packets:4 errors:0 dropped:0 overruns:0 frame:0
         TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

rename4   Link encap:Ethernet  HWaddr 34:c3:d2:6d:4b:68  
         inet addr:192.168.1.111  Bcast:192.168.1.255  Mask:255.255.255.0
         inet6 addr: fe80::36c3:d2ff:fe6d:4b68/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:404 errors:0 dropped:0 overruns:0 frame:0
         TX packets:105 errors:0 dropped:1 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:88215 (86.1 KiB)  TX bytes:16487 (16.1 KiB)

Here is the iwconfig:

Code:
debian@pine64pro:~$ sudo iwconfig
eth0      no wireless extensions.

rename4   IEEE 802.11bgn  ESSID:"Propagation-Guest-2.4GHz"  Nickname:"<WIFI@REALTEK>"
         Mode:Managed  Frequency:2.437 GHz  Access Point: F8:1A:67:2E:F7:D9  
         Bit Rate:150 Mb/s   Sensitivity:0/0  
         Retry:off   RTS thr:off   Fragment thr:off
         Encryption key:****-****-****-****-****-****-****-****   Security mode:open
         Power Management:off
         Link Quality=99/100  Signal level=-68 dBm  Noise level=0 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<WIFI@REALTEK>"
         Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated  
         Sensitivity:0/0  
         Retry:off   RTS thr:off   Fragment thr:off
         Encryption key:off
         Power Management:off
         Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

and here is my interfaces:

Code:
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
#source-directory /etc/network/interfaces.d

# Primary Ethernet
auto eth0
iface eth0 inet dhcp

# Disable Secondary Wireless Lan (8723bs Has Two Interfaces)
iface wlan1 inet manual

#wlan0
#auto wlan0
#iface wlan0 inet dhcp
#wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
#iface pine64 inet dhcp

#rename4/wlan0
auto rename4
iface rename4 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface pine64 inet dhcp


Also my wpa_supplicant.conf:
Code:
network={
    ssid="Propagation-Guest-2.4GHz"
    psk="1234567890"
    proto=WPA RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP
    auth_alg=OPEN
    id_str="pine64"
}
  Reply
#24
Okay so I am comparing your files and mine and all are pretty much the same.  The one difference is your wpa_supplicant.conf.  The differences do not seem significant though.  Perhaps try matching mine exactly?  Here is mine:

Code:
network={
      ssid="MyNetworkName"
      psk="MyNetworkPasscode"
      proto=RSN
      key_mgmt=WPA-PSK
      pairwise=CCMP
      group=CCMP
      auth_alg=OPEN
      priority=9
      id_str="pine64"
}
  Reply
#25
There is a simple fix for wlan0 showing up as rename4. Just delete, or rather move /etc/udev/rules.d/70-persistent-net.rules to somewhere else. That will trigger /lib/udev/write_net_rules to execute again. When I did that I found it only made one entry for wlan0, if left wlan1 and eth0 alone. After that systemd-udevd should just use wlan0.

I would also suggest adding 
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

to the top of your /etc/wpa_supplicant/wpa_supplicant.conf. After that and a quick reboot everything worked as expected. It seems systemd starts wpa_supplicant and that can cause some strangeness. If you are getting wpa_supplicant errors check /var/log/deamon.log
  Reply
#26
(05-25-2016, 05:55 PM)I followed your idea, now it back to wlan0. But still cannot get the web browser online.  JamesHarris Wrote: There is a simple fix for wlan0 showing up as rename4. Just delete, or rather move /etc/udev/rules.d/70-persistent-net.rules to somewhere else. That will trigger /lib/udev/write_net_rules to execute again. When I did that I found it only made one entry for wlan0, if left wlan1 and eth0 alone. After that systemd-udevd should just use wlan0.

I would also suggest adding 
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

to the top of your /etc/wpa_supplicant/wpa_supplicant.conf. After that and a quick reboot everything worked as expected. It seems systemd starts wpa_supplicant and that can cause some strangeness. If you are getting wpa_supplicant errors check /var/log/deamon.log
  Reply
#27
I switched to Debian XFCE image, and now the WiFi is working
  Reply
#28
(05-25-2016, 05:55 PM)JamesHarris Wrote: There is a simple fix for wlan0 showing up as rename4. Just delete, or rather move /etc/udev/rules.d/70-persistent-net.rules to somewhere else. That will trigger /lib/udev/write_net_rules to execute again. When I did that I found it only made one entry for wlan0, if left wlan1 and eth0 alone. After that systemd-udevd should just use wlan0.

I would also suggest adding 
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

to the top of your /etc/wpa_supplicant/wpa_supplicant.conf. After that and a quick reboot everything worked as expected. It seems systemd starts wpa_supplicant and that can cause some strangeness. If you are getting wpa_supplicant errors check /var/log/deamon.log
The rename thing has been annoying me and so I decided to do this. It worked perfectly and now my WiFi connection is listed as wlan0 as expected.

Thank you!

Sent from my XT1254 using Tapatalk
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Q4OS WiFi Dongle not working cheezmeister 3 2,410 04-07-2017, 08:01 AM
Last Post: iccoldbeer
  Wifi connect through terminal? cheezmeister 0 914 04-02-2017, 09:44 AM
Last Post: cheezmeister
  Bringing up wifi dongle m16bishop 2 1,981 07-04-2016, 03:24 PM
Last Post: m16bishop

Forum Jump:


Users browsing this thread: 1 Guest(s)