How to connect with wifi ?
#11
I booted the pine64 with newer version of debian lenny raposo. But I got the same behaviour, when I tried to open a website. It tries to load the page but could not open. Then I typed

Code:
sudo ifdown eth0

and weasel opened the webpage. I checked the interface and the

Code:
autodown eth0

line was already commented out.
  Reply
#12
ok can you give me the results of

1) uname -a
2) sudo ifconfig
3) sudo iwconfig

thx
If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
  Reply
#13
Code:
debian@pine64pro:~$ sudo uname -a
Linux pine64pro 3.10.101-0-pine64-longsleep #39 SMP PREEMPT Sat May 7 12:39:25 CEST 2016 aarch64 GNU/Linux



Code:
debian@pine64pro:~$ sudo ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:658 errors:0 dropped:0 overruns:0 frame:0
          TX packets:658 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:58141 (56.7 KiB)  TX bytes:58141 (56.7 KiB)

rename4   Link encap:Ethernet  HWaddr 34:c3:d2:7b:4e:b7  
          inet addr:192.168.0.18  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::36c3:d2ff:fe7b:4eb7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2830 errors:0 dropped:19 overruns:0 frame:0
          TX packets:1887 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3364780 (3.2 MiB)  TX bytes:249434 (243.5 KiB)


Code:
debian@pine64pro:~$ sudo iwconfig
eth0      no wireless extensions.

rename4   IEEE 802.11bgn  ESSID:"Network Name"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.412 GHz  Access Point: FC:4A:E9:14:BC:3F   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=100/100  Signal level=-58 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
  Reply
#14
So you have the latest kernel
and wireless is there

It looks like your adapter is called rename4


give me the results of cat /etc/network/interfaces
If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
  Reply
#15
here it is:


Code:
debian@pine64pro:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
#source-directory /etc/network/interfaces.d

# Primary Ethernet
auto eth0
iface eth0 inet dhcp

# Disable Secondary Wireless Lan (8723bs Has Two Interfaces)
iface wlan1 inet manual
  Reply
#16
Hi,

I am seeing the same issue on a fresh install of your debian build.  I previously installed Longsleep's Ubuntu build and the wifi worked perfectly and so I think that it has something to do with this image.

We appear to be getting an IP from DHCP.  The name of the interface is "rename4" which also seems odd to me.  Below is the output from uname -a, ifconfig, iwconfig, interfaces and for the heck of it, wpa-supplicant.conf.  Note that I modified both interfaces and wpa-supplicant.conf using settings that worked in the Ubuntu build.

uname -a

Code:
Linux pine64pro 3.10.101-0-pine64-longsleep #39 SMP PREEMPT Sat May 7 12:39:25 CEST 2016 aarch64 GNU/Linux

ifconfig

Code:
eth0      Link encap:Ethernet  HWaddr 36:c9:e3:f1:b8:05
          inet6 addr: fe80::34c9:e3ff:fef1:b805/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:670 (670.0 B)
          Interrupt:114

eth0:avahi Link encap:Ethernet  HWaddr 36:c9:e3:f1:b8:05
          inet addr:169.254.9.92  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:114

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:243 errors:0 dropped:0 overruns:0 frame:0
          TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21008 (20.5 KiB)  TX bytes:21008 (20.5 KiB)

rename4   Link encap:Ethernet  HWaddr 34:c3:d2:96:84:85
          inet addr:192.168.0.134  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::36c3:d2ff:fe96:8485/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:695 errors:0 dropped:0 overruns:0 frame:0
          TX packets:313 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:127884 (124.8 KiB)  TX bytes:56683 (55.3 KiB)

iwconfig

Code:
eth0      no wireless extensions.

rename4   IEEE 802.11bgn  ESSID:"MyNetworkName"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.462 GHz  Access Point: C4:E9:84:E0:B9:42
          Bit Rate:150 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=98/100  Signal level=-45 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


interfaces

Code:
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
#source-directory /etc/network/interfaces.d

# Primary Ethernet
auto eth0
iface eth0 inet dhcp

#wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface pine64 inet dhcp

# Disable Secondary Wireless Lan (8723bs Has Two Interfaces)
iface wlan1 inet manual

wpa_supplicant.conf

Code:
network={
       ssid="MyNetworkName"
       psk="MyNetworkKey"
       proto=RSN
       key_mgmt=WPA-PSK
       pairwise=CCMP
       group=CCMP
       auth_alg=OPEN
       priority=9
       id_str="pine64"
}
  Reply
#17
Hi,

I keep exploring this and found something interesting. Using "ping -I" seems to work over rename4.  However if I ping the same domain with "ping" it fails.  This feels like some kind of routing issue.  

Code:
debian@pine64pro:~$ ping -I "rename4" abc.com
PING abc.com (199.181.132.250) from 192.168.0.134 rename4: 56(84) bytes of data.
64 bytes from play.toontown.com (199.181.132.250): icmp_seq=1 ttl=239 time=95.9 ms
64 bytes from play.toontown.com (199.181.132.250): icmp_seq=2 ttl=239 time=91.2 ms


debian@pine64pro:~$ ping abc.com
PING abc.com (199.181.132.250) 56(84) bytes of data.
From pine64pro.local (169.254.9.92) icmp_seq=1 Destination Host Unreachable
From pine64pro.local (169.254.9.92) icmp_seq=2 Destination Host Unreachable
From pine64pro.local (169.254.9.92) icmp_seq=3 Destination Host Unreachable
  Reply
#18
I found a solution to this that works for me.  It requires a couple of file modifications.  Here you go.

/etc/network/interfaces.d - Add the following:

Code:
#rename4/wlan0
auto rename4
iface rename4 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface pine64 inet dhcp
/etc/wpa_supplicant - create the file (if it is not already there) and put in the following:

Code:
network={
       ssid="YourNetworkName"
       psk="YourNetworkKey"
       proto=RSN
       key_mgmt=WPA-PSK
       pairwise=CCMP
       group=CCMP
       auth_alg=OPEN
       priority=9
       id_str="pine64"
}

Then you need to restart the the rename4 interface or reboot.  To restart to the following.  (If you are missing ifconfig, you can get it with apt-get install net-tools):

Code:
sudo ifconfig rename4 down
sudo ifconfig rename4 up

This solution worked for me....
  Reply
#19
(05-16-2016, 02:12 PM)I followed your modification, but still cannot get online. It just shows rename4 - device not managed. Any idea I can fix this issue?Thanks jl_678 Wrote: I found a solution to this that works for me.  It requires a couple of file modifications.  Here you go.

/etc/network/interfaces.d - Add the following:

Code:
#rename4/wlan0
auto rename4
iface rename4 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface pine64 inet dhcp
/etc/wpa_supplicant - create the file (if it is not already there) and put in the following:

Code:
network={
       ssid="YourNetworkName"
       psk="YourNetworkKey"
       proto=RSN
       key_mgmt=WPA-PSK
       pairwise=CCMP
       group=CCMP
       auth_alg=OPEN
       priority=9
       id_str="pine64"
}

Then you need to restart the the rename4 interface or reboot.  To restart to the following.  (If you are missing ifconfig, you can get it with apt-get install net-tools):

Code:
sudo ifconfig rename4 down
sudo ifconfig rename4 up

This solution worked for me....
  Reply
#20
Hi,

To be clear you are working with the official WiFi board, correct?

Are you running a desktop like Mate? That is the easiest way to to configure it.

If not then did you follow my instructions exactly? Where does it show unmanaged?

Sent from my XT1254 using Tapatalk
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Q4OS WiFi Dongle not working cheezmeister 3 2,723 04-07-2017, 08:01 AM
Last Post: iccoldbeer
  Wifi connect through terminal? cheezmeister 0 1,035 04-02-2017, 09:44 AM
Last Post: cheezmeister
  Bringing up wifi dongle m16bishop 2 2,214 07-04-2016, 03:24 PM
Last Post: m16bishop

Forum Jump:


Users browsing this thread: 1 Guest(s)