Rock64 v2 network issues
#1
I'm having regular problems netbooting my Rock64 with U-Boot 2017.09-rockchip-ayufan-1035-gd646df03ac (Oct 26 2018 - 08:36:01 +0000)
  
The symptoms reflecting the problem are that the LED state on the Rock64 RJ45 is wrong (either the green LED or the orange LED is on but not both) and both the U-Boot console and the switch at the other end of the cable[1] indicate GigE/FDX but the TFTP client reports checksum errors and eventually gives up.
  
This seems to be solely related to the firmware autonegotiation - once the kernel starts, it's rock solid at 1000/FDX.  It also gets less reliable as the ambient temperature drops[2].  Whilst the above firmware isn't the latest, the changelogs for the later versions appear solely related to supporting the RK3399.

Has anyone else seen this problem?

Whilst investigating the problem, I discovered that there's a Rock64 v3 and my board is v2.0.  According to ROCK64 SBC v3.0 Change Notice, one change is "Improved transmission packet loss on gigabit Ethernet by adjusting LED0/CFG_EXT and LED2/CFG_LDO1 pull up resistor connect to 3.3V instead of 1.8V."  This sounds similar enough to my problem that I thought it was worth looking into.  Comparing the v2 and v3 schematics, the only relevant difference is that on v2, R3331 is absent and R3332 is present, whilst on v3, R3331 is present and R3332 is absent.  VCCIO_PHY is connected to VCC_IO (3.3V via R3352) in both variants.  Based on that, it should be possible to implement that fix on a v2 board by moving R3332 to R3331.  Whilst there's no publicly available component overlay for the v2 board, the v3 component overlay in that area agrees with the results of my buzzing out that part of the schematic.  Has anyone tried making this mod on a v2 board?
  
[1] I've tried both a NetGear GigE switch and a spare GigE port on my main server with the same behaviour.
[2] Warming the board with my wife's hairdryer will "fix" the problem.
#2
I've tried making the mod I suggested it the previous posting and all my network problems have gone away.
#3
Please be so kind as to enlighten us on the position of R3331 and R3332 on the Rock64 V2.

Thank you very much.


Possibly Related Threads…
Thread Author Replies Views Last Post
  OpenWRT on the Rock64 CanadianBacon 5 979 03-31-2022, 01:29 PM
Last Post: CT456
  Rock64 bricked shawwwn 6 1,637 01-29-2022, 05:49 AM
Last Post: shawwwn
  Rock64 board not working, no HDMI no Ethernet. EDited 2 804 01-26-2022, 08:46 AM
Last Post: TRS-80
Question Constant RockPro64 PCIe SATA Issues Kwarter 0 251 01-22-2022, 05:16 PM
Last Post: Kwarter
  Rock64 <--> Rock64 Serial Connection mark1250 1 617 12-23-2021, 09:27 PM
Last Post: barray
  Are you guys still using Ayufan's OMV on your Rock64? AkiraSensei 0 612 11-26-2021, 07:01 PM
Last Post: AkiraSensei
  Rock64 kernel panics clay 15 4,293 10-17-2021, 06:30 PM
Last Post: Rocklobster
  Pine Rock64 eMMC lifespan moonspell79 3 1,758 08-19-2021, 06:46 PM
Last Post: bcnaz
  Rock64 No Audio - Solved wbecks 12 21,803 08-13-2021, 01:23 PM
Last Post: blakeadam
  Trustzone support for Rock64 capablegh 1 1,253 07-17-2021, 10:15 AM
Last Post: capablegh

Forum Jump:


Users browsing this thread: 1 Guest(s)