Failed to start Network Manager Wait Online
#1
I have a ping64+ 1Gb that refuses to obtain a IP address.

ip addr:
Quote:1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 26:6f:b5:31:80:36 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::246f:b5ff:fe31:8036/64 scope link
       valid_lft forever preferred_lft forever
3: sit0: <NOARP> mtu 1480 qdisc noop state DOWN group default
    link/sit 0.0.0.0 brd 0.0.0.0

Doing a sudo ifconfig eth0 down && sudo ifconfig eth0 up results in:

Quote:[ 5060.383772] Call trace:
[ 5060.592128] Call trace:

Edit:
Output from: systemctl status NetworkManager-wait-online.service
Quote:NetworkManager-wait-online.service - Network Manager Wait Online
Loaded: loaded (/lib/systemd/system/NetworkManager-wait-online.service; enabl
Active: failed (Result: exit-code) since Thu 2018-08-23 15:00:12 UTC; 20s ago
Docs: man:nm-online(1)
Process: 999 ExecStart=/usr/bin/nm-online -s -q --timeout=30 (code=exited, sta
Main PID: 999 (code=exited, status=1/FAILURE)

Aug 23 14:59:42 pine64 systemd[1]: Starting Network Manager Wait Online...
Aug 23 15:00:12 pine64 systemd[1]: NetworkManager-wait-online.service: Main proc
Aug 23 15:00:12 pine64 systemd[1]: Failed to start Network Manager Wait Online.
Aug 23 15:00:12 pine64 systemd[1]: NetworkManager-wait-online.service: Unit ente
Aug 23 15:00:12 pine64 systemd[1]: NetworkManager-wait-online.service: Failed wi

I also attached the serial out from the first boot.

I have also tried to manually set a mac address. That does not seem to change anything. I could be doing it wrong.

Edit:
It does look like I am using the provided mac address:
Quote:eth0 Link encap:Ethernet HWaddr 00:06:dc:8b:41:a5
inet6 addr: fe80::206:dcff:fe8b:41a5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:401 (401.0 B) TX bytes:2462 (2.4 KB)
Interrupt:114

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6368 (6.3 KB) TX bytes:6368 (6.3 KB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Any suggestions welcomed.


Attached Files
.txt   firstboot.txt (Size: 13.73 KB / Downloads: 14)
  Reply
#2
Do the LED lights flash on your Ethernet port? I'm having issues, too, and posted in a separate thread before I saw this one.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to make a GTK app start up fullscreen on boot? julu 2 1,240 02-28-2017, 05:57 PM
Last Post: julu

Forum Jump:


Users browsing this thread: 1 Guest(s)