gphoto2 error
Good morning all.

I have Debian installed on my A64, trimmed down to be headless.  It only offers SSH connections with only TTY & SSH access.

It works fine but gphoto2 throws an error when attempting to access my Canon EOS 350d.  

gphoto2 --auto-detect re4cognises it:

ken@floki:~$ gphoto2 --auto-detect
Model                          Port
Canon EOS 350D                 usb:002,003

gphoto2 -L or gphoto2 -l returns an error:

*** Error ***
An error occurred in the io-library ('I/O problem'): No error description available
*** Error (-7: 'I/O problem') ***

I also specified a port using --port and tried --summary.  Received the same error.

Last year on a Debian build and AMD X64 machine it worked fine.  My Win 10 machine sees the camera just fine.  Does anyone have any guidance?



Quick follow-up.

I found a post somewhere that indicates in some cases, in order to run gphoto2, the user must be running with root privileges. So, I ran gphoto2 using sudo and it works mostly. When I say 'mostly', I mean that after entering SHELL mode, then exiting, I receive similar errors from my original post. Resetting the camera clears the error.

So, basically my solution to the problem I asked about is to run gphoto2 using sudo.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Forum error? androsch 1 2,608 04-11-2016, 04:06 PM
Last Post: Ghost

Forum Jump:

Users browsing this thread: 1 Guest(s)