mpph264enc output doesn't work on bionic
(05-16-2019, 09:39 AM)jonsmirl Wrote: That is 32b image. 32b is known to work. 64b is broken.

I believe 64b is broken because kernel and mpp aren't compiled using the same header files, so the IOTCL don't match between user space and the kernel.

So it still doesn't work on 64-bit? Are there any plans to support this in the future? Any idea if the new rock64pro works at all?
I guess that won't help, but I tried your commands with an OrangePi RK3399, and it seemed to work.
I suppose it is working with 32 bits, not 64...

$ sudo gst-launch-1.0 -e videotestsrc is-live=false num-buffers=500 \
> ! video/x-raw,format=NV12,width=1280,height=720 \
> ! mpph264enc ! filesink location=1280.h264

(gst-plugin-scanner:741): GLib-GObject-WARNING **: 09:29:09.504: cannot register existing type 'GstKMSSink'

(gst-plugin-scanner:741): GLib-GObject-CRITICAL **: 09:29:09.504: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gst-plugin-scanner:741): GLib-GObject-CRITICAL **: 09:29:09.504: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gst-plugin-scanner:741): GLib-CRITICAL **: 09:29:09.504: g_once_init_leave: assertion 'result != 0' failed

(gst-plugin-scanner:741): GStreamer-CRITICAL **: 09:29:09.504: gst_element_register: assertion 'g_type_is_a (type, GST_TYPE_ELEMENT)' failed
Setting pipeline to PAUSED ...
mpi: mpp version: b212d1b author: Jacob Chen [mpp]: fix mjpeg buffer leak
Pipeline is PREROLLING ...
h264e_api: h264e_config MPP_ENC_SET_RC_CFG bps 3456000 [3240000 : 3672000]
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Got EOS from element "pipeline0".
Execution ended after 0:00:14.428808048
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
mpp_thread: MPP_THREAD_STOPPING status set mThread 0xab2a1c30
Freeing pipeline ...
linaro@captation-techforum-rk3399-4GB:~$ ffprobe -hide_banner 1280.h264
Input #0, h264, from '1280.h264':
 Duration: N/A, bitrate: N/A
   Stream #0:0: Video: h264 (High), yuv420p(progressive), 1280x720, 30 fps, 30 tbr, 1200k tbn, 60 tbc

Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 Rev3 doesn't boot and leds blinking fast dishins 3 3,662 08-16-2020, 07:42 AM
Last Post: aclaret
  armbian / bionic - hdmi to vga not functioning on newer5.4 kapqa 1 1,859 03-31-2020, 07:19 PM
Last Post: tllim
Sad HDMI doesn't work on rock64 rock7 0 1,889 12-16-2019, 01:04 PM
Last Post: rock7
  Owncloud installation on Ubuntu Bionic Count Omega 9 6,909 07-19-2019, 03:54 AM
Last Post: stuartiannaylor
  HDMI output with Arch Linux Arm yogo1212 2 3,173 07-17-2019, 02:46 AM
Last Post: yogo1212
  Screen lock fail Bionic-lxde-rock64-0.7.8-1061-arm64 electrique 0 1,404 12-28-2018, 11:00 PM
Last Post: electrique
  bionic lxde 0.6.xx was not getting audio/sound jose_s_c 2 2,937 11-13-2018, 11:18 AM
Last Post: UnicornFarts
  Arch Linux minimal image w/ full HDMI output support hiccupstix 1 2,625 11-01-2018, 08:33 AM
Last Post: danboid
  Spontaneous Reboot during scp with Ubuntu bionic 0.7.8-1061 perniciouscaffeine 0 1,288 10-16-2018, 05:34 PM
Last Post: perniciouscaffeine
  Cannot make DAC Add-on Board work under debian szclsya 0 1,277 09-29-2018, 12:57 AM
Last Post: szclsya

Forum Jump:

Users browsing this thread: 1 Guest(s)