HW Acceleration Working
Quote:The following packages have unmet dependencies:
 xserver-xorg-video-armsoc-sunxi : Depends: xorg-video-abi-20 but it is not installable
                                   Depends: xserver-xorg-core (>= 2:1.17.99.902) but 2:1.16.4-1 is to be installed
E: Unable to correct problems, you have held broken packages.

As you can see I am having an issue installing the sunxi package, it seems to think something is on hold but ....

Quote:debian@pine64:~$ sudo apt-mark unhold xserver-xorg-core
xserver-xorg-core was already not hold.
debian@pine64:~$ sudo apt-mark unhold xorg-video-abi-20
xorg-video-abi-20 was already not hold.

I can't find it. When I do apt-mark showhold, I get nothing back. Is there a big huge thing that I am missing?

I will say even without this I am still getting around 50fps on glxgears at 1080p.

Thanks in advance.
(08-03-2016, 12:30 PM)HorreC Wrote:
Quote:The following packages have unmet dependencies:
 xserver-xorg-video-armsoc-sunxi : Depends: xorg-video-abi-20 but it is not installable
                                   Depends: xserver-xorg-core (>= 2:1.17.99.902) but 2:1.16.4-1 is to be installed
E: Unable to correct problems, you have held broken packages.

As you can see I am having an issue installing the sunxi package, it seems to think something is on hold but ....

Quote:debian@pine64:~$ sudo apt-mark unhold xserver-xorg-core
xserver-xorg-core was already not hold.
debian@pine64:~$ sudo apt-mark unhold xorg-video-abi-20
xorg-video-abi-20 was already not hold.

I can't find it. When I do apt-mark showhold, I get nothing back. Is there a big huge thing that I am missing?

I will say even without this I am still getting around 50fps on glxgears at 1080p.

Thanks in advance.

I mean maybe I am missing something but doesn't number one saying you can't install xserver-..-sunxi because it needs xorg-video-abi-20 - can't find that in the repos
xserver-xorg-core version 2.1.17 or greater... but when I look for it in the repos I can't find it....

So you need to ignore that with apt-get --nodeps // not advisable because you may break the system
Or you need to find those packages and build them? with git and what not?
(08-03-2016, 03:26 PM)rallar8 Wrote:
(08-03-2016, 12:30 PM)HorreC Wrote:
Quote:The following packages have unmet dependencies:
 xserver-xorg-video-armsoc-sunxi : Depends: xorg-video-abi-20 but it is not installable
                                   Depends: xserver-xorg-core (>= 2:1.17.99.902) but 2:1.16.4-1 is to be installed
E: Unable to correct problems, you have held broken packages.

As you can see I am having an issue installing the sunxi package, it seems to think something is on hold but ....

Quote:debian@pine64:~$ sudo apt-mark unhold xserver-xorg-core
xserver-xorg-core was already not hold.
debian@pine64:~$ sudo apt-mark unhold xorg-video-abi-20
xorg-video-abi-20 was already not hold.

I can't find it. When I do apt-mark showhold, I get nothing back. Is there a big huge thing that I am missing?

I will say even without this I am still getting around 50fps on glxgears at 1080p.

Thanks in advance.

I mean maybe I am missing something but doesn't number one saying you can't install xserver-..-sunxi because it needs xorg-video-abi-20 - can't find that in the repos
xserver-xorg-core version 2.1.17 or greater... but when I look for it in the repos I can't find it....

So you need to ignore that with apt-get --nodeps // not advisable because you may break the system
Or you need to find those packages and build them? with git and what not?
It wont install due to something that is on hold
Quote:E: Unable to correct problems, you have held broken packages.   <----

And you are right I dont wanna break anything with --no-deps, so I was hoping that someone would have the info that I needed as so many seem to have installed this, I only have the default install so I am confused why I am getting this error. I do come from a HUGE linux background but its all been redhat not much on the deb side till now.

This feels like installing sawfish in the 90's to me and I broke so many installs with that damn --force command that I wanna take this one slow.
HorreC

I see you are using debian and not ubuntu. Ubuntu (16.04) is currently up to xserver-xorg-core version 2.1.18 and that version is definitely in the Ubuntu repo (of course.) I don't know about debian. Maybe it is in the unstable debian repo. When dependencies like this happen, people sometime recommend switching to the debian unstable repo (and then switch back if you want to.)

Despite many statements implying the contrary, debian and ubuntu are not interchangeable by design, or in sync by design, although they sometimes happen to be. True, they are close.

But in Ubuntu you can set the package manager to prefer your current versions or the highest version. If you can do this in debian, that could be the problem or the solution.

IAC, there is a debian 2.2.18 version, although jumping versions can result in a long string of more and more dependencies.

http://http.us.debian.org/debian/pool/ma..._arm64.deb

You can look for packages at:

https://packages.debian.org/sid/arm64/xs...e/download
I figured it was a debian issue, I just cant figure out what got held at all on the system. I might try this again on a ubuntu build and see if that will allow me to look at the new built kernel and see if the gains are there for me and able to press on with the other project these Pines will be going at.


Thanks for the help, and if I find a fix for the debian issues I will post here for info for others.
(08-04-2016, 09:53 AM)HorreC Wrote: I figured it was a debian issue, I just cant figure out what got held at all on the system. I might try this again on a ubuntu build and see if that will allow me to look at the new built kernel and see if the gains are there for me and able to press on with the other project these Pines will be going at.


Thanks for the help, and if I find a fix for the debian issues I will post here for info for others.

try:
Code:
dpkg -l | grep ^h
Please excuse me, but after reading this long thread I'm not sure what's the status for the Mali driver.
Any chance for a summary, and instructions if it's ready?
Thanks!
(08-08-2016, 02:04 AM)piner64 Wrote: Please excuse me, but after reading this long thread I'm not sure what's the status for the Mali driver.
Any chance for a summary, and instructions if it's ready?
Thanks!
Summary is that it is working but not released yet.

Sent from my SM-G935F using Tapatalk
(08-08-2016, 04:05 AM)Monochrome Wrote:
(08-08-2016, 02:04 AM)piner64 Wrote: Please excuse me, but after reading this long thread I'm not sure what's the status for the Mali driver.
Any chance for a summary, and instructions if it's ready?
Thanks!
Summary is that it is working but not released yet.

Sent from my SM-G935F using Tapatalk

Any idea when we can expect the release? 

PS. congrats to all the guys who worked hard to make this work!
When it is ready for release [it's not polite to ask for eta]. Keep an eye here or on pine64.pro


Possibly Related Threads…
Thread Author Replies Views Last Post
  Brand New LCD not working adamjedgar 3 2,796 03-11-2017, 12:20 AM
Last Post: simplexdan
  Pine64+: 3 working, 1 shows nothing on tv zumtra 1 1,872 07-30-2016, 05:47 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)