HDD gets not detected after reboot
#9
I have the same problem: https://forum.pine64.org/showthread.php?tid=5875

What do you get when you enter: dmesg -wH?

Turning on and off the hard drives a few times make it work. But it doesnt work by default on USB3.0 on boot.



[Mar27 20:41] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.001330] usb usb5-port1: cannot disable (err = -32)
[ +19.989129] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.001335] usb usb5-port1: cannot disable (err = -32)
[Mar27 20:42] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.001341] usb usb5-port1: cannot disable (err = -32)
[ +1.202664] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.018718] usb usb5-port1: cannot disable (err = -32)
[Mar27 20:44] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.019053] usb usb5-port1: cannot disable (err = -32)
[ +40.660799] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.018685] usb usb5-port1: cannot disable (err = -32)
[Mar27 20:46] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.019019] usb usb5-port1: cannot disable (err = -32)
[Mar27 20:47] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.006564] usb usb5-port1: cannot disable (err = -32)
[Mar27 20:48] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.018923] usb usb5-port1: cannot disable (err = -32)
[Mar27 20:49] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.019101] usb usb5-port1: cannot disable (err = -32)
[ +16.277967] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.006342] usb usb5-port1: cannot disable (err = -32)
[Mar27 21:30] xhci-hcd xhci-hcd.8.auto: port 0 resume PLC timeout
[ +5.742867] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +5.232322] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +0.218864] usb 5-1: device not accepting address 2, error -62
[Mar27 21:31] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +5.232182] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +0.207003] usb 5-1: device not accepting address 3, error -62
[ +5.409325] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +0.207016] usb 5-1: Device not responding to setup address.
[ +0.206919] usb 5-1: device not accepting address 4, error -71
[ +0.006232] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.006210] usb usb5-port1: cannot disable (err = -32)
[ +5.365865] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +5.216288] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +0.207000] usb 5-1: device not accepting address 5, error -62
[ +0.027109] usb usb5-port1: unable to enumerate USB device
[ +18.534735] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +5.216250] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +0.206943] usb 5-1: device not accepting address 6, error -62
[ +5.395727] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +5.229836] xhci-hcd xhci-hcd.8.auto: Timeout while waiting for setup device command
[ +0.218966] usb 5-1: device not accepting address 7, error -62
[ +0.018411] xhci-hcd xhci-hcd.8.auto: Cannot set link state.
[ +0.018858] usb usb5-port1: cannot disable (err = -32)
[Mar27 21:32] usb 5-1: new SuperSpeed USB device number 8 using xhci-hcd
[ +0.029930] usb 5-1: New USB device found, idVendor=174c, idProduct=55aa
[ +0.018513] usb 5-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ +0.013358] usb 5-1: Product: External HDD
[ +0.006015] usb 5-1: Manufacturer: 01234567890123456789012345678901234567890123
[ +0.006308] usb 5-1: SerialNumber: 201308070213
[ +0.059266] usb-storage 5-1:1.0: USB Mass Storage device detected
[ +0.007795] usb-storage 5-1:1.0: Quirks match for vid 174c pid 55aa: 400000
[ +0.006389] scsi host0: usb-storage 5-1:1.0
[ +0.006746] usbcore: registered new interface driver usb-storage
[ +0.010794] usbcore: registered new interface driver uas
[ +6.364552] scsi 0:0:0:0: Direct-Access WDC WD32 01ABYS-01B9A0 13.0 PQ: 0 ANSI: 5
[ +0.007974] sd 0:0:0:0: [sda] 625142448 512-byte logical blocks: (320 GB/298 GiB)
[ +0.007000] sd 0:0:0:0: [sda] Write Protect is off
[ +0.006170] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
[ +0.000435] sd 0:0:0:0: [sda] No Caching mode page found
[ +0.006158] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ +0.080574] sda: sda1
[ +0.007636] sd 0:0:0:0: [sda] Attached SCSI disk
[ +1.791350] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: user_xattr,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl
  Reply


Messages In This Thread
RE: HDD gets not detected after reboot - by k8Va - 04-19-2018, 04:12 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
Question HDD filesystem corruption at reboot / poweroff (DietPi) WrongWorld 1 2,985 02-11-2019, 04:00 PM
Last Post: WrongWorld
  USB drive powered off after reboot huberttrz 1 3,111 12-20-2018, 05:39 PM
Last Post: huberttrz
  Spontaneous Reboot during scp with Ubuntu bionic 0.7.8-1061 perniciouscaffeine 0 1,926 10-16-2018, 05:34 PM
Last Post: perniciouscaffeine
  Freeze/reboot/errors when compiling - unable to make - reproducible and not isolated jovval 2 3,984 10-02-2018, 08:10 AM
Last Post: jovval
  Rock64 - Stuck when do the soft reboot ramprasad 10 14,123 06-21-2018, 01:16 AM
Last Post: pfeerick
  Debian: MAC address keeps changing on every reboot rontant 14 16,916 11-22-2017, 05:11 PM
Last Post: joseccz

Forum Jump:


Users browsing this thread: 1 Guest(s)