[Repaired] [Progressed] [Successful] How to play Minecraft with ROCK 64
#1
Google Translate : 
I was suffering at ROCK 64 whether I can not do Minecraft.
The reason why Minecraft can not easily play on the single board computer with ARM installed,
LWJGL that is downloaded automatically by the launcher is not compatible with ARM.
Therefore, I compile LWJGL with ROCK 64.

* Here, FPS is very low because I do not use GPU to process graphics.
I am using "https://github.com/yuq/linux-lima", "https://github.com/yuq/mesa-lima"
Although I am challenging to compile, because of lack of knowledge, I have not been able to compile and install a forward kernel.
Please tell me how to compile the kernel with ROCK 64!
* The sound does not come out from the headphone jack for some reason!
Please tell me about this matter too!
* If you have any advice, please reply!

Installation:
sudo apt-get update
sudo apt-get install gradle openjdk-8-jdk libx11-dev xorg-dev
reboot
sudo ln -s /usr/lib/jvm/java-8-openjdk-arm64/lib/aarch64/libjawt.so /usr/lib/libjawt.so
git clone https://github.com/LWJGL/lwjgl
cd lwjgl
ant generate-all
ant compile_native
mkdir -p ~/.minecraft/natives
cp ~/lwjgl/libs/linux/liblwjgl.so ~/.minecraft/natives/
cp ~/lwjgl/libs/linux/libopenal.so ~/.minecraft/natives/
cd ~/
wget https://s3.amazonaws.com/Minecraft.Downl...ecraft.jar
At startup:
export _JAVA_OPTIONS='-Djava.library.path=/home/rock64/.minecraft/natives/'
java -jar Minecraft.jar
have fun!


原文 : 
私は、ROCK64で、Minecraftができないかずっと悩んでいました。
ARM搭載のシングルボードコンピュータで、Minecraftが安易にプレイできない理由は、
ランチャーで自動的にダウンロードされるLWJGLがARMに対応していないことです。
そこで、LWJGLをROCK64でコンパイルしてしまいます。

*ここでは、グラフィックの処理にGPUを使っていないため、FPSがとても低いです。
私は、「https://github.com/yuq/linux-lima」、「https://github.com/yuq/mesa-lima」
のコンパイルに挑戦していますが、知識不足で、前方のカーネルのコンパイルとインストールができていません。
ぜひ、ROCK64でのカーネルのコンパイルの方法を教えてください!
*ヘッドホンジャックから音が何故か出ません!
この件についても教えてください!
*何かアドバイスがあったら、ぜひ返信をください!

インストール : 
sudo apt-get update
sudo apt-get install gradle openjdk-8-jdk libx11-dev xorg-dev
reboot
sudo ln -s /usr/lib/jvm/java-8-openjdk-arm64/lib/aarch64/libjawt.so /usr/lib/libjawt.so
git clone https://github.com/LWJGL/lwjgl
cd lwjgl
ant generate-all
ant compile_native
mkdir -p ~/.minecraft/natives
cp ~/lwjgl/libs/linux/liblwjgl.so ~/.minecraft/natives/
cp ~/lwjgl/libs/linux/libopenal.so ~/.minecraft/natives/
cd ~/
wget https://s3.amazonaws.com/Minecraft.Downl...ecraft.jar
起動時: 
export _JAVA_OPTIONS='-Djava.library.path=/home/rock64/.minecraft/natives/'
java -jar Minecraft.jar
楽しんでください!
  Reply
#2
Hi, to compile a kernel on the Rock64, check out this repo


Code:
git clone https://github.com/ayufan-rock64/linux-kernel


then

Code:
make rockchip_linux_defconfig

then 

Code:
make menuconfig

add the options you need and

Code:
make -j5

after that you should have everything built... building on the Rock64 will take quite some time if you dont have a heatsink and the cores get throttled, it should be around 40 minutes with good cooling...

Are you sure limadriver is already in a state that can be used for what you want to do? As opposed to mali?
Come have a chat in the Pine A64 IRC channel >>
  Reply
#3
(02-19-2018, 04:55 AM)xalius Wrote: Hi, to compile a kernel on the Rock64, check out this repo


Code:
git clone https://github.com/ayufan-rock64/linux-kernel


then

Code:
make rockchip_linux_defconfig

then 

Code:
make menuconfig

add the options you need and

Code:
make -j5

after that you should have everything built... building on the Rock64 will take quite some time if you dont have a heatsink and the cores get throttled, it should be around 40 minutes with good cooling...

Are you sure limadriver is already in a state that can be used for what you want to do? As opposed to mali?
Mali-450で、OPENGLを実行するためにはどうしても「linux-lima」ドライバーを使う必要があります。
私は、
git clone https://github.com/ayufan-rock64/linux-kernel
make rockchip_linux_defconfig
をした後、生成され「.config」ファイルを、「linux-lima」のディレクトリに上書きし、
make oldconfig
make -j5
をしましたが、なぜか一部のドライバーがコンパイルされませんでした。
それは、「-C」オプションをつけても無意味でした。
それと、その後、コンパイルされたカーネルは、どのようにインストールすればよいのでしょうか?
make install
を実行しても、エラーが出てしまいます。
何故?

Google Translate : 
With Mali - 450, you absolutely need to use 'linux - lima' driver to run OPENGL.
I,
git clone https://github.com/ayufan-rock64/linux-kernel
make rockchip_linux_defconfig
After doing, overwrite the generated ".config" file over the "linux-lima" directory,
make oldconfig
make - j 5
I did, but some drivers were not compiled for some reason.
It did not make sense to attach the "- C" option.
Also, how do you install the compiled kernel afterwards?
make install
Even if you execute, an error will appear.
why?
  Reply
#4
How did you change the .config exactly? Can you upload it to pastebin? Also upload the output of your kernel build...

Edit: I just saw that linux-lima is a mainline 4.13 source tree, so you better take the .config from ayufan's mainline kernel ( https://github.com/ayufan-rock64/linux-m..._defconfig), but 4.13.x is also too old for RK3328, the HDMI drivers you need for video output are probably arriving in 4.17.x or 4.18.x... so you need to forward port the linux-lima patches, from what I read in the issues in the git repo starting from " f0fddeaf1b7df4f1f7404155ad8b03a5190e5550 : drm/lima: init commit for adding lima driver" 


[url=https://github.com/yuq][/url]
Come have a chat in the Pine A64 IRC channel >>
  Reply
#5
(02-19-2018, 08:55 AM)xalius Wrote: How did you change the .config exactly? Can you upload it to pastebin? Also upload the output of your kernel build...

Edit: I just saw that linux-lima is a mainline 4.13 source tree, so you better take the .config from ayufan's mainline kernel ( https://github.com/ayufan-rock64/linux-m..._defconfig), but 4.13.x is also too old for RK3328, the HDMI drivers you need for video output are probably arriving in 4.17.x or 4.18.x... so you need to forward port the linux-lima patches, from what I read in the issues in the git repo starting from " f0fddeaf1b7df4f1f7404155ad8b03a5190e5550 : drm/lima: init commit for adding lima driver" 


[url=https://github.com/yuq][/url]


https://github.com/yuq/linux-lima/tree/l...rs/gpu/drm
https://github.com/yuq/linux-lima/tree/l...u/drm/lima

Apparently it seems just to compile this driver.
  Reply
#6
(02-19-2018, 08:55 AM)xalius Wrote: How did you change the .config exactly? Can you upload it to pastebin? Also upload the output of your kernel build...

Edit: I just saw that linux-lima is a mainline 4.13 source tree, so you better take the .config from ayufan's mainline kernel ( https://github.com/ayufan-rock64/linux-m..._defconfig), but 4.13.x is also too old for RK3328, the HDMI drivers you need for video output are probably arriving in 4.17.x or 4.18.x... so you need to forward port the linux-lima patches, from what I read in the issues in the git repo starting from " f0fddeaf1b7df4f1f7404155ad8b03a5190e5550 : drm/lima: init commit for adding lima driver" 


[url=https://github.com/yuq][/url]

When attempting to compile a DRM driver and a LIMA driver in "rock64", the following error occurred.
How can you solve it?
Please cooperate with me.


rock64@rock64:~/linux-lima-lima-4.13/drivers/gpu/drm$ sudo make -C
/lib/modules/4.4.77-rockchip-ayufan-136/build M=$PWD
CONFIG_ARCH_ROCKCHIP CONFIG_DRM
[sudo] password for rock64:
make: Entering directory '/usr/src/linux-headers-4.4.77-rockchip-ayufan-136'
make: *** No rule to make target 'CONFIG_ARCH_ROCKCHIP'.  Stop.
make: Leaving directory '/usr/src/linux-headers-4.4.77-rockchip-ayufan-136'
rock64@rock64:~/linux-lima-lima-4.13/drivers/gpu/drm$ sudo make -C
/lib/modules/4.4.77-rockchip-ayufan-136/build M=$PWD CONFIG_DRMmake:
Entering directory '/usr/src/linux-headers-4.4.77-rockchip-ayufan-136'
make: *** No rule to make target 'CONFIG_DRM'.  Stop.
make: Leaving directory '/usr/src/linux-headers-4.4.77-rockchip-ayufan-136'
rock64@rock64:~/linux-lima-lima-4.13/drivers/gpu/drm$ sudo make -C
/lib/modules/4.4.77-rockchip-ayufan-136/build M=$PWD
CONFIG_ARCH_ROCKCHIP=m CONFIG_DRM=m
make: Entering directory '/usr/src/linux-headers-4.4.77-rockchip-ayufan-136'
  CC      /home/rock64/linux-lima-lima-4.13/drivers/gpu/drm/drm_crtc_helper.o
/home/rock64/linux-lima-lima-4.13/drivers/gpu/drm/drm_crtc_helper.c:39:10:
fatal error: drm/drm_encoder.h: No such file or directory
 #include <drm/drm_encoder.h>
          ^~~~~~~~~~~~~~~~~~~
compilation terminated.
scripts/Makefile.build:258: recipe for target
'/home/rock64/linux-lima-lima-4.13/drivers/gpu/drm/drm_crtc_helper.o'
failed
make[1]: *** [/home/rock64/linux-lima-lima-4.13/drivers/gpu/drm/drm_crtc_helper.o]
Error 1
Makefile:1424: recipe for target
'_module_/home/rock64/linux-lima-lima-4.13/drivers/gpu/drm' failed
make: *** [_module_/home/rock64/linux-lima-lima-4.13/drivers/gpu/drm] Error 2
make: Leaving directory '/usr/src/linux-headers-4.4.77-rockchip-ayufan-136'
rock64@rock64:~/linux-lima-lima-4.13/drivers/gpu/drm$
  Reply
#7
I am pretty sure you can not build that module from mainline 4.13.x against a BSP kernel 4.4.77... as I said above, you have to cherry-pick the patches from linux-lima-4.13 and apply them to https://github.com/ayufan-rock64/linux-mainline-kernel/ ...
Come have a chat in the Pine A64 IRC channel >>
  Reply
#8
(02-23-2018, 10:26 AM)xalius Wrote: I am pretty sure you can not build that module from mainline 4.13.x against a BSP kernel 4.4.77... as I said above, you have to cherry-pick the patches from linux-lima-4.13 and apply them to https://github.com/ayufan-rock64/linux-mainline-kernel/ ...

I am getting this on 

$sudo make install:
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  CHK     include/generated/bounds.h
  CHK     include/generated/timeconst.h
  CHK     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
make[1]: 'include/generated/vdso-offsets.h' is up to date.
  CHK     scripts/mod/devicetable-offsets.h
  CHK     include/generated/compile.h
  CHK     kernel/config_data.h
/bin/bash ./arch/arm64/boot/install.sh 4.4.114-gccfa68a3e270-dirty \
arch/arm64/boot/Image System.map "/boot"
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.114-gccfa68a3e270-dirty /boot/vmlinuz-4.4.114-gccfa68a3e270-dirty
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.114-gccfa68a3e270-dirty /boot/vmlinuz-4.4.114-gccfa68a3e270-dirty
update-initramfs: Generating /boot/initrd.img-4.4.114-gccfa68a3e270-dirty
WARNING: missing /lib/modules/4.4.114-gccfa68a3e270-dirty
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: could not open directory /lib/modules/4.4.114-gccfa68a3e270-dirty: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
Warning: root device  does not exist
depmod: WARNING: could not open /var/tmp/mkinitramfs_AwXRHp/lib/modules/4.4.114-gccfa68a3e270-dirty/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_AwXRHp/lib/modules/4.4.114-gccfa68a3e270-dirty/modules.builtin: No such file or directory
Using DTB: rk3328-rock64.dtb
Couldn't find DTB rk3328-rock64.dtb in /usr/lib/linux-image-4.4.114-gccfa68a3e270-dirty or /etc/flash-kernel/dtbs
run-parts: /etc/initramfs/post-update.d//flash-kernel exited with return code 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
arch/arm64/boot/Makefile:54: recipe for target 'install' failed
make[1]: *** [install] Error 1
arch/arm64/Makefile:119: recipe for target 'install' failed
make: *** [install] Error 2

Could you describe how to apply the patches for this lib?
/lib/modules/4.4.114-gccfa68a3e270-dirty
  Reply
#9
(03-05-2018, 01:36 AM)jegb Wrote:
(02-23-2018, 10:26 AM)xalius Wrote: I am pretty sure you can not build that module from mainline 4.13.x against a BSP kernel 4.4.77... as I said above, you have to cherry-pick the patches from linux-lima-4.13 and apply them to https://github.com/ayufan-rock64/linux-mainline-kernel/ ...

I am getting this on 

$sudo make install:
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  CHK     include/generated/bounds.h
  CHK     include/generated/timeconst.h
  CHK     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
make[1]: 'include/generated/vdso-offsets.h' is up to date.
  CHK     scripts/mod/devicetable-offsets.h
  CHK     include/generated/compile.h
  CHK     kernel/config_data.h
/bin/bash ./arch/arm64/boot/install.sh 4.4.114-gccfa68a3e270-dirty \
arch/arm64/boot/Image System.map "/boot"
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.114-gccfa68a3e270-dirty /boot/vmlinuz-4.4.114-gccfa68a3e270-dirty
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.114-gccfa68a3e270-dirty /boot/vmlinuz-4.4.114-gccfa68a3e270-dirty
update-initramfs: Generating /boot/initrd.img-4.4.114-gccfa68a3e270-dirty
WARNING: missing /lib/modules/4.4.114-gccfa68a3e270-dirty
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: could not open directory /lib/modules/4.4.114-gccfa68a3e270-dirty: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
Warning: root device  does not exist
depmod: WARNING: could not open /var/tmp/mkinitramfs_AwXRHp/lib/modules/4.4.114-gccfa68a3e270-dirty/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_AwXRHp/lib/modules/4.4.114-gccfa68a3e270-dirty/modules.builtin: No such file or directory
Using DTB: rk3328-rock64.dtb
Couldn't find DTB rk3328-rock64.dtb in /usr/lib/linux-image-4.4.114-gccfa68a3e270-dirty or /etc/flash-kernel/dtbs
run-parts: /etc/initramfs/post-update.d//flash-kernel exited with return code 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
arch/arm64/boot/Makefile:54: recipe for target 'install' failed
make[1]: *** [install] Error 1
arch/arm64/Makefile:119: recipe for target 'install' failed
make: *** [install] Error 2

Could you describe how to apply the patches for this lib?
/lib/modules/4.4.114-gccfa68a3e270-dirty


Thank you for trying out various things.

By the way, what is a patch?
  Reply
#10
パッチはどのように当てて、どのようにコンパイルすればよいのでしょうか?
それがコンパイルできれば、「make install」をせず、ファイルを「/lib/modules/4.4.77-rockchip-ayufan-136」にコピーし、「depmod -A」を実行するのはだめなのでしょうか?

Google Translate :
How do you apply patches and how do I compile them?
If it can be compiled, is it not possible to copy "file" to "/lib/modules/4.4.77-rockchip-ayufan-136" without executing "make install" and execute "depmod-A"?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  First-Timer trying to set up a minecraft server Sothe 3 319 05-31-2019, 02:59 PM
Last Post: Luke
  Rock 64 seem like a dead end munocat 3 896 03-21-2019, 10:13 PM
Last Post: thewonderer
  Rock 64 network error as soon as I try to write or read. georgegohl888 1 270 03-12-2019, 09:35 AM
Last Post: georgegohl888
  Rock 64 a failure..very disappointed arxaios 5 1,414 11-02-2018, 07:29 AM
Last Post: Trash_Can_Man
  [Issue] All Rock leds are blinking Chispolas 6 1,411 04-18-2018, 09:12 PM
Last Post: pfeerick
  [Warning: root device does not exist] Can not install generic kernel on ROCK 64? pine3228 0 889 03-16-2018, 05:40 PM
Last Post: pine3228
Sad Rock 64 No video borisacomputers 4 841 03-03-2018, 03:11 PM
Last Post: borisacomputers
Wink My Stick of Rock digitaldaz 3 565 10-26-2017, 09:23 AM
Last Post: Luke
  Is the Rock 64 something strange? kometchtech 13 2,630 08-20-2017, 06:00 PM
Last Post: sjk
  Minecraft Server on Rock64 elienar 0 1,181 08-07-2017, 08:05 PM
Last Post: elienar

Forum Jump:


Users browsing this thread: 1 Guest(s)