My 1st post here on the pine64 forums.

ayufan Thanks for your work creating images!

I have a rock64 2GB running ayufan's 0.6.10 xenial minimal on a 16GB emmc. I'm using it as a router between my ISP and LAN. It's been running for 6 days without issue. I would like to convert the root filesystem to BTRFS so I can make a snapshot before upgrading to a newer version. Is anybody running BTRFS on their root filesystem, and is it stable?


It should work. Consider that BTRFS likes most recent kernels. You can use Mainline kernel quite well, but only if you care about headless support.

Rock/Pro 64/Pinebook Pro: LinuxChromium OS
So/Pine A64/Pinebook: LinuxAndroid 6.0Android 7.1

Buy me a Beer

Thanks for the reply. I'm currently running the 4.4 kernel, but graphics are not needed for this router, so installing the 4.14 kernel would not cause any pain. - When I get some time I will give it a try. The conversion from ext3/4  is easy, but setting it up for rollbacks will take some work.

I run opensuse on my other computers and really like the ability to roll back when something goes wrong. I wasn't able to locate an opensuse image to flash, so I settled on ubuntu. Some people are working on an opensuse image here

there is this,
it's about 10 months old but i used it for awhile and it worked well. only issue i had were was update process.
I'm using btrfs in raid1 config with two devices: eMMC and SD card. It sacrifices performance, obviously, but if one of the two goes bad, at least I'll still have my rootfs.

Best to run latest kernel, but I'm running 4.4 from ayufan, because 4.15rc3 from ayufan mainline is not booting form me (mmc error -5 -- see the thread on mainline). Btrfs has been ok on 4.4 so far.
I put together a headless  Arch Linux image for the rock64 if you like, with a btrfs root
(01-13-2018, 10:11 AM)ayufan Wrote: It should work. Consider that BTRFS likes most recent kernels. You can use Mainline kernel quite well, but only if you care about headless support.

Hi ayufan,

since usb3 (uas driver) with latest legacy kernel 4.4.77-rockchip-ayufan-136 is still not working reliably under heavy disk load on my rock64 (4GB RAM; I already checked chipset of enclosure and power supply issues), I wanted to use mainline kernel 4.18 (4.18.0-rc8-1060-ayufan-g45828c4db727) instead to make full usage of usb3 capabilities of my rock64. For better performance and the possibility to make snapshot backups I would like to run rootfs on btrfs.

Unfortunately it doesn't work. I already installed btrfs-tools and updated initramfs, but still the boot process fails and ends in an infinite boot loop, rebooting about every 60 seconds. I think rootfs is not available (timely) during boot process, but initramfs should contain all necessary modules and rootwait is given as a boot attribute in /boot/extlinux/extlinux.conf. I am running out of ideas how to get it work.

Could you give me some advice how to get it work? Or will there be a patch for the legacy kernel in order to provide stable usb3 capabilities? Thanks a lot for your work!
I am a fan of btrfs as well. OpenSuse have done a nice job of implementing rollbacks in their latest releases using snapper. But using snapper in other distros is hard as far as I can tell. With so many updates coming to our favourite linux distro we could benefit from something like this. Faced with a large number of updates recently, I used snapper to capture a snapshot of the system. When it failed to boot, I was able to use the rescue system to get to a prompt and log in. Using snapper I then rolled back to this working snapshot. It booted ok and seemed to work, but I lost all of my snapshots and snapper was not working. I had landed in root file system that was an orphan. It was isolated.

Anyone have thoughts on this - especially further down - file system layout?

Possibly Related Threads…
Thread Author Replies Views Last Post
  arch linux with btrfs root wilsonYan 1 1,731 01-16-2018, 05:14 AM
Last Post: Luke

Forum Jump:

Users browsing this thread: 1 Guest(s)