Constant crash Xenial minimal - help much appreciated
Hi guys,

First of: love the Rock64 so far, very happy running the ayufan Xenial minimal.

I was a bit hesistant about buying the Rock64 due to it being a relatively new device, but was convinced due to what seems like a vibrant user community being built here. The community pages proved to be very helpful in setting up the device, thanks for that!

I did a search in the forum on my specific issue and could not find a direct solution - apologies in advance if it turns out to be a rookie / easy mistake. I have working knowledge from tinkering with Linux over the past 15 years, but am definitely not an expert.

My setup:

- Rock 64 on the official power supply (running on a US to EU power converter however).

- Running Ayufan Xenial minimal on a 16GB micro SD card.

- Aukey USB powered hub:

- Three Seagate Expansion Portable 4TB drives linked to the USB hub:

- Very limited software installed (Docker, vsftp)

What happened:

I tried setting up my three external harddrives in RAID 0, following this tutorial:

In the middle of the tutorial, the device crashed (no error message on screen through putty).

I connected the Rock64 to a monitor (figured at first there was a problem with the network connection) and saw it crashing in 'real time' (while I was not taking any user actions). I took a few pictures (attached to this post). I looked at syslog and the last error there is from a few hours before the crashed. Happy to post any other logs.

In essence, it seems there are a few read/write errors on my external disks and then the device crashed. I plugged out the USB hub and the crashing stopped, so the error is likely connected to the drives.

I took a good look at one of the overview forum posts ( and I think my issue might be linked to undervoltage. Is there any way to check that? I thought my powered HUB was strong enough to handle all three drives, but please correct me if I'm wrong.


[Image: 1.jpg]
[Image: 2.jpg]
[Image: 3.jpg]

Any help appreciated!
By way of update: this is fixed now. Seems there was an error with my drives, perhaps faulty configuration of the RAID setup.

Steps taken to resolve:
1. unplug all external hard drives from the powered HUB
2. insert drive 1: set new partition table (sudo parted /dev/sd[?] mklabel gpt) - repeat for two other drives
3. remove the previous RAID 0 array (see under "Resetting Existing RAID Devices")
4. install new RAID 0 array (see under "Creating a RAID 0 Array")

Later edit: this did not do the trick, see below for second attempt at a fix.
Hey Freeloader, have you updated everything prior to your HD expansion?

sudo apt-get update -y

sudo apt-get install linux-rock64 -y
have you seen this, if not, you might get some ideas from it,
Unfortunately, the fix above didn't completely do the trick.

@Rustproof: yes, I did a full system update and upgrade prior to putting these disks in RAID 0.

@dkryder: much appreciated, I took up on that idea and played around with it a bit further, but no luck so far. The three disks are brand new and the smartctl command turned up no flaunts. I don't think these are bad disk sectors.

I am now loading each drive separately (no raid) and for now I don't seem to have any further crashes. That seems to suggest two things: (1) it's likely not an undervoltage issue given that the three disks are connected to the hub without problems, and (2) it's likely something to do with the fact that the disks are placed in RAID.
By way of update: the problem is not so much with connecting the hard drives, but starts as soon as I mount these drives. My hypothesis is that Seagate stores a bunch of stuff on the first (boot) sectors of the hard drives which causes I/O errors. The drives had two partitions on them out of the box: a 128MB partition and a second partition with the remainder of the drives.

Attempt #2 (repeated for each HD): set up a new partition table and start the new partition after the first 128MB. Alternatively, you could zero the first 128MB of the drives -- my guess is that would work the same (while wasting less space), but I wanted a quick workaround.

Step 1: find drive identifiers

Drive will show up as /dev/sda or similar.

STEP 2: create new partition table
sudo parted /dev/sd[?] mklabel gpt

STEP 3: boot up parted
sudo parted --align optimal /dev/sd[?]

STAP 3: partition starting at 1% (using percentages to ensure optimal alignment -- you could also zero the first 128MB and save more space by starting the partition at 0%)
mkpart primary ext4 1% 100%

STAP 4: check
align-check optimal 1

STAP 5: stop parted

I'll get back if that does not work.

Later edit: confirmed, this solved it.
Glad to hear that you've managed to solve the problem.

I have been using Ayufan's images on My Rock64 and it is running almost 7x24 hours without hardly a glitch. 

My powered USB 3 hub is not even a branded one but it does the job well. I am not on RAID though. Anyway here is my setup:

2GB Rock 64
Stock power supply for Rock64
Unbranded powered USB3 hub
500GB Seagate HDD where the Linux file system is 
4TB WD My Passport Ultra USB 3.0 drive.

Software installed:
Ayufan's Ubuntu Bionic Beaver release 18.04 (Linux rock64 4.4.103-rockchip-ayufan-152)
(I have tried his other images as well and they are fine. )
NginX server
PHP server
rTorrent server
Samba server
Mariadb server

Attached Files Thumbnail(s)
Are you using LVM or similar?
(01-02-2018, 02:17 AM)freeloader Wrote: Are you using LVM or similar?

No, I am not.

Possibly Related Threads…
Thread Author Replies Views Last Post
Sad Rock64 crash randomly during usb 3 copy with RAID1 drive phalae 24 36,286 09-14-2020, 10:48 AM
Last Post: BrownLuther007
  How to get a minimal Debian system started? musbur 3 4,323 02-07-2019, 11:50 AM
Last Post: musbur
  Arch Linux minimal image w/ full HDMI output support hiccupstix 1 3,738 11-01-2018, 08:33 AM
Last Post: danboid
  Xenial Mate + Emmc Guettt 2 3,283 05-31-2018, 02:49 AM
Last Post: pas059
  compiling meteor on xenial-minimal-rock64-0.5.15-136-armhf.img.xz maudy 0 1,960 05-02-2018, 05:35 PM
Last Post: maudy
  Crash/Hardlock on boot audiohacked 0 1,672 04-13-2018, 02:31 PM
Last Post: audiohacked
  Rock64 Xenial Mate Community Build Image [microSD to eMMC] [0.5.15-136] Guld 6 7,856 03-14-2018, 08:26 PM
Last Post: colgs3b
  bringing up X on minimal stretch install gene83 11 12,382 03-05-2018, 01:47 AM
Last Post: jegb
Question stretch-minimal with static IP and GUI RDC skipper 1 2,688 11-24-2017, 03:45 PM
Last Post: dontpostalot
  Rock64 crash - spinlock lockup suspected on CPU (possibly thermal reason) JoeH 2 3,984 11-17-2017, 04:49 AM
Last Post: dkryder

Forum Jump:

Users browsing this thread: 1 Guest(s)