Launching a terminal app from command line
#4
(09-28-2017, 01:14 AM)dahni Wrote:
(09-22-2017, 03:32 PM)Siliconserf Wrote:
Code:
Version=1.0
Name=Manuskriptlauncher
mate=terminal -- working-directory= .. -e 'manuskript=develop/bin/manuskript'
this code doesn't make any sense.
please show us the complete content of the .desktop file in question.

Thanks for posting. The only missing line is "exit" at the end. So, the code posted was it. However, I edited the file to be just this:

~/manuskript-develop/bin/manuskript

That works. I still get an exit status message I don't want to see, but it works.

Once I got to that point I added a line that mounts googledrive:

google-drive-ocamlfuse ~/googledrive
~/manuskript-develop/bin/manuskript

I tried putting the mounting command into system startup script, but that seems to cause a problem which I attribute to the wi-fi connection not being completed before the mount command is executed. In any event, my next adventure in command line programming will be to set up issuing a command mounting the googledrive only if it isn't already mounted (just to get rid of the pesky error messaging about needing to unmount a drive before trying to mount it. It would be simpler, I suppose, to put the google mount command in another desktop file and invoking it when I need to use a program that needs to look at files there, but that wouldn't be as much fun.
"Get your facts straight first, then distort them as you wish." -- Mark Twain
  Reply


Messages In This Thread
RE: Launching a terminal app from command line - by Siliconserf - 09-28-2017, 12:36 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] How to poweroff PBP from Linux terminal? mx43 1 981 03-21-2020, 12:49 PM
Last Post: tllim
  KNOWING how to properly use the "dd" command. chessie 5 1,788 04-29-2019, 12:59 AM
Last Post: erchache2000
Information i3wm xenial-i3 introduction -- mate terminal & battery monitor MarkHaysHarris777 4 2,935 08-31-2017, 04:47 AM
Last Post: shirman

Forum Jump:


Users browsing this thread: 1 Guest(s)