solved: ROCK64 Stereo Audio POT-Board anyone having success getting sound?
#1
Thumbs Up 
Hello everyone,

Last Monday I received my Rock64 including the ES9023 Audio POT-Board. Till now I don't have any success getting audio out of this board. aplay -l lists 3 cards. Card 1 is i2s device. I tried speaker-test, aplay  and mpd but and don't get any sound or error.

For example: 

Code:
speaker-test -c2 -D hw:1,0

claims to play noise but nothing is heard. Audio-Pot board is connected to a small Class-D amplifier with speakers. I am using ayufan's debian stretch minimal image. 


Did anyone got any sound out of the Audio-POT-Board? If yes: Which image/settings where used?

Thanx for your help.
  Reply
#2
No luck so far but I'm certainly not a linux guru. Installed Amarok, tried to see if I could set the output to the optical SPDIF but nothing works.  Haven't tried it on Xenial. Been playing with Debian LXDE load. I hope the answer isn't that until a volumio load is made the DAC won't be operational.
  Reply
#3
More testing, same results. Can't get audio out via audio jack, RCA connections on DAC, optical on DAC or HDMI. I spent some time reading Pine64 sound threads. Seems it took some tweaking in order to get audio to work. People referred to mixer settings in alsamixer. Fired that up, "this device has no settings" for all three of the audio outputs available. I'll keep digging but if anyone has definitive answer on whether I should be able to put my headphones on, fire up a favorite .flac file and listen to music while I'm tinkering I'd like to know. If it's dependent upon kernel/package stuff out of my control I understand and know there are other priorities. Just need to know if I'm banging my head against the wall and could save time by just waiting for the experts to weigh in. Thanks.

Tried Xenial Mate, stock Debian - same thing on both. Haven't tried Android but will.
  Reply
#4
you might want to search the chat logs to see if there has been any meaningful discussions on the status of the board. the time i spent reading logs during the build up to first sales did not have any info i can remember. but, in some cases those logs have discussions about stuff that can not be found elsewhere.
  Reply
#5
Will do. In the meantime, Android sound works on the stock build. I mainly wanted to prove the DAC was working so connected RCA cables to my receiver. "It's alive!" Didn't check the optical, I will eventually but was glad to hear output from the RCA jacks. While music was playing I plugged in headphones to the audio jack. The RCA output wasn't muted but I did hear sound from the headphones so that jack is operational too. I remember reading something about that being an issue. For now, I'm thinking the linux builders haven't gotten to includiing the audio pieces yet. I'll keep playing.
  Reply
#6
The latest 0.5.x does output sound.

Kwiboo on IRC:

Code:
RockyBoulder Xalius: the audio POT board should work including spdif, but at the moment there are some limitations on the i2s bus and the J3 jumper needs to be changes to use 50M OSC

[7:02 PM]
I need to write a simple codec driver for i2s that allows correct sample rates, channels and sets mclk that works with es9023 for full function

[7:09 PM]
RockyBoulder APP Kwiboo: 50 M OSC? There is none included, right? Do you can recommend one? I don't have one.

[7:15 PM]
Kwiboo APP RockyBoulder you should only need to change a jumper on the board, check https://www.pine64.org/wp-content/uploads/2017/06/ROCK64_audio_board_bottom.jpg (50kB)
in the middle 50M and MCLK it need to connect 50M and the middle pin instead of the middle and MCLK

[7:19 PM]
RockyBoulder APP Kwiboo: Thank you I checked the schmatics and found that the OSC is onboard. Thought i had to connect it through this white header. Changed j3 to use the osc and got sound with speaker-test -c2 -D hw:1,0 Now to more testing. Thank you!

[7:22 PM]
Kwiboo APP at the moment it is limited to up to 96khz and not 192khz because that is the limit of the acodec that is used for the on-board a/v jack
Homepage: https://ayufan.eu

Releases:
Rock/Pro 64/Pinebook Pro: LinuxChromium OS
So/Pine A64/Pinebook: LinuxAndroid 6.0Android 7.1

Buy me a Beer
  Reply
#7
Thanx to ayufan and Kwiboo audio pot is now useable (some limit). 

Hardware volume mixer is not available at the moment (don't now if this will change/ is even available).

Therefore software volume mixer is an option. 

This is what I use if aynone is interessted (copy to /etc/asound.conf):


Code:
pcm.!default {
   type             plug
   slave.pcm       "rock_audio_pot"
}

pcm.rock_audio_pot {
   type            softvol
   slave {
       pcm         "hw:1"
   }
   control {
       name        "Master"
       card        0
   }
}
  Reply
#8
How good is the audio quality?

Also wondering if it only works on Volumio or everything like youtube, retropie...
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  1wire DS18b20 on Rock64? mypineme 5 1,843 09-22-2021, 08:42 AM
Last Post: Rocky64
  Rock64 4K60P HDR Media Board Computer 64 bit MarkHaysHarris777 8 8,854 07-14-2021, 11:52 PM
Last Post: jontumontu
  Any way to tell the rock64's hardware revision? kittyland 1 367 07-01-2021, 09:42 PM
Last Post: evilbunny
  Configuring Python GPIO Pin Control Rock64 www139 3 3,758 06-22-2021, 06:57 AM
Last Post: Mrfixit2001
  POE support for the Rock64 v3 h64poe 0 368 05-30-2021, 07:40 AM
Last Post: h64poe
  3D-Printable Button Pegs for the ROCK64 Aluminium Case CounterPillow 1 563 05-21-2021, 05:44 PM
Last Post: tllim
  How to enable ES9023-based DAC hat on Rock64? lowry 2 803 03-18-2021, 03:44 PM
Last Post: zborgerd
  Display options for the Rock64 joey49 1 1,286 11-23-2020, 09:52 AM
Last Post: joey49
  Help connecting a dvb board in the right gpio pins cosmodeal 0 829 11-11-2020, 12:48 PM
Last Post: cosmodeal
  Are HW design files available for ROCK64? irenek 1 1,623 09-29-2020, 05:57 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)