Disable pinch-to-zoom in chromium
#1
Hello.

I'm using pinebook for a few weeks and stuck with unwelcome featue - pinch to zoom event during ordinary scrolling with to fingers.

Chrome resizes page (very slow on big webpages) and it's very annoying.

Can I disable this behaviour?

I disabled touch events in chrome, but it wasn't helps - pinch-to-zoom still active.

I can't find any appropriate utility to configure pinebook's touchpad. Looks like it isn't synaptic (synclient said - no synaptics driver loaded).
  Reply
#2
(07-23-2017, 03:24 AM)angry_elf Wrote: Hello.

I'm using pinebook for a few weeks and stuck with unwelcome featue - pinch to zoom event during ordinary scrolling with to fingers.

Chrome resizes page (very slow on big webpages) and it's very annoying.

Can I disable this behaviour?

I disabled touch events in chrome, but it wasn't helps - pinch-to-zoom still active.

I can't find any appropriate utility to configure pinebook's touchpad. Looks like it isn't synaptic (synclient said - no synaptics driver loaded).


Make sure you have the latest pinebook image;  there are some fixes to the touchpad which adjust its sensitivity and make it less annoying.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#3
(07-23-2017, 03:24 AM)angry_elf Wrote: Chrome resizes page (very slow on big webpages) and it's very annoying.

Can I disable this behaviour?

Yes, you can install the No MouseWheel Zoom extension for Chrome (big thanks to longsleep for mentioning it a few months ago Wink)
  Reply
#4
Huh, I wasn't able to get that Chrome extension to work for me (update: working after a Chromium restart). I wonder why. It seems like it should... just traps the Ctrl+ mousewheel combo that the trackpad is sending yeah?

I found this technique interesting https://ubuntuforums.org/showthread.php?t=2354717 but couldn't get it to work for me... disabling the extra keyboard devices just disabled my actual keyboard, ha. (if you do this yourself, Applications->Universal Access->Onboard will let you fix without a restart)

are there any registers in the H2168 that we could adjust to disable the gesture? I can't find a datasheet for it... the datasheet for the HK-9562 on the Pine site is a good start but mostly focused on dimensionals, doesn't mention much about the controller.
  Reply
#5
Just a quick test with evtest and xev confirm that it's the USB keyboard device which also does the normal key presses this sending the CTRL, while the other "USB keyboard" is the actual touchpad which then sends the mouse wheel events. Which explains why your keyboard also stops working.


@Mark: Got a link to the patch(es) that improved the touchpad? Would make a start point for finding out how to disable this properly.
  Reply
#6
Based on this information it seems that there is no Linux way to disable it.
  Reply
#7
(08-09-2017, 02:36 PM)hene Wrote: Based on this information it seems that there is no Linux way to disable it.

Well... I remember speculation that it could potentially be disabled in the kernel - what I mean by this is to prevent the system on kernel level registering those 'key-presses'. I remember that it was ruled out as a solution a long time ago; I do not recall why.
You can find me on IRC, Discord and Twitter


  Reply
#8
If you'll check the htop output, you will see that there is special option for chromium --enable-pinch
[Image: O754fFt.png]

Try to run it with --disable-pinch? Or just try to edit shortcut?
  Reply
#9
Yes!! That worked for me.

The /usr/bin/chromium-browser wrapper shell script also accepts --no-touch-pinch, but all that does is OMIT --enable-pinch... it doesn't ADD --disable-pinch. And I guess the default is enabled in the current Chromium, because omitting --enable-pinch doesn't do the trick.

So I just added --disable-pinch to the Chromium shortcut and all is well.

many thanks!
  Reply
#10
(08-13-2017, 04:48 PM)shirman Wrote: If you'll check the htop output, you will see that there is special option for chromium --enable-pinch
[Image: O754fFt.png]

Try to run it with --disable-pinch? Or just try to edit shortcut?

Nicely done!  Smile
You can find me on IRC, Discord and Twitter


  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Chromium OS? Devilotx 4 1,767 01-31-2019, 03:19 AM
Last Post: soupbowl
Music Problems using Spotify Web version because DRM (Firefox & Chromium) Ekkaia 6 1,626 09-07-2018, 02:23 AM
Last Post: JerrySmith1021
  Disable Bottom Part of Touchpad (where the buttons are)? dahni 1 433 09-28-2017, 12:46 AM
Last Post: dahni
  Installing VS Code (& Chromium) Prophesi 21 5,157 09-13-2017, 03:27 PM
Last Post: DigitalStefan
  Chromium for Q4OS q4osteam 0 604 06-21-2017, 08:09 AM
Last Post: q4osteam

Forum Jump:


Users browsing this thread: 1 Guest(s)