[Jan 06] Arch Linux (20171225-1) PINE A64(+) Pinebook A64-LTS/SOPINE | [Jan 04] Linux (0.5.15-136) ROCK64 | [Jan 04] Android (20171204) ROCK64 | [Dec 22] Stretch Mate (0.5.15-136-20171222) ROCK64 | [Dec 21] openHAB 2 (v1.4) PINE A64(+) | [Dec 11] Volumio (2.315) PINE A64(+) A64-LTS/SOPINE | [Dec 11] Armbian (5.35) PINE A64(+) Pinebook A64-LTS/SOPINE | [Dec 8] OpenMediaVault (0.5.15-136) ROCK64

Getting Started | Visit the WIKI | IRC Logs | Forum Rules/Policy


touchpad edges scrolling
#1
Sad 
Hi, After testing Pinebook for a few days, I realized that the touchpad does not respond as well as I want (I know that I could use a usb mouse) the problem is that when using two fingers sometimes the system thinks I want to zoom and not Scroll, the temporary solution I have found for Firefox and Chrome is to edit the value of mousewheel.with_control.action in about: config and use some plugin to disable zoom using the touchpad respectively. I still think it would be more convenient to configure the touchpad to scroll from edges instead of using two fingers, but I cann't do it from dconf or xorg.conf
Reply
#2
I'm looking into this as well, have subscribed to this thread to see if others are making progress. From my perspective, this is a possible accessibility issue.
Reply
#3
I believe a part of the issue is that the trackpad is recognised as a mouse (or keyboard/mouse combo) in linux, and hence trackpad settings are not accessible. We have talked about this at length a good while back in the IRC (please check logs) - needless to say, we didnt come up with a solution then. Perhaps its time to take another look into this ...
  If you manage to click this link you'll join in the IRC channel
Reply
#4
i have no idea how successful you might be in setting up a touchpad on ubuntu, for example, but my laptop offers a good feature set on an ubuntu install. here is a manpage link for a synaptics driver.
http://manpages.ubuntu.com/manpages/trus...ics.4.html
Reply
#5
(06-29-2017, 09:02 AM)Luke Wrote: I believe a part of the issue is that the trackpad is recognised as a mouse (or keyboard/mouse combo) in linux, and hence trackpad settings are not accessible. We have talked about this at length a good while back in the IRC (please check logs) - needless to say, we didnt come up with a solution then. Perhaps its time to take another look into this ...

I looked at this myself with xinput and didn't see any way to distinguish the keyboard from mouse. Unless the driver offers more configurable options that can be played with (maybe it'd be possible to turn pinch-to-zoom off completely?) I'm not sure what can be done outside of configuring specific apps that can ignore the action (like Firefox).
Reply
#6
(06-30-2017, 12:54 AM)jordanjay29 Wrote:
(06-29-2017, 09:02 AM)Luke Wrote: I believe a part of the issue is that the trackpad is recognised as a mouse (or keyboard/mouse combo) in linux, and hence trackpad settings are not accessible. We have talked about this at length a good while back in the IRC (please check logs) - needless to say, we didnt come up with a solution then. Perhaps its time to take another look into this ...

I looked at this myself with xinput and didn't see any way to distinguish the keyboard from mouse. Unless the driver offers more configurable options that can be played with (maybe it'd be possible to turn pinch-to-zoom off completely?) I'm not sure what can be done outside of configuring specific apps that can ignore the action (like Firefox).

So I looked in the log (see from 06-05-2017 -> 11-05-2017

Quote:06:16:16 <tllimhttp://files.pine64.org/doc/datasheet/pi...cation.pdf 

06:16:44 <tllimhttp://files.pine64.org/doc/datasheet/pi...cation.pdf 

Those are the tech sheets. The gestures are actually key combinations (so the system thinks a key combo is pressed) works over i2c. 


Quote:14:47:10 <itdaniher> it looks like an i2c (not usb) module, so it's possible there's a way to adjust settings in the mentioned eeprom at a lower level than is exposed via pinebook hardware 
 
IIRC, one option would be to block the particular combination for zoom +/- in the kernel - but neither longsleep nor ayufan found that to be a valid solution at the time.
  If you manage to click this link you'll join in the IRC channel
Reply
#7
How do we enable natural scrolling on the pinebook? In other words how do we invert scrolling from the touchpad?
Reply
#8
(06-29-2017, 04:52 AM)kurai021 Wrote: Hi, After testing Pinebook for a few days, I realized that the touchpad does not respond as well as I want (I know that I could use a usb mouse) the problem is that when using two fingers sometimes the system thinks I want to zoom and not Scroll, the temporary solution I have found for Firefox and Chrome is to edit the value of mousewheel.with_control.action in about: config and use some plugin to disable zoom using the touchpad respectively. I still think it would be more convenient to configure the touchpad to scroll from edges instead of using two fingers, but I cann't do it from dconf or xorg.conf

What plugin did you use to disable pinch zoom in Chromium? I have tried everything but cant for the life of me get this annoying zoom thing to go away.
Reply
#9
(06-29-2017, 04:52 AM)kurai021 Wrote: Hi, After testing Pinebook for a few days, I realized that the touchpad does not respond as well as I want (I know that I could use a usb mouse) the problem is that when using two fingers sometimes the system thinks I want to zoom and not Scroll, the temporary solution I have found for Firefox and Chrome is to edit the value of mousewheel.with_control.action in about: config and use some plugin to disable zoom using the touchpad respectively. I still think it would be more convenient to configure the touchpad to scroll from edges instead of using two fingers, but I cann't do it from dconf or xorg.conf

I have the same problem. It's sometimes unbearable. 
Excuse but my english is not very fluent and I don't understand what is the solution ? An application to block the zoom ?

Thanks.
Reply
#10
For chrome you can download a plugin (as explained by longsleep here) and in Firefox you can prevent mouse-wheel scrolling or disable zoom (as described here)
  If you manage to click this link you'll join in the IRC channel
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Proof of concept script to disable the touchpad while typing daid 20 886 11-24-2017, 10:51 AM
Last Post: southern.cross
  Disable touchpad tap to click? colin.faulkingham 15 845 08-04-2017, 09:36 PM
Last Post: MarkHaysHarris777

Forum Jump:


Users browsing this thread: 1 Guest(s)