Joystick/Gamepad support
Hello all, first time noob posting...

I've just got the Pine64+ 2GB model, installed the latest Debian XFCE image and did all of the updates suggested. I've successfully installed XMAME following this tutorial and now I'm trying to configure a gamepad to work with it. I've tried 2 separate USB devices, one is a PS2/PS3 compliant device and the other one is a DragonRise gamepad, but unfortunately both of them didn't work.

Here's the log from dmesg when I connect a gamepad:
[ 1299.821184] ehci_irq: highspeed device connect
[ 1299.948456] ohci_irq: fullspeed or lowspeed device connect
[ 1300.342055] usb 3-1: new full-speed USB device number 3 using sunxi-ohci

Here's an output from lsusb:
Bus 004 Device 002: ID 1997:2433  
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 054c:0268 Sony Corp. Batoh Device / PlayStation 3 Controller

...but there's no device detected in the /dev/input/ folder (/dev/input/js0 is missing). I've tried "cat" and "evtest" on every /dev/input/eventX device, but with no luck. I can see that both the "joydev" and "evdev" modules are built in, and I've installed the "joystick" and "xserver-xorg-input-joystick" packages, but nothing seems to help.

As I've seen on a Gentoo forum post, I've looked at /usr/src/linux-headers-3.10.102-2-pine64-longsleep/.config and I found that



# CONFIG_HID_SONY is not set I guess this is the problem the system isn't detecting the gamepad devices. Now, I guess I need to somehow enable kernel support for those two, but I have no idea how and it doesn't seem like a one-liner...

Can anyone give me pointers or help?
Try sudo apt-get install linux-firmware
Haven't tried a gamepad on my Pine yet, as I don't have spare time these days.
(08-10-2016, 09:52 AM)CaptainZalo Wrote: Try sudo apt-get install linux-firmware
Haven't tried a gamepad on my Pine yet, as I don't have spare time these days.

firmware-linux-free is already the newest version.
firmware-linux is already the newest version.
firmware-linux-nonfree is already the newest version.
firmware-misc-nonfree is already the newest version.
...already installed all of the firmware packages.
If the kernel modules are not enabled you can maybe ask longsleep to include them in his next kernel build, see thread here: or you could try and follow the instructions in the first post to download the sources and build your own updated kernel based on the current config and with the missing modules enabled.
Come have a chat in the Pine IRC channel >>

Possibly Related Threads…
Thread Author Replies Views Last Post
  Programming languages support under PINE64 baryluk 6 12,202 09-23-2020, 11:46 PM
Last Post: Phillip Bell
  AXP803 Battery Charger Support xalius 14 23,891 12-22-2017, 08:59 AM
Last Post: Velociraptor
Wink Pine64 Will support Freenas or openmediavault ? joe 1 4,947 04-13-2017, 07:44 AM
Last Post: xalius
  Remote Desktop Support? Rochambeaux 20 29,038 10-01-2016, 05:08 PM
Last Post: HayseedGeek
  Binfmt_misc support cztian 1 3,679 08-17-2016, 11:49 PM
Last Post: longsleep
Big Grin Funny ! Support Intel x86 linux applications on ARM-based ( PINE64 ) not freeware joe 10 16,274 08-09-2016, 05:59 PM
Last Post: dkryder
  Camera support - Ubuntu Xenial 16.04 LTS @lex 3 5,171 08-07-2016, 03:47 AM
Last Post: romansavrulin
  Virtualization Support soccercheng 12 17,278 07-14-2016, 11:04 AM
Last Post: mont3z
  distro with kernel support for DVB-T dongles? mkaut 2 4,582 07-02-2016, 02:36 PM
Last Post: mkaut
  XFS Support? utdrmac 2 3,315 06-30-2016, 01:44 AM
Last Post: longsleep

Forum Jump:

Users browsing this thread: 1 Guest(s)