Accidentally Erased internal SD memory
#1
Dear Pine64 Community,

Unfortunately, I made a mistake while trying to install a new operating system on my PineTab and accidentally erased the BIOS (UEFI). Here are the details of what happened:

What Happened:
  • I was in the process of installing a new operating system on my PineTab and inadvertently followed the wrong steps, resulting in the internal drive, including the BIOS, being completely wiped.
  • The device now fails to boot, and I have no access to the BIOS to attempt to troubleshoot the issue.
What I've Tried:
  • I attempted to boot the device from a bootable SD card, but without success.
  • I also tried starting into MASKROM mode, to no avail. (the adapter shows lights, so it is active)


Any suggestions, tips, or guidance would be greatly appreciated. Thank you in advance for your assistance!
  Reply
#2
I'm assuming you have a PineTab2. Follow these instructions; insert a bootable SD card and use the "SD BOOT MASKROM" switch on the adapter to force it to boot from the SD card. That should work regardless of what you have on the SPI/eMMC.

IMPORTANT: Make sure that the SD card image you are using has it's own U-Boot image. If you try to use e.g. a Mobian SD card, it won't work for you because it expects you to have an existing U-Boot installation on the SPI/eMMC (which you had previously accidentally wiped).

In case you have a PineTab1 it's actually even easier; it will automatically boot from the SD card if it has a valid OS+U-Boot image on it.
  Reply
#3
Hi Pavlos1, thank you for your response.

I have tried as you suggested, I downloaded Rhino Linux, the Pine64 PineTab2 version and made a bootable SD card with Balena etcher which gave me issues, so I stepped over to Rufus.

Once it was completed I tried using the adapter as followed:
1. Plug in with SD BOOT MASKROM on
2. Add power to the adapter
3. Everything lights up on the adapter, all 3 LEDs
4. Power on does not respond, only a black screen.

Perhaps the issue lies with not correctly mounting on the SD card, so I'm going to try again with Ubuntu touch.

Any further reccomendations are always welcome.
  Reply
#4
Have a look at the UART boot logs as well.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Lightbulb Tutorial: (Internal SDR) Adding External Threaded Antenna Port RTP 2 3,402 02-20-2021, 06:43 PM
Last Post: RTP
  Enabling internal USB expansion power geeksville 3 5,723 10-29-2020, 05:12 PM
Last Post: geeksville

Forum Jump:


Users browsing this thread: 1 Guest(s)