Using the internet
#1
I have Pine with the 2GB board and a wifi/bluetooth board. I 'm using Debian Linux OS.  I can't get to any pages on the internet even though I can connect to my cable modem/wifi router using wifi.  The browser tells me "not connected to the internet." I'm a Linux rookie. Can anyone give me a hint.
Tom Arneson
  Reply
#2
hi tom arneson,

Usually, this is because your system does not have proper access to a nameserver.

... Usually your system will get the nameserver info at the same time as the ip address from the dhcpd server. You could try

sudo route

... to see if there is a route to your router 192.168.1.1 (typically) and you could try looking at

cat /etc/resolv.conf

... to see if you have a nameserver configured (sometimes its also your router... which forwards on to a main server)

Without name services (bind) you will not get ip to name resolution and no pages will come up on your browser unless you give the ip address directly.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#3
I attached screenshots of the results of your suggestions.  I'd appreciate suggestions


Attached Files Thumbnail(s)
       
Tom Arneson
  Reply
#4
hi Tom,

This is kinda typical for Comcast; they often use the 10.0.0.1 address for the gateway address; however, I thought that the 10.0.0.1 was a class A network , so would need a netmask of 255.0.0.0 (yours shows the netmask set to 255.255.255.0 which is a class C netmask.

So, things may not be working because of the netmask being incorrect ; possibly, please don't hold my feet to the fire. Comcast is a strange animal.

(anyone else is free to chime in here too)

You might want to take a look at other machines on your network, and compare their gateway addresses, netmask, and nameserver information. How do they compare?
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#5
Here's what Windows 10 tells me on my desktop:

SSID: viking42
Protocol: 802.11n
Security type: WPA2-Personal
IPv6 address: 2601:440:c300:9970:61cc:f5d1:eebb:ef47
2601:440:c300:9970:a14d:c22:ad05:107c
IPv6 DNS Servers: 2001:558:feed::2
2001:558:feed::1
IPv4 address: 10.0.0.7
IPv4 DNS Servers: 75.75.76.76
75.75.75.75
Manufacturer: Netgear
Description: NETGEAR WNA3100 N300 Wireless USB Adapter
Driver version: 5.100.148.5
Physical address: ‎DC-EF-09-11-7D-6F
Tom Arneson
  Reply
#6
hi Tom, 

How funny, everything is there, except the netmask.

... also, it looks like your setup (Comcast in your area) might be using IPV6 ???  Are you actually using IPV6, or IPV4, if you don't know contact Comcast in your area and find out.

When you contact them, ask them what they recommend you set the netmask to/  also, often carriers like Comcast and Charter will send a tech to your house (or business) and do hand holding and troubleshooting diagnostics.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#7
Have you figured out your network issues?
  Reply
#8
(08-26-2016, 04:05 PM)mypineme Wrote: Have you figured out your network issues?

I got a new modem/wifi router from Comcast which seems to work, but I don't have much luck getting to websites with the browser. I was able to download some software. I haven't fired up the Pine 64 for over a week.
Tom Arneson
  Reply
#9
(09-01-2016, 01:34 PM)tomarneson Wrote:
(08-26-2016, 04:05 PM)mypineme Wrote: Have you figured out your network issues?

I got a new modem/wifi router from Comcast which seems to work, but I don't have much luck getting to websites with the browser. I was able to download some software. I haven't fired up the Pine 64 for over a week.

Can you try to go to 74.80.228.190 IP address from your browser? If you can access it then its your DNS settings then set your DNS to OpenDNS 208.67.222.222 and 208.67.220.220 or google public DNS 8.8.8.8 and 8.8.4.4. Let me know if it's not the dns and I will help you to troubleshoot it.
  Reply
#10
I typed 74.80.228.190 into the Midori browser and didn't get anywhere. It does work from Chrome on my PCs. I'd like to get another browser, but don't know how I can without having one that works.
Tom Arneson
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)