Could not initialize OpenGL support
#1
I get the error named in "subject" above when trying to play a .mp4 file with the preinstalled video player.

Though I can use Clapper to watch these files, I'd like to learn and understand, what the problem here is. Is it app related or is it an OS issue?
Maybe someone can give me a short explanation?

Thanks!
  Reply
#2
Hello

Personally, I use VLC which is far better (more reliable, supports many formats). The PinePhone should support OpenGL-ES flawlessly.
  Reply
#3
It looks like the app is trying to use hardware acceleration by default, which is not supported,.
Someone shared a workaround here:
https://www.reddit.com/r/pinephone/comme...lications/

You can start Phosh default video player like this:
LIBGL_ALWAYS_SOFTWARE=1 totem
  Reply
#4
Well, OpenGL hardware acceleration is supported by the PinePhone. Video hardware acceleration is to some extent in some applications. But LIBGL_ALWAYS_SOFTWARE only turns off OpenGL hardware acceleration and does not touch video hardware acceleration at all. If that fixes your problem, you are running into a bug in the OpenGL driver (or in the application, e.g., it might assume an optional OpenGL extension to always be available), not a hardware limitation.
  Reply
#5
(07-03-2024, 09:15 PM)Kevin Kofler Wrote: Well, OpenGL hardware acceleration is supported by the PinePhone. Video hardware acceleration is to some extent in some applications. But LIBGL_ALWAYS_SOFTWARE only turns off OpenGL hardware acceleration and does not touch video hardware acceleration at all. If that fixes your problem, you are running into a bug in the OpenGL driver (or in the application, e.g., it might assume an optional OpenGL extension to always be available), not a hardware limitation.

It looks like the PinePhone only supports OpenGL ES 2.0 like mentioned here:
https://forum.pine64.org/showthread.php?tid=16710

And when forcing totem to use hardware acceleration with "GDK_GL=gles", there is an error saying it requires OpenGL ES 3.0:
https://salsa.debian.org/Mobian-team/dev...ote_504360
  Reply
#6
The video driver used on the PinePhone actually supports desktop OpenGL 2.0 as well. Functionality which is not part of OpenGL ES will get little to no acceleration from the GPU (because the hardware was built with only OpenGL ES in mind), but the driver is supposed to handle it, e.g., Qt compiled (this is unfortunately a compile-time-only choice in Qt) for desktop OpenGL just works (which is why Manjaro ARM no longer ships the custom Qt GLES builds they used to ship, relying instead of the standard Arch Linux ARM Qt builds built for desktop OpenGL). I do not know what Totem is doing that crashes the driver, but it is either a bug in the driver or in Totem (or the libraries Totem uses, such as GTK/GDK).

If you are running Mobian stable, chances are the bug you are running into was fixed upstream eons ago. Mobian stable is a really really old distribution by mobile GNU/Linux standards.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Bluetooth audio support? Zebulon Walton 5 4,024 02-28-2022, 08:59 AM
Last Post: Zebulon Walton
  Mainline MMS Support?? tyha 2 2,257 01-06-2022, 03:25 PM
Last Post: bcnaz
  Camera support progress a-wai 73 90,425 08-18-2020, 02:46 PM
Last Post: bcnaz
  Unable to initialize message in chatty tims1979 16 20,373 07-17-2020, 04:45 PM
Last Post: jjs

Forum Jump:


Users browsing this thread: 1 Guest(s)