broken?
#1
Hey, newbie solder here

i bought a pinecil used it once and it was great

i whipped it out a few months later, today, to use it again and it reads low DC on the same setup as before

i tried to switch the power source but now it wont even power up? even on the setup that read low DC

tried different cubes, and cables even the barrel jack with blocks within the voltage range 

i think it smells burnt or maybe it smells like a soldering iron. What gives?
  Reply
#2
Dude! The same exact thing happened to me!

I had my iron in a drawer for 3-4 months, and when I went to use it again it wasn't working. Any time I try to initiate the heating process it flashes "Low DC Voltage: 5.2V" or something similar. Initially it read something like "Insufficient Voltage" instead.

At first, I assumed I had a bad USB-QC charger, so I swapped to a battery pack that I had used successfully before. That had the exact same issue. I tested on a third USB-QC charger that I had also used it with before; same result. After playing with the settings to no avail, I tried resetting the iron to factory defaults, which did nothing. Then I updated the firmware from my desktop. Again, nothing. Finally, I plugged it into a variable DC power supply I have and tried with that. It would read the voltage change (9V), but flashed the same issue about low voltage. Even after I set the Power Delivery voltage to 9V or 0, or disabled PD entirely. Nothing had any affect.

I'd love it if anyone had any ideas for troubleshooting!

At this point though, I'm not holding my breath. This is the coolest iron I've ever used! But if I can't rely on it, then I gotta just go buy a second-hand Hakko and a cheap, 3-setting vape battery.

Thanks mates!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Broken pinecil (?) sh4ttered 2 2,428 02-16-2022, 01:50 AM
Last Post: sh4ttered

Forum Jump:


Users browsing this thread: 1 Guest(s)