Resume from suspend not working after flashing Tow-Boot to SPI
#3
Thanks wdt!  I'm running the latest Manjaro that comes on the PBP eMMC, kernel 6.0.2-MANJARO-ARM.  Previously suspend/resume had worked for this kernel and lid magnet.

/etc/systemd/sleep.conf is all defaults

Quote:[Sleep]
#AllowSuspend=yes
#AllowHibernation=yes
#AllowSuspendThenHibernate=yes
#AllowHybridSleep=yes
#SuspendMode=
#SuspendState=mem standby freeze
#HibernateMode=platform shutdown
#HibernateState=disk
#HybridSleepMode=suspend platform shutdown
#HybridSleepState=disk
#HibernateDelaySec=120min


Before I flashed Tow-Boot to the SPI flash, suspending looked like (output of 'journalctl | grep -C 4 suspend').

Quote:Oct 29 08:58:10 neptune systemd-sleep[2735]: Entering sleep state 'suspend'...
Oct 29 08:58:10 neptune kernel: PM: suspend entry (deep)
Oct 29 08:58:14 neptune kernel: Filesystems sync: 0.109 seconds
Oct 29 08:58:14 neptune kernel: Freezing user space processes ... (elapsed 0.005 seconds) done.
Oct 29 08:58:14 neptune kernel: OOM killer disabled.
Oct 29 08:58:14 neptune kernel: Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
Oct 29 08:58:14 neptune kernel: printk: Suspending console(s) (use no_console_suspend to debug)
Oct 29 08:58:14 neptune kernel: LDO_REG2: No configuration
Oct 29 08:58:14 neptune kernel: LDO_REG1: No configuration
Oct 29 08:58:14 neptune kernel: ieee80211 phy2: brcmf_fil_cmd_data: bus is down. we have nothing to do.
Oct 29 08:58:14 neptune kernel: ieee80211 phy2: brcmf_cfg80211_get_tx_power: error (-5)
Oct 29 08:58:14 neptune kernel: PM: suspend devices took 2.160 seconds
Oct 29 08:58:14 neptune kernel: Disabling non-boot CPUs ...
Oct 29 08:58:14 neptune kernel: psci: CPU1 killed (polled 0 ms)
Oct 29 08:58:14 neptune kernel: psci: CPU2 killed (polled 0 ms)
Oct 29 08:58:14 neptune kernel: psci: CPU3 killed (polled 0 ms)
--
Oct 29 08:58:14 neptune kernel: OOM killer enabled.
Oct 29 08:58:14 neptune kernel: Restarting tasks ... done.
Oct 29 08:58:14 neptune kernel: random: crng reseeded on system resumption
Oct 29 08:58:14 neptune kernel: mmc_host mmc1: Bus speed (slot 0) = 400000Hz (slot req 400000Hz, actual 400000HZ div = 0)
Oct 29 08:58:14 neptune kernel: PM: suspend exit
Oct 29 08:58:14 neptune systemd-resolved[375]: Clock change detected. Flushing caches.
Oct 29 08:58:14 neptune wpa_supplicant[496]: p2p-dev-wlan0: CTRL-EVENT-DSCP-POLICY clear_all
Oct 29 08:58:14 neptune systemd-logind[430]: Lid opened.
Oct 29 08:58:14 neptune wpa_supplicant[496]: p2p-dev-wlan0: CTRL-EVENT-DSCP-POLICY clear_all



Now journalctl shows the following when trying to suspend:
Quote:Oct 30 15:12:20 neptune systemd[1]: Starting System Suspend...
Oct 30 15:12:20 neptune systemd-sleep[1017]: Entering sleep state 'suspend'...
Oct 30 15:12:20 neptune kernel: PM: suspend entry (deep)
Oct 30 15:12:20 neptune wpa_supplicant[503]: wlan0: CTRL-EVENT-DSCP-POLICY clear_all
Oct 30 15:12:20 neptune wpa_supplicant[503]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0

Erasing Tow-Boot off of the SPI flash and rebooting worked.  Now resume from suspend works as expected.  I installed the mtd-tools package and ran
Code:
flash_erase /dev/mtd0 0 0
  Reply


Messages In This Thread
RE: Resume from suspend not working after flashing Tow-Boot to SPI - by xp19375 - 10-31-2022, 07:08 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Slackware Linux working on PBP vxzero 0 135 06-05-2024, 04:30 PM
Last Post: vxzero
  Need Help Recovering Manjaro /boot Contents on Pinebook Pro calinb 6 2,572 12-11-2023, 03:47 AM
Last Post: calinb
  Boot Order in Pinebook Pro food 8 1,637 11-23-2023, 07:37 AM
Last Post: KC9UDX
  USB 3 port not working with Armbian zaius 3 1,084 11-13-2023, 01:54 PM
Last Post: zaius
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 1 2,103 08-21-2023, 09:08 PM
Last Post: vanessadonald
  Camera not working with Cheese cypresstwist 1 1,357 08-18-2023, 02:02 AM
Last Post: juliamenendez
  Emergency Mode Boot Hotkey? jiacovelli 20 5,419 06-02-2023, 01:32 PM
Last Post: wdt
  Suspend/Resume Broken with Bootloader on SPI Flash xp19375 2 1,293 03-24-2023, 04:25 PM
Last Post: srs5694
  5GHz wifi not working snorwood 11 6,055 01-16-2023, 03:41 PM
Last Post: ehcorn
  Pinebook Pro wifi not working Queliffrel 1 1,402 11-30-2022, 06:30 AM
Last Post: myself600

Forum Jump:


Users browsing this thread: 1 Guest(s)