Help with ssh and setting default apps
#1
Hello,

while setting up postmarketos on pinephone I encountered some problems, I don't get along with.

Probably the easier one: I try to access the PP shell via SSH like described on https://wiki.postmarketos.org/wiki/SSH.
The password should be the same like I use for sudo commands, right? But whatever I try, my password is not correct...
And which is the correct folder to put the public key?

Secondly I'm trying to set a default app as video player.
I tried using the xdg-mime command like described on https://wiki.alpinelinux.org/wiki/Default_applications.
But it says
Code:
/bin/ash: xdg-mime: not found
What am I supposed to do about this? xdg-utils should be working, shouldn't it? Or is this about "ash" and "bash"?

I'd be grateful for any hints
  Reply
#2
(09-10-2022, 07:22 AM)jojuma Wrote: Hello,

while setting up postmarketos on pinephone I encountered some problems, I don't get along with.

Probably the easier one: I try to access the PP shell via SSH like described on https://wiki.postmarketos.org/wiki/SSH.
The password should be the same like I use for sudo commands, right? But whatever I try, my password is not correct...

Secondly I'm trying to set a default app as video player.
I tried using the xdg-mime command like described on https://wiki.alpinelinux.org/wiki/Default_applications.
But it says
Code:
/bin/ash: xdg-mime: not found
What am I supposed to do about this? xdg-utils should be working, shouldn't it? Or is this about "ash" and "bash"?

I'd be grateful for any hints

usually user name is required and for pmos it is "user", mobian has "mobian", archlinux has "alarm" and manjaro has "manjaro".

Code:
$ ssh -p 22 user@ip-number-or-hostname

although in pinephone, i found out that authentication module crashes or malfunctions some cases, so reboot is required.

pmos has firewall activated by default, so it might cause some blocks. proper way is to add necessary holes to the firewall rules. but if lazy.

Code:
## disables firewall, not necessarily good idea for some.
$ sudo service nftables stop

for that default app, i cannot give direct advice but in my knowledge it is handled by gnome components, maybe gsettings.
  Reply
#3
SSH is working now. It was indeed the username, which was wrong. "user" worked.
I was confused, since the username in the terminal is not "user".

Thanks for that!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Unable to set default apps Barugon 7 475 Yesterday, 12:28 PM
Last Post: alaraajavamma
  closing apps rather than leaving them running (phosh) lordearl 7 3,489 02-03-2022, 09:14 PM
Last Post: parry
  What is the default pin!? ThatWasLeftHanded 3 3,119 09-08-2021, 09:01 AM
Last Post: walter1950
  Disabe Bluetooth by default Alejandro.SU 1 1,835 11-09-2020, 10:59 AM
Last Post: Lousy Fisherman
  What is default password? quixote 6 13,424 11-03-2020, 08:55 AM
Last Post: wibble
  Phone arrived: Stupid Questions begin. Setting up OpenVPN? OLOV 3 3,385 10-06-2020, 05:10 PM
Last Post: OLOV
  Resize apps for postmarket OS zeb11 8 7,540 09-26-2020, 04:21 PM
Last Post: ragreenburg
  More Apps! Zweitaktmotor 6 5,242 03-24-2020, 04:59 AM
Last Post: PureTryOut

Forum Jump:


Users browsing this thread: 1 Guest(s)