snap install exceeded maximum runtime
#1
Hi everyone,

seeking for help if this "project" is possible at all.

I want to install classic "Prince of Persia" from the snapstore. But no matter if I try online or offline after downloading the snap I get the same output:

Code:
sudo snap install sdlpop
[sudo] password for mobian:
error: cannot perform the following tasks:
- Run configure hook of "sdlpop" snap if present (run hook "configure":
-----
/usr/share/fonts: caching, new cache contents: 0 fonts, 5 dirs
/usr/share/fonts/cMap: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/opentype: caching, new cache contents: 0 fonts, 3 dirs
/usr/share/fonts/opentype/cantarell: caching, new cache contents: 5 fonts, 0 dirs
/usr/share/fonts/opentype/noto:
<exceeded maximum runtime of 5m0s>
-----)

Is there something wrong with the fonts or can I take influence on the maximum runtime?

I am asking this here since on any other system installation was no problem and I can't find a solution in the WWW.

Thanks for advices

EDIT: There are versions for amd64, arm64, armhf, i386 and ppc64el. So this should work, shouldn't it?

EDIT: Since '/usr/share/fonts/opentype/noto' is a rather big folder, I thought the caching of it takes a lot of time and thus moved it to another location.
After that, the installation process went through without further problems. I copied the 'noto' folder back afterwards.
The game runs smoothly now and though I don't know if this is a proper solution due to future updates, I'll mark this as 'solved' for know.

Thanks!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Waydroid install instructions end up attempting to use wrong URLS to aquire .debs chainingsolid 1 271 04-26-2024, 04:56 PM
Last Post: zetabeta
  Phoch Trixie weekly install seems nice reTestability 0 339 03-10-2024, 08:47 AM
Last Post: reTestability
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 2,492 11-22-2023, 11:46 AM
Last Post: aLoop100o
  apt trying to install a package version not in the repo chainingsolid 1 672 11-12-2023, 03:54 AM
Last Post: evilbunny
  Recent install, no wifi user641 3 1,641 01-12-2023, 03:06 PM
Last Post: user641
  I built a reminder app but can't seem to build a deb/snap/flatpak for it, help? ragreenburg 9 7,173 09-10-2021, 02:51 PM
Last Post: ragreenburg
  Best/easiest way to install minimal Debian on PinePhone? mcgee 6 5,745 07-18-2021, 09:35 AM
Last Post: swiley
  Cannot install spotify, librespot or mopidy Gon 3 3,815 06-18-2021, 06:53 AM
Last Post: Gon
  firefox 79 will not install motox6 1 2,290 05-08-2021, 02:09 AM
Last Post: MtnSk8
  How do I install pinephone-devtools? lsitongia 1 2,334 04-06-2021, 04:31 PM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)