error when try to build infinitime 1.10
Got stuck on building infinitime on my own computer. The following procedure worked well for version 1.9 but not 1.10
I used a win10 64bit computer. I installed Microsoft visual studio code and docker on my computer.
Here is what I have tried:
1. use github desktop app to make a clone of the infinitime code.
2. under github app choose the master branch tagged 1.10
3. then use the visual studio code to open the infinitime folder.
4. wait for visual studio code to run docker container, then opened an terminal
5. with root account
apt-get install npm
npm install lv_font_conv
6. runs the
 /workspaces/InfiniTime$ cmake -G 'Unix Makefiles' -DCMAKE_BUILD_TYPE=Release -DUSE_OPENOCD=1 -DARM_NONE_EABI_TOOLCHAIN_PATH=/opt/gcc-arm-none-eabi-9-2020-q2-update -DNRF5_SDK_PATH=/opt/nRF5_SDK_15.3.0_59ac345 -S . -Bbuild
7. cd build
8 make -j pinetime-app
Then it gives error:
[ 42%] Built target lvgl
[ 63%] Built target nimble
(Stripping trailing CRs from patch; use --binary to disable.)
patching file jetbrains_mono_bold_20.c
patching file jetbrains_mono_bold_20.c
patch: **** malformed patch at line 3:

Traceback (most recent call last):
  File "/workspaces/InfiniTime/src/displayapp/fonts/", line 75, in <module>
  File "/workspaces/InfiniTime/src/displayapp/fonts/", line 70, in main
    subprocess.check_call(['/usr/bin/env', 'patch', name+'.c', patch])
  File "/usr/lib/python3.10/", line 369, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/usr/bin/env', 'patch', 'jetbrains_mono_bold_20.c', 'jetbrains_mono_bold_20.c_M.patch']' returned non-zero exit status 2.
make[3]: *** [src/displayapp/fonts/CMakeFiles/infinitime_fonts_jetbrains_mono_bold_20.dir/build.make:73: src/displayapp/fonts/jetbrains_mono_bold_20.c] Error 1
make[3]: *** Deleting file 'src/displayapp/fonts/jetbrains_mono_bold_20.c'
make[2]: *** [CMakeFiles/Makefile2:590: src/displayapp/fonts/CMakeFiles/infinitime_fonts_jetbrains_mono_bold_20.dir/all] Error 2
make[1]: *** [CMakeFiles/Makefile2:286: src/CMakeFiles/pinetime-app.dir/rule] Error 2
make: *** [Makefile:189: pinetime-app] Error 2
try to change EOLs (e.g. with Notepad++) from Win to Linux format for:
(07-08-2022, 08:23 AM)ITCactus Wrote: try to change EOLs (e.g. with Notepad++) from Win to Linux format for:

Thanks! It works!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Infinitime Build problem BlackDev 1 731 12-23-2023, 08:07 AM
Last Post: Luno
  Bluetooth BLE-MIDI-controller app for PineTime / InfiniTime Luno 0 550 08-20-2023, 05:17 AM
Last Post: Luno
  Python Hangman Game Program Error gulshan212 2 784 07-24-2023, 11:29 PM
Last Post: gulshan212
  Can't build InfiniTime Anonymous1 1 1,415 01-25-2023, 01:49 AM
Last Post: matthewfelgate
  Fixing CMake Error: Can't access folder '/home/james/projects/src/libs/lvgl' matthewfelgate 0 625 01-25-2023, 01:47 AM
Last Post: matthewfelgate
  Daemon and go library to interact with InfiniTime on Linux Arsen6331 0 1,870 08-21-2021, 10:32 AM
Last Post: Arsen6331
  Build Infinitime Sources aemkai 4 4,922 08-01-2021, 01:41 PM
Last Post: JF002
Information InfiniTime Default Face USA Mod - No longer supported The3DmaN 1 3,207 02-25-2021, 03:51 PM
Last Post: The3DmaN
  InfiniTime Avamander 4 6,984 02-24-2021, 02:38 PM
Last Post: Avamander
  Build PineTime Firmware in the Cloud lupyuen 3 5,912 07-27-2020, 04:54 PM
Last Post: lupyuen

Forum Jump:

Users browsing this thread: 1 Guest(s)