Pine A64 does only boot with Android 5.1

recently, i got the Pine A64 2GB. I bought a SanDisk Ultra Class10 32GB sdcard to flash the OS on it.

I tried a bunch of OS's but none of them were booting.

After reading a couple of threads in this forum about the power that the Pine needs to run, i bought a matching charger and a cable. With that, i was able to boot Android 5.1. But none of the other OS's like Remix_OS, Armbian and others boot.

To flash the sdcard, i use Etcher for windows 10 attachted to a 2.0 Cardreader thats connected to an 3.0 port. That flashes the OS about three times faster than the 2.0 port. I mention that because i dont know if the port might cause the problem due to the speed the 3.0 port provide. Like, the OS flashes too fast or something like that. I'm a bit desperate.

In general, i'm fine with android but i would like to try different OS's.

Is there something missing or am i doing something wrong?

Thanks for your help!
first, i'd say dont count on Remix OS to boot. I could never get it to, even when it was under active development. You might want to try using that slower USB2 port. sometimes it helps for an IMG to be written more slowly.

You might also try using Rufus to write your SD (I hear it's a popular Windows alternative to Etcher, but I've never used it)
Thank you tophneal for your reply.

Using the 2.0 port and rufus did work only for Armbian 22.05 Jammy XFCE. Didn't try it with android.
I can not tell what the difference between this combination and the 3.0/Etcher como is, but that worked out.
Of course there is another "but". The problem here is, that i'm stuck with the cli in armbian jammy.
I doublechecked if i downloaded the desktop-version, and i did, but it did boot in the cli instead of a gui. So i did set up the cli-version i.e. Upgrade the system.

I also, and i think that might caused the issue, tried to set up a password. Since this Pine is just ment to stream Netflix on my tv once in a while so that i dont have to use my old, big and loud laptop, armbian rejected my good old "1234" password as too simple. After 3 new tries of using Upper letters, digits and specials, i got logged in as root. While a cli is very good for server purposes, it is not very practical for gui-based purposes.

Shouldn't it boot in gui-mode to setup the OS on the first place? I read in a forum, you can run apps with a gui from the cli by typing "explore display=:0 (or any specific number)". I gave it a shot and nothig happens. Not a supprise.

What am i doing wrong here?
try running sudo armbian-config and then use the Softy tool to install the DE you'd like to use.If you DE is already installed, there's an option to enable/disable the DE, you may want to try toggling that.
Great, that worked out. Next time, i better read the documentation. But thanks for the link.

Next step is to figure out what drivers etc. i need to install that netflix is working. As soon as i got there, i'll let you know.

Thanks a lot for your help!
If your goal is use it to watch Netflix from a browser on the OS, and not stream to it as a second screen, you won't find the drivers you need. Instead, I'd suggest using this docker img:
Thanks for your support.

But that doesnt work. Like all the other ideas i found the last days run into issues i was not able to solve. Beside that, armbian behaves very slow. I open the cli and that takes 2 seconds until its useable. To open an browser take exponentially longer. A friend gave me his ps4 as a gift on friday (the hdd was the issue and he hates dealing with tech-stuff - i put inan ssd) and i'll use that to stream netflix and other playstation-stuff. It was a fun project but disproportionate time consuming and frustrating af. I send the Pine back. Thank you very much for your help and i say sorry to everybody who has similar issues and see this thread in the future.

Possibly Related Threads…
Thread Author Replies Views Last Post
  PINE A64 SBC: Clone of a functional 32GB SD card doesn't boot burningkrome 3 1,773 05-19-2023, 07:43 AM
Last Post: crocspot
  PINE A64 Ubuntu 18 or 20 IMG with touchscreen? burningkrome 0 677 04-29-2023, 05:13 AM
Last Post: burningkrome
  Pine A64+ vs LCD do not boot DDS 3 6,105 02-23-2021, 05:33 PM
Last Post: thedu
  Autodetect if Pine unit is a Pine A64+ or PineA64-LTS pkfpeters 1 3,426 02-09-2021, 12:17 AM
Last Post: tllim
  Pine 64 | 2GB x2 & Acrylic Cases x2 for Sale | Canada - GTA ViperVi 1 4,594 01-18-2021, 03:45 PM
Last Post: squidius
  sd format?for pine 64 angegardien 3 7,935 12-06-2020, 03:53 PM
Last Post: junkyj753
Exclamation Can't boot when SD card inserted kivox 5 8,207 03-15-2020, 06:00 AM
Last Post: kivox
  Node Red on the Pine DonFL 0 2,835 12-16-2019, 04:21 PM
Last Post: DonFL
Photo Pine A64+ from Kick starter running Pi-Hole netHolio 0 3,286 12-02-2019, 09:36 PM
Last Post: netHolio
  Boot from HDD via usb BnEc 1 3,774 11-29-2019, 04:39 AM
Last Post: evilbunny

Forum Jump:

Users browsing this thread: 1 Guest(s)