Modem in failed state, not sending/receiving SMS
I have a PP Braveheart on Arch Phosh that had worked fine for almost 2 years on Verizon's CDMA network. Calls, SMS, and now even MMS worked. Occasionally the inbound SMS would get hung up, but clearing the modem cache by connecting to the modem and running 
resolved that. Recently I wrote a systemd service/timer that ran
echo "AT+CMGD=0,4" > /dev/ttyUSB2
every hour. Seems my issues have arisen since then. Now when I try to manually clear the cache it just returns
repeatedly in minicom. I tried flashing biktorgj modem firmware to "refresh" my modem, but it gets hung at
< waiting for any device >
and detects no fastboot devices.
Bus 002 Device 002: ID 2c7c:0125 Quectel Wireless Solutions Co., Ltd. EC25 LTE modem
So the modem is there, just not responding to me in the way I have become familiar with.

It seems maybe the modem may be the source of these SMS issues, but I'm not sure how to resolve it if its not responseive to minicom, atinout, or fastboot. Any thoughts?

sudo mmcli -m any -e
error: couldn't enable the modem: 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.WrongState: modem in failed state'
I have tried restarting eg25-manager and rebooting. How might I get out of this failed state?
Pretty much out of my depth, but pull the battery for 3 mins to make sure the modem gets a fresh start is my only suggestion.

Happened to me once my modem went into bizarre mode and mine did recover.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (6.2 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition, daily driver, rk2aw & U-boot on SPI, Arch/SXMO & Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/SXMO on eMMC
tried pulling the battery, still booted back up in failed state
Temporarily boot to another distro, like pmOS or Manjaro, from SDCard. See if something became messed up during an upgrade.

If that ^ doesn't work, poke around on the issue trackers for something similar. IIRC, people have "lost" their modems before and sometimes recovered them. I've found the eg25-manager and modemmanager boards to be full of helpful details.
PPv1.2a running PMOS ... almost a daily driver!
Same response in Mobian booted from sdcard. I think the issues is on the modem side. Any suggestions?
If all else fails you can look into opening the phone and jumpering pins / test points to boot the modem into EDL mode then reflashing with Qfirehose.

Possibly Related Threads…
Thread Author Replies Views Last Post
Bug PinePhone modem keeps "disappearing" Kevin Kofler 14 3,980 03-22-2023, 05:28 PM
Last Post: Kevin Kofler
  modem not working michelinux 0 736 02-16-2023, 04:56 AM
Last Post: michelinux
  modem not detected al_x 3 3,716 02-15-2023, 11:17 AM
Last Post: fxc
  Supported Carrier and Modem Bands NachoMomma 2 1,127 02-05-2023, 11:27 AM
Last Post: wibble
  firmware udate Quectel EG25-G modem alwi 7 4,427 07-06-2022, 01:43 PM
Last Post: user641
  Need command to tell what modem firmware I am on. purpletiger 4 2,291 07-06-2022, 12:35 PM
Last Post: Zebulon Walton
  The modem does not recognize Korean SIM cards (what?) bdicewk 9 3,350 06-13-2022, 04:12 AM
Last Post: zetabeta
  kb151 2-0015: Charger read failed - MCU returned 0xff as365n4 5 2,348 06-08-2022, 10:41 AM
Last Post: as365n4
  Modem Hardware bad? Not ready for 5g?? linux76 8 4,041 05-31-2022, 06:41 PM
Last Post: SwordfishII
  Modem Dead? grimlok 5 3,005 03-12-2022, 04:38 PM
Last Post: bcnaz

Forum Jump:

Users browsing this thread: 1 Guest(s)