System Updates: "unexpected error"
#1
Question 
Just received my first Pro, switched off the modem, mic and both cameras, plugged in charger, connected WiFi and attempted to update/upgrade the soft:

   

Rebooted, tried again — same thing.

Note that the updates' size appears zero. Weird.

How to debug it? Can I try the same via CLI to see some details? Isn't this a common/known issue with new Pros?
  Reply
#2
I never had any luck with that.  Use pacman to update from the cli
sudo pacman -Syu

hth,rz
  Reply
#3
(03-04-2022, 08:40 PM)arzach Wrote: Use pacman to update from the cli
sudo pacman -Syu

Thanks, but.... It started asking me lots of [Y/n] questions, so I added `--noconfirm`. When that finished, there were lots of stuff like:

Code:
:: File /var/cache/pacman/pkg/....pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature))
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))

And at the end:

Code:
Error occurred, no packages were upgraded


Now what?
  Reply
#4
Uh...I'm an idiot who can't type.  Sorry.
Use -Syyu so it forces the package list to be refreshed

edit: this is what happens to me every time I punch the Post button before rereading what I wrote.
  Reply
#5
(03-04-2022, 10:01 PM)arzach Wrote: Use -Syyu so it forces the package list to be refreshed

That works muuuch better!
Now it hits this wall trying to download some packages from fastmirror.pp.ua. Connection timeout, or "Operation too slow" on the second attempt. (I can understand why — perhaps due to the sad situation over there).

Surely there must be a way to set a different mirror, closer to where I am (New Zealand)?

Update: "sudo pacman-mirrors --continent" seems to have done the trick.
  Reply
#6
That .ua server is Ukrainian which is inaccessible last time I checked so I commented it out of the pacman mirrors list which resolved that problem.
  Reply
#7
So... I kept getting these "keyring is not writable" errors repeatedly trying to upgrade until I found this post suggesting to run:

Code:
sudo rm -rf /etc/pacman.d/gnupg
sudo pacman -Sy gnupg archlinux-keyring archlinuxarm-keyring manjaro-keyring manjaro-arm-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --populate archlinuxarm manjaro-arm
sudo pacman-key --refresh-keys

That didn't work straight away either: I had to juggle those commands in random order many times until they eventually allowed
Code:
sudo pacman -Syyu --noconfirm
to proceed smoothly. Now upgrade is done, yay! Thanks all.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Error Updating Emilio 2 514 02-20-2022, 09:51 AM
Last Post: Emilio
  Offline Updates Error dgiffin 5 867 02-17-2022, 10:25 AM
Last Post: dgiffin
  How to find location of running system tckosvic 3 522 02-03-2022, 11:25 AM
Last Post: tckosvic
  No update PGP, Error Solved iopser 2 472 02-01-2022, 07:53 AM
Last Post: iopser

Forum Jump:


Users browsing this thread: 1 Guest(s)