Error - megapixels not opening
#1
I am having some problems with a mobian isntall I did today, when tryting to open megapixels I get this error:

Code:
mobian@mobian:~$ megapixels
Renderdoc not found
Found config file at /usr/share/megapixels/config/pine64,pinephone-1.2.ini
Adding camera rear from config
Adding camera front from config
Found postprocessor script at /usr/share/megapixels/postprocess.sh

(megapixels:2559): Gdk-WARNING **: 22:08:12.230: gdk_gl_context_set_required_version - GL context versions less than 3.2 are not supported.
Initialized OpenGL 2.1
**
Gsk:ERROR:../../../gsk/gl/gskglcommandqueue.c:1266:gsk_gl_command_queue_create_render_target: assertion failed (glCheckFramebufferStatus (GL_FRAMEBUFFER) == GL_FRAMEBUFFER_COMPLETE): (0x00008cd6 == 0x00008cd5)
Bail out! Gsk:ERROR:../../../gsk/gl/gskglcommandqueue.c:1266:gsk_gl_command_queue_create_render_target: assertion failed (glCheckFramebufferStatus (GL_FRAMEBUFFER) == GL_FRAMEBUFFER_COMPLETE): (0x00008cd6 == 0x00008cd5)
Annullato
What can I do?
  Reply
#2
Same here Cry   , since I've installed some Mobian updates and rebooted.
Using encrypted Mobian (bookworm) on pmOS CE Convergence PinePhone (3GB/32GB) as Daily Driver, and Beta Edition Convergence PinePhone (3GB/32GB) with encrypted Mobian (bookworm) as Backup device.
  Reply
#3
(02-22-2022, 02:46 PM)dante404 Wrote: Same here Cry   , since I've installed some Mobian updates and rebooted.

I experienced this too. I manually fetched the package for megapixels 1.4.3 and installed that, and it's working again.
(Maybe this will cause me some problem I don't know about yet, I only just did it a few minutes ago.. But I did not have to install or upgrade any other packages to make it work, so I hope there will be no issues.)

-john
  Reply
#4
(02-22-2022, 10:33 PM)johns Wrote: I experienced this too. I manually fetched the package for megapixels 1.4.3 and installed that, and it's working again.
(Maybe this will cause me some problem I don't know about yet, I only just did it a few minutes ago.. But I did not have to install or upgrade any other packages to make it work, so I hope there will be no issues.)

-john

Thank you for this info!
How did you do that? Fetched the source and compiled it yourself? Or is there a deb package of v1.4.3 anywhere?
Using encrypted Mobian (bookworm) on pmOS CE Convergence PinePhone (3GB/32GB) as Daily Driver, and Beta Edition Convergence PinePhone (3GB/32GB) with encrypted Mobian (bookworm) as Backup device.
  Reply
#5
(02-24-2022, 04:25 PM)dante404 Wrote:
(02-22-2022, 10:33 PM)johns Wrote: I experienced this too. I manually fetched the package for megapixels 1.4.3 and installed that, and it's working again.
(Maybe this will cause me some problem I don't know about yet, I only just did it a few minutes ago.. But I did not have to install or upgrade any other packages to make it work, so I hope there will be no issues.)

-john

Thank you for this info!
How did you do that? Fetched the source and compiled it yourself? Or is there a deb package of v1.4.3 anywhere?

Just grabbed the deb package from http://ftp.debian.org/debian/pool/main/m/megapixels/

-john
  Reply
#6
I had the same problem. no need to download or reinstall things, just



Code:
sudo dpkg-reconfigure megapixels



and it should work again
  Reply
#7
@ johns : Thank you! It worked!  Smile

@ battlegarden : Too late for me, but thank you too!  Smile
Using encrypted Mobian (bookworm) on pmOS CE Convergence PinePhone (3GB/32GB) as Daily Driver, and Beta Edition Convergence PinePhone (3GB/32GB) with encrypted Mobian (bookworm) as Backup device.
  Reply
#8
On my phone the latest version works fine until there is a {bar,qr}code. The previous version marked it with a red rectangle and you could copy the content. The current version (1.4.3-1) freezes.
Can you reproduce this issue?
  Reply
#9
(02-26-2022, 12:51 PM)jsch Wrote: On my phone the latest version works fine until there is a {bar,qr}code. The previous version marked it with a red rectangle and you could copy the content. The current version (1.4.3-1) freezes.
Can you reproduce this issue?

I never tried on the old version, but I can confirm that with the current version, it freezes. It appears to lock on the QR code and then the image wobbles/vibrates and moving the camera no longer moves the image.

-john
  Reply
#10
I found a bug report matching this issue: https://gitlab.com/postmarketOS/megapixels/-/issues/45
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  [Megapixels] Flash strobe, pictures viewer and MPCamera error 22 freelectro 1 1,234 08-30-2023, 03:59 AM
Last Post: karensather
  Megapixels doesn't work Glenn 4 3,054 08-28-2022, 03:19 PM
Last Post: vortex
  Megapixels and Pinhole Zebulon Walton 0 958 06-15-2022, 04:53 PM
Last Post: Zebulon Walton
  Flatpak error during apt update user641 0 1,199 02-14-2022, 08:35 AM
Last Post: user641
  Waydroid error: not using Wayland. But I am! quixote 7 7,056 01-09-2022, 02:47 PM
Last Post: jsch
  Installed Apps not opening mmd604 5 4,227 10-08-2021, 09:29 AM
Last Post: ragreenburg
  Enter disk decryption passphrase error healthyliving101 3 3,211 09-07-2021, 12:21 PM
Last Post: Fenellakw
  Video playback error (Totem/Videos) Zebulon Walton 0 1,137 08-19-2021, 05:37 PM
Last Post: Zebulon Walton
  Unable to play videos ("bitstream error") pietenpol 1 2,248 06-14-2021, 07:58 AM
Last Post: Gribouille
  How to use Megapixels and QR codes? Zebulon Walton 3 3,697 05-06-2021, 12:20 AM
Last Post: awaittrot

Forum Jump:


Users browsing this thread: 1 Guest(s)