No PCIe controller detected...

I received my RockPro64 yesterday and want to build a NAS with it, using the official Pine64 PCIe controller and two SATA drives in RAID1. Pretty standard I thought.

But even after spending the whole morning trying all the different images I could find, still no success.

Mainly, Ayufan's image compatibility list shows that e.g. the 0.9.14 image (I'm using stretch openmediavault or bionic/buster minimal, either arm64 or armhf) should support the PCIe controller.

However, lspci shows nothing, ever. Always blank.

Also, dmesg | grep pci only ever shows:

[    1.914531] rockchip-pcie f8000000.pcie: invalid power supply
[    2.414583] rockchip-pcie f8000000.pcie: PCIe link training gen1 timeout!
[    2.414632] rockchip-pcie f8000000.pcie: deferred probe failed
[    2.414903] rockchip-pcie: probe of f8000000.pcie failed with error -110
[    2.710029] ehci-pci: EHCI PCI platform driver
[    4.248474] vcc3v3_pcie: disabling

When googling these errors, I get the impression that this is a very old bug that should've been solved by now. But why is my PCIe controller never recognized?

It doesn't matter whether I plug in the official Pine64 PCIe/SATA adapter or connect SATA drives to it.

What am I missing here? Any help is appreciated.
Alright, it seems I have solved it myself by moving away from Ayufan's images.

I flashed MrFixit2001's latest debian minimal image, and that seems to work.

For reference: I have a v2.1 board (2018-07-02) with a 64 GB eMMC and the official Pine64 PCIe to 2x SATA adapter.

I now get from lspci:

00:00.0 PCI bridge: Device 1d87:0100
01:00.0 SATA controller: JMicron Technology Corp. Device 0585

Hurray Smile

Possibly Related Threads…
Thread Author Replies Views Last Post
  RK3399 PCIe enumeration jhadd 0 328 01-31-2024, 08:56 AM
Last Post: jhadd
  Can RockPRO64 support PCIe Endpoint? andrewg132 3 2,321 10-14-2022, 06:24 AM
Last Post: rwk-
  Using the PCIe slot of ROCKPro64 as EndPoint mode nonoriri 1 1,895 11-20-2021, 10:53 AM
Last Post: fire219
  WiFi not working with PCIe SSD installed mikeD 0 1,445 05-25-2021, 07:48 AM
Last Post: mikeD
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 7,046 05-20-2021, 10:04 PM
Last Post: t4_4t
  Frequent kernel panic, possibly due to PCIe SSD? meier 4 6,082 11-22-2019, 05:15 PM
Last Post: meier
  My PCIe disk controller works with Linux 5.3.6 guannais 1 2,811 10-30-2019, 07:11 PM
Last Post: guannais
Information Update 22.02.2019 Feature-complete Debian build - SDIO WiFi/BT / PCIe / 3D / 2D Luke 100 129,209 10-04-2019, 08:57 PM
Last Post: tuxd3v
  PCIe ath10k on RockPro64 dasfranky 5 7,092 08-31-2019, 11:36 AM
Last Post: tuxd3v
  PCIe Sata II adapter and ssd TRIM bavay 0 1,832 08-16-2019, 07:49 AM
Last Post: bavay

Forum Jump:

Users browsing this thread: 1 Guest(s)