red/green power led not working with kernel 5.14
#1
Hi!

With linux kernel 5.13, I had a green power led when the kernel starts and is running. Now with linux kernel  5.14, the led is always red.

What kernel option/code do I need to enable in  order to have the green led ? This is some good indicator that the kernel really starts without having a console access.

Kind regards,
Xavier.

EDIT: the green led is lit, but the ged led keeps being on, and it hides the green led. The brighness parameter of the red led is 0, which is incorrect (red led should be off and brightness value should be 0).
Kind regards,
Xavier Miller.
  Reply
#2
If you are using manjaro, there was a bug with the green LED in kernel 5.14, it's fixed in the most recent kernel.

the leds are at /sys/class/leds

Code:
echo 0 | sudo tee /sys/class/leds/red\:standby/brightness
echo 1 | sudo tee /sys/class/leds/green\:power/brightness
  Reply
#3
Hi!,

I am using the patches from https://gitlab.manjaro.org/manjaro-arm/p...core/linux applied on gentoo-sources (= vanilla + some patches), running kernel 5.14.5
The current patches don't apply correctly to 5.14.6...

I can see the 2 led entries.

The red led says the brightness is 0, but if I send it to 0, the red led goes off and I can see the green led.
So there seems an initialization bug for the red led...
Kind regards,
Xavier Miller.
  Reply
#4
I changed the title to be more accurate.

So the green led is lit at kernel startup, but togheter with the red which is brighter and hides the green one.
Kind regards,
Xavier Miller.
  Reply
#5
Hi!,

for kernel 5.14, I did a boot script to reset the led status

Code:
for led in /sys/class/leds/*/brightness
do
    b=$(cat $led)
    echo $b > $led
done

And it's fixed in kernel 5.15 : the led is green when the kernel loads.
Kind regards,
Xavier Miller.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  5GHz wifi not working snorwood 11 1,776 01-16-2023, 03:41 PM
Last Post: ehcorn
Question Debian (Vanilla) no output on display after Kernel update (6.0.8-1) as365n4 1 362 12-09-2022, 12:43 PM
Last Post: as365n4
  Pinebook Pro wifi not working Queliffrel 1 368 11-30-2022, 06:30 AM
Last Post: myself600
  Resume from suspend not working after flashing Tow-Boot to SPI xp19375 3 471 10-31-2022, 10:14 AM
Last Post: wdt
  kernel module that supports usb-c hdmi alexandre 15 9,377 10-13-2022, 10:51 PM
Last Post: rfm83
  Webcam not working in Manjaro with Cheese, but works in Armbian petaramesh 1 359 09-30-2022, 10:09 AM
Last Post: crazyquark
  Loud distorted speaker sound when connecting to power supply myself600 2 407 09-21-2022, 12:11 PM
Last Post: myself600
  Help with Kali Linux wifi not working but works with Manjaro PineSupporter 2 1,169 08-25-2022, 02:15 PM
Last Post: Niko
  Camera not working with Cheese cypresstwist 0 365 08-16-2022, 09:28 PM
Last Post: cypresstwist
  bootloader menu to pick a kernel - what is the current situation in in early 2022? maxtothemax 4 1,837 02-05-2022, 03:04 PM
Last Post: maxtothemax

Forum Jump:


Users browsing this thread: 1 Guest(s)