Manjaro Image
#1
Now that we have working LAN, we can link this image here Smile

https://github.com/manjaro-arm/quartz64-...s/releases

The image is updated weekly.

With

Code:
pacman -Syu


you can then update it.


Working
  • LAN
  • PCIe
  • USB2
Not Working
  • USB3
  • SATA-Port
  • HDMI

Quote:If there is no battery plugged into the board, the jumper labelled "ON/OFF_BATT" must be in place. If this is set wrong, stability issues such as failures to boot will occur.
Source: https://wiki.pine64.org/wiki/Quartz64#St...tery_Shunt

Thank you Dan!
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA JMS585 Chipsatz / Booting from an 2,5 Zoll SSD on port 5/ 2 * 3,5 Zoll 4TB HDD (raid1) md0 / 2 * 2,5 Zoll 2TB HDD (raid1) md1 / using as NAS / Kernel 5.6.0-1137-ayufan-ge57f05e7bf8f

2. RP64 v2.1 / testing.....testing....testing

3. Quartz64 Model A with 4GB RAM

https://forum.frank-mankel.org/category/14/rockpro64
  Reply
#2
Just received my first of 2 quartz64s, will likely try this soon. I like manjaro and have it on multiple PINE devices (the phone and PBP right now I think).
------
it doesn't get happy
it doesn't get sad
it just runs programs
  Reply
#3
How do I even boot this thing?
I've downloaded manjaro image from gintub, flashed it with dd to an sd-card... and I get nothing.
I know that hdmi doesn't work yet, but LAN port doesn't have a link either (tried turning off autonegotiation on the switch, tried 100m 100m, no luck).
Tried various power/reset inputs - still no luck.
SoC gets barely warm, so there is definitely something going on with an angry pixies inside Smile
  Reply
#4
I have flashed the latest image from manjaro for quartz github repo, and got as far as getting an output on UART, but it remains stuck while booting the kernel...

I have a jumper on ON/OFF_BAT pins, and get stuck on the following:

                                          Disk: /dev/sda
                        Size: 29.12 GiB, 31268536320 bytes, 61071360 sectors
                    Label: gpt, identifier: 8551F660-0661-4597-8AF9-EA3B6AFC5F42

   Device                   Start            End        Sectors        Size Type
>>  Free space                2048          16383          14336          7M                           
   /dev/sda1                16384          30719          14336          7M Microsoft basic data
   Free space               30720          62499          31780       15.5M                           
   /dev/sda2                62500         500000         437501      213.6M EFI System
   /dev/sda3               500001        3291102        2791102        1.3G Linux filesystem
   Free space             3291136       61071326       57780191       27.6G                          



Jumping to U-Boot(0x00a00000) via ARM Trusted Firmware(0x00)
Total: 218.346 ms

INFO:    Preloader serial: 2
NOTICE:  BL31: v2.3():v2.3-135-gcda1658bc-dirty:xsf
NOTICE:  BL31: Built : 19:32:20, Jun  2 2021
INFO:    GICv3 without legacyr initialized in EL3
INFO:    pmu v1 is valid
INFO:    dfs DDReq_mhz= 1056MHz
INFO:    dfs DDR fsp_param[1].freq_mhz= 324MHz
INFO:    dfs DDR fsp_param[2].f   dfs DDR fsp_param[3].freq_mhz= 780MHz
INFO:    Using opteed sec cpu_context!
INFO:    boot INFO:    BL31: Initializing runtime services
INFO:    BL31: Initializing BL32
I/TC:  
I/TC: Start rockchip platform init
I/TC: Rockchip release version: 1.0
I/TC: OP-TEE ve 2021 aarch64
I/TC: Initialized
INFO:    BL31: Preparing for E to normal world
INFO:    Entry point address = 0xa00000
INFO:    SPSR = 0x3c9


U-Boot 2017.09 (Jun 26 2021 - 13:03:27 +0000)

Model: PineRK3566 Quartz64 Board
PreSerial: 2, raw, 0xfe660000
DRAM:  7.7 GiB
Sysmem: init
Relocation Offset: ed39f000, fdt: eb9f9fbdwmmc@fe2b0000: 1, dwmmc@fe2c0000: 2, sdhci@fe310000: 0
Bootdev(atags): mmc 0
MMC0: HS200, 200Mhz
PartType: EFI
No misc partition
boot mode: None
FIT: No boot partition
No r
   Failed to load DTB
Failed to get kernel dtb, ret=-19
io-domain: OK
MMC error: The cmd index is 1, ret is -110
Card did not respondct!
mmc_init: -95, time 10
** Bad device mmc 1 **
Using default environment

Model: Pine64 RK3566 Quartz64 Board
rockchip_set_serialno: could not find efuse/otp device
CLK: (syarm: enter 816000 KHz, init 816000 KHz, kernel 0N/A)
 apll 816000 KHz
 dpll 528000 KHz
 gp npll 24000 KHz
 vpll 24000 KHz
 hpll 24000 KHz
 ppll 100000 KHz
 armclk 816000 KHz
 aclk_bus 150000 KHz
 pclk_bus 5KHz
 aclk_top_high 300000 KHz
 aclk_top_low 200000 KHz
 hclk_top 150000 KHz
 pclk_top 50hclk_perimid 150000 KHz
 pclk_pmu 50000 KHz
Net:   clk_get_by_name(master_bus) failed: -22eqo failed: -22No ethernet found.
Hit key to stop autoboot('CTRL+C'):  0  
## Booting FIT Image FIT: No boot partition
FIT: No FIartition
ANDROID: reboot reason: "(none)"
optee api revision: 2.0
TEEC: Waring: Could not find security partition
Not AVB images, AVB skip
android_image_lot find part: boot
Android image load failed
Android boot failed, error -1.
MMC error: The cmd index is 1, ret is -110
Card did not respond
mmc0(part 0) is current device
Scanning mmc 0:2...
Found /extlinux/extlinux.conf
Retrieving file: /extlinux/extlinreading /extlinux/extlinux.conf
285 bytes read in 15 ms (18.6 Ki        Manjaro ARM
Retrieving file: /initramfs-linux.img
reading /initramfs-linux.img
7788335 bytes read in 59 ms (125.9 MiB/s)
Retrieving file: /Imareading /Image
29518336 bytes read in 187 ms (150.5 MiB/s)
append: initrd=/initramfs-linux.img root=PARTUUID=d35c868c-5a33-4bae-b2f6-f0cb5b2aac3a rw earlycon=uart8250,mmio32,,1500000n8 s
Retrieving file: /dtbs/rockchip/rk3566-reading /dtbs/rockchip/rk3566-quartz64-a.dtb
104865 bytes read in 28 ms (3.6 MiB/s)
Fdt Ramdisk skip relocation
## Flattened Device Tree blob at 0x0a100000
  Booting using the fdt blob at 0x0a100000
  Using Device Tree in place at 000000000a100000, end 000000000a11c9a0
can't found rockchip,drm-logo, use rockchip,fb-logo
WARNING: could not set reg FDT_ERR_BADOFFSET.
failed to reserve fb-loader-logo memory
Adding bank: 0x00200000 - 0x08400000 (sisize: 0xe6c00000)
Adding bank: 0x100000000 - 0x200000000 (size: 0x100000000)
Total: 786.452 ms

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x0000000000 [0x412fd050]
[    0.000000] Linux verGCC) 10.2.0, GNU ld (GNU Binutils) 2.35) #1 SMP PREEMPT Fri Sep 17 12:52:46 UTC 2021
[    0.000ne64 RK3566 Quartz64-A Board
[    0.000000] earlycon: uart8250 000] printk: bootconsole [uart8250] enabled
[    3.048209] rockchip-usb2phy fe8a0000.usb2-phy: failed to cre[    3.067859] arm-scmi firmwareConfusedcmi: Failed. SCMI protocol 2e
[    3.496594] arm-scmi firmwareConfusedcmi: Failed. SCMI protocol 19 not active.
[    3.499908] arm-scmi firmwareConfusedcmi: Failed. SCMI protocol 17 [    3.561017] rockchip-dw-pcie 3c0000000.pcie: invalid resour)
Starting version 249.4-1-arch


----

and then nothing anymore... Am I missing something? I would expect to get a prompt after a while, or something. thx!
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)