podcast shuts down after 10 minutes or perhaps bluetooth
#1
I am running the podcast app and listening to hour long shows.
If I allow the screen to go dark (blank) after about 10 minutes the audio to the bluetooth announces disconnected.

However if I keep the screen active 100% of the time things work fine.

Though this burns through the battery unnecessarily.

What can I do to keep the bluetooth from being disconnected while the screen is blanked?
  Reply
#2
(06-18-2021, 12:34 AM)motox6 Wrote: I am running the podcast app and listening to hour long shows.
If I allow the screen to go dark (blank) after about 10 minutes the audio to the bluetooth announces disconnected.

However if I keep the screen active 100% of the time things work fine.

Though this burns through the battery unnecessarily.

What can I do to keep the bluetooth from being disconnected while the screen is blanked?
You can either disable suspend in the power settings or start the app this way:
Code:
gnome-session-inhibit --inhibit suspend gnome-podcasts

Edit: You may want to replace the gnome-podcasts command with the command for the app you are using in case it's a different one or with --inhibit-only to inhibit suspend generally (not just while a specified app is running).
  Reply
#3
I use the flatpak version of podcasts.

I modified:

/var/lib/flatpak/exports/share/applications/org.gnome.Podcasts.desktop

with

Exec=gnome-session-inhibit --inhibit /usr/bin/flatpak run --branch=stable --arch=aarch64 --command=gnome-podcasts org.gnome.Podcasts

The podcast, bluetooth, wifi, basically everything, still shuts down after 10 minutes.
  Reply
#4
(06-22-2021, 12:47 AM)motox6 Wrote: I use the flatpak version of podcasts.

I modified:

/var/lib/flatpak/exports/share/applications/org.gnome.Podcasts.desktop

with

Exec=gnome-session-inhibit --inhibit /usr/bin/flatpak run --branch=stable --arch=aarch64 --command=gnome-podcasts org.gnome.Podcasts

The podcast, bluetooth, wifi, basically everything, still shuts down after 10 minutes.
I noticed that too with Gnome Podcasts (not flatpak, but from Manjaro repos). I think it has something to do with Podcasts being started as "gnome-podcasts --gapplication-service" when started with the desktop file. It doesn't seem to take the new exec command. If I start it by entering the exec command in the terminal, it works. I tried adding gnome-session-inhibit to other desktop files and that worked too.
  Reply
#5
(06-22-2021, 01:05 AM)kqlnut Wrote:
(06-22-2021, 12:47 AM)motox6 Wrote: I use the flatpak version of podcasts.

I modified:

/var/lib/flatpak/exports/share/applications/org.gnome.Podcasts.desktop

with

Exec=gnome-session-inhibit --inhibit /usr/bin/flatpak run --branch=stable --arch=aarch64 --command=gnome-podcasts org.gnome.Podcasts

The podcast, bluetooth, wifi, basically everything, still shuts down after 10 minutes.
I noticed that too with Gnome Podcasts (not flatpak, but from Manjaro repos). I think it has something to do with Podcasts being started as "gnome-podcasts --gapplication-service" when started with the desktop file. It doesn't seem to take the new exec command. If I start it by entering the exec command in the terminal, it works. I tried adding gnome-session-inhibit to other desktop files and that worked too.

Is it that the pinephone is set to go to standby after 10 min on battery?
I suppose we need to optimize audio apps to force keep-awake but minimize CPU and mostly use audio processor, especially when in locked mode.
This podcast app is something we need on the repos, it is one of the things(and battery life in stable kernel) keeping my pinephone from replacing my N900 and being my everyday device.
I put Panucci in the recommend apps(I use it on my N900, it is FOSS and I can compile it for current desktop Debian AMD64.)
https://wiki.mobian-project.org/doku.php?id=wishlist
I dont love flatpack or snap and prefer to stick with apt packages.
(edit)
I installed this on desktop and it is definitely a podcast specific app and not also an audiobook player like Panucci.
  Reply
#6
Settings -> Power -> Automatic Suspend -> When on battery Power -> Delay ... is the one that is killing the bluetooth and audio.
I set it to 1 hour.

The inhibit feature mentioned earlier has no effect.
  Reply
#7
(06-25-2021, 06:36 PM)motox6 Wrote: Settings -> Power -> Automatic Suspend -> When on battery Power -> Delay ... is the one that is killing the bluetooth and audio.
I set it to 1 hour.

The inhibit feature mentioned earlier has no effect.
Yes, that's the setting for suspend. Have you tried starting the podcast app with the gnome-session-inhibit command in the terminal? That successfully disables suspend for Gnome Podcasts for me.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  phone call using built it app will not go to bluetooth motox6 3 370 06-28-2021, 11:03 AM
Last Post: wibble
  Jerky wifi and bluetooth motox6 0 223 06-22-2021, 12:50 AM
Last Post: motox6
Information Bluetooth DIsconnect Problems? RTP 3 1,347 05-20-2021, 09:28 AM
Last Post: Emichel2020
  Bluetooth audio stalling (maybe the whole phone) motox6 1 309 05-18-2021, 10:15 AM
Last Post: wibble
  Is there a better audio / podcast player? motox6 8 2,961 01-15-2021, 08:56 AM
Last Post: 3x5co
  How to improve Bluetooth audio quality CyberSeb 6 3,583 07-28-2020, 01:21 PM
Last Post: CyberSeb
  Pinephone doesn't stay connected to bluetooth audio devices. tims1979 1 1,158 07-03-2020, 01:46 PM
Last Post: tims1979

Forum Jump:


Users browsing this thread: 1 Guest(s)