Internet not working properly
I have set up a 32GB SD card from pine64-image-debianmate-310101bsp.img.xz with command xzcat /media/pine64-image-debianmate-310101bsp.img.xz|pv|sudo dd of=/dev/sdc bs=1M oflag=sync

I have the 2GB version of pine64 with WiFi native board installed. Once I plug the micro sd card it boots (albeit taking more than 1 minute to get me to the desktop).

From the debian mate desktop I can set up the wifi connection and I can see the connection is set up. I can also do sudo apt-get update / upgrade. But when I try to access websites with Iceweasel I get errors. For example works but doesn't work.

I have tried also git clone from github but I get an error Failed to connect to port 443: No route to host

My ISP is ipv6 based. Any other device in the house (Windows PC, Linux PC, Android device) have standard DHCP settings and all work without problems. What can I check/set on the pine board to get complete connectivity?
edit /etc/resolv.conf

add your preferred dns entries there


If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
If I connect the pine64 by Ethernet cable, the internet works properly and the contents of the resolv.conf are
domain home
search home

If I don't connect the pine64 by cable & only use the wifi board, the internet doesn't work and the contents of the resolv.conf are
# Generated by NetworkManager
search home
nameserver 2a02:908:2:a::1
nameserver 2a02:908:2:b::1

If I try to replace the /etc/resolv.conf with the "ethernet-only" one, it still doesn't work. If I try to make sudo service network-manager restart , the /etc/resolv.conf is regenerated.

So it seems that the network manager is adding the ipv6 nameservers which don't work properly. I checked in the other computers and the /etc/resolv.conf only have standard ipv4 nameservers (again, with standard DHCP settings).

Any ideas?

Possibly Related Threads…
Thread Author Replies Views Last Post
Information Howto: OctoPrint Working on Pine 64 chaos_actual125 22 48,281 07-11-2021, 04:13 AM
Last Post: zer0sig
  Captive portal at school not working on the Pinebook pro WilliamZieg 2 4,416 02-06-2020, 10:41 PM
Last Post: xmixahlx
  Q4OS WiFi Dongle not working cheezmeister 3 4,548 04-07-2017, 08:01 AM
Last Post: iccoldbeer
  HowTo working with MPD and analog sound caragk 3 12,759 11-09-2016, 08:44 AM
Last Post: jkmooney
Exclamation JAVA App. not working correct wrongway 0 2,085 09-14-2016, 11:14 AM
Last Post: wrongway
  FAT-fs (sda2): Volume was not properly unmounted janeku 4 7,067 09-04-2016, 12:29 PM
Last Post: MarkHaysHarris777
  Anyone got jackd working? jkmooney 4 5,968 08-27-2016, 08:18 AM
Last Post: pfeerick
  wget not working? slerched 3 5,213 06-01-2016, 08:15 AM
Last Post: slerched
  Wireless mouse & kbd recognized but not working thehamguy1 9 10,475 05-17-2016, 11:44 AM
Last Post: thehamguy1

Forum Jump:

Users browsing this thread: 1 Guest(s)