PineTab Mobian Upgrade issue - Pin no longer works
#1
I have had lots of issues trying to get Mobian to work and I am confused by my most recent problem.  Maybe one of you have resolved this issue.

Background: I could not get the latest installer (mobian-installer-pinetab-phosh-alpha5.img.gz) or the latest build (mobian-pinetab-phosh-20210314.img.gz) to work by flashing the eMMC using JumpDrive 0.7 with bmap or dd.  I tried both encrypted and unencrypted with the installer.  The installer finished, but both choices resulted in a system that did not boot.  With the latest build, it would resize, and then go to black.  Reboots would flash the Mobian logo and then be black.  I started flashing older builds using the same process with success.  I do not have the serial cable to investigate the black screen issue further.

Now I am having trouble updating the old builds (mobian-pinetab-phosh-20201215.img.gz) to the latest version.  If I use the Software app and try to update, I run into the "Gnome Software (gnome-software) unable to download updates" issue listed on the troubleshooting section of the Mobian wiki [1].

The wiki suggests running these commands using King's Cross app:

Code:
sudo apt-get install packagekit-tools
sudo pkcon repair
sudo pkcon update

I do that and answer y enter to the apt-get install and pkcon update.  Everything appears to be updating.  If the device falls asleep during the update, my old pin no longer works!  I swipe up, enter the pin, tap unlock, it says Checking..., shakes, and returns to the Enter Passcode screen.  I tried twice with the default 1234 and a new updated numerical pin.  Both have the same behavior.  I even tried with an older build (mobian-pinetab-20201005.img.gz) and it had the same behavior.

If I plug a USB keyboard into the PineTab, I can enter a different TTY to access a command line with CTRL+ALT+F3.  I can login with username mobian and password 1234 so I can verify that the pin is correct.

Any troubleshooting ideas?  I could try the entire process a third time and make sure that the screen does not sleep, but this seems like a big issue that could affect others.

[1] https://wiki.mobian-project.org/doku.php...ad-updates
  Reply
#2
I figured out a workaround, but I needed to use a physical USB keyboard.  A more user friendly option for others would be helpful.  I then ran into another issue in the process and found another workaround for that.

After getting locked out, I left the PineTab alone to complete the update over night.  Pin entry still did not work.

Workaround: I plugged in a keyboard, entered a TTY with CTRL+ALT+F3, logged in with username mobian and my pin as the password.  I gracefully rebooted.

Code:
sudo shutdown -r now

The PineTab booted successfully.  Pin then worked.

I tapped the Software app.  Package information was downloaded.  I tapped on the updates tab.  There were then OS Updates again.  I tapped Download.  I tapped Restart & Update.  I tapped Restart.  Reboot successful.  I did this several times in a loop.

The only update is f2fs-tools 1.11.0-1.1.  Restart & Update would not update that package.

I ran sudo pkcon repair && sudo pkcon update again.  Result: There are no updates available at this time.

Opened Software.  Refreshed.  Still have f2fs-tools update available....

I ran these commands:

Code:
sudo apt update && sudo apt upgrade -y


Lists f2fs-tools.  Upgrading...  Rebuilding initrd.img... Making sure to not make it go to sleep...  Finished!

Retried Software app.  Refreshed... "Software is up to date"  Success!

Unless I am missing something, this process seems to be the way to install and update Mobian for the first time which is not very user friendly.  I will add my notes to the Mobian wiki, but let me know if you know of better processes for these issues.
  Reply
#3
I'm sorry for you that no one of the "cracks" answered to your issue. The mobian section (and PineTab in general) seems not really busy at the moment. Either it works so well or they have all given up Big Grin

I didn't try the alpha installer since I have no need for encryption. Just "dd" the image to the eMMC using jump drive what worked flawless in my case. But that's long ago. The "software" app seems broken at the moment. I update only in terminal anyway.

Good that you have found a solution and shared your experience. Keep on trucking Smile
  Reply
#4
I was able to update through the software app the following time after that successfully!  Maybe the issue is fixed now after you upgrade to a certain point.

Now that I have a working system, I am most impressed with the battery life at idle.  I could use it for light browsing and brief research for several days and it stayed above 90% battery.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  PineTab Mobian bcnaz 139 46,707 04-30-2021, 06:58 AM
Last Post: thomzane
  Arch Linux ARM on PineTab Danct12 22 9,583 03-30-2021, 01:44 AM
Last Post: RTP
  Video Tutorial: SDR/GQRX- Listening In To Voice On Pinetab (Internal SDR) RTP 1 495 03-08-2021, 09:33 AM
Last Post: barray
  Use Pinebook (not pro) image for pineTAB? dhosh 2 469 02-27-2021, 06:37 PM
Last Post: barray
  PineTab Mobian LXDE desktop fjord 0 396 02-24-2021, 06:32 PM
Last Post: fjord
  Pinetab Mobian optimization tomoqv 13 3,438 02-06-2021, 04:36 AM
Last Post: barray
Bug Porting lora (meshtastic) to Pinetab, some questions... geeksville 2 1,308 11-19-2020, 11:37 PM
Last Post: jeremyrutman
  VS Code running on PineTab brentashley 7 3,635 10-15-2020, 08:07 AM
Last Post: m.alizade7
  Mobian and HW performance guenther 4 2,137 10-10-2020, 07:42 PM
Last Post: metreo
  How get gcc for new PineTab? PaulWalters 1 971 10-07-2020, 03:56 AM
Last Post: wibble

Forum Jump:


Users browsing this thread: 1 Guest(s)