Installing Mobian --> "Resizing file system" forever
#11
(03-22-2021, 03:42 PM)Anna Wrote: To install Mobian on an SD card I, all I theoretically have to do is to download mobian-pinephone-phosh-20210314.img.gz, write it to the card, put the card into the phone and start it, right?

However, when I do that, the "resizing file system during initial boot" screen is there for quite a long time (30 minutes maybe) and afterwards the screen turns black (not pitch black though, the display remains switched on) and that's it.

I have used two different 64 GB cards  (a new Sandisk Extreme and and old Sandisk Ultra). I used BalenaEtcher and I tried
Code:
sudo zcat mobian-pinephone-phosh-20210314.img.gz | sudo dd of=/dev/mmcblk0 bs=1M

What am I doing wrong? Huh

If you are using Balena Etcher :
      You do not SUDO  anything.

You simply download Mobian,  then use Balena Etcher to flash your sd card.

<(You Can prep your sd card,   IF   you so desire,  format or zero wipe or whatever)>

I have been using Balena Etcher and Mobian since the first release of Mobian.  

   * (actually that's all I have ever used,  -  since I purchased my first Pinebook Pro, from the first public sales,  second batch I think, Sept. 2019)
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#12
(08-31-2021, 11:59 PM)bcnaz Wrote: If you are using Balena Etcher :
      You do not SUDO  anything.

Thanks! Sorry if I did not express myself clearly: I had tried "sudo zcat..." and, after that attempt failed, I tried Balena Etcher, both several times.

The solution was @dukla2000 's answer.
  Reply
#13
Hello,

our Pinephone arrived about a week ago and I had the "resizing forever" issue with mobian-pinephone-phosh-2021051 yesterday. My solution was to resize it manually before inserting the SD into the computer.

Just wanted to say that the filesystem is f2fs, not ext2 as described in the Installation Instructions

For me, these commands worked:

Code:
: sudo bmaptool copy --bmap Downloads/mobian-pinephone-phosh-20210517.img.bmap Downloads/mobian-pinephone-phosh-20210517.img.gz /dev/mmcblk0
: sudo growpart /dev/mmcblk0 2
: sudo resize.f2fs /dev/mmcblk0p2
  Reply
#14
(09-09-2021, 02:42 AM)loderunner Wrote: Just wanted to say that the filesystem is f2fs, not ext2 as described in the Installation Instructions

Just wanted to say, that these are not the installation instructions for mobian which has it's own.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Has anyone got briar-desktop running on mobian? vusra 4 758 11-29-2022, 01:35 PM
Last Post: Fish
  Axolotl on PinePhone / Mobian arno_nuehm 203 95,482 11-10-2022, 02:40 AM
Last Post: arno_nuehm
  Battery problem with a Pinephone keyboard and Mobian elode 1 517 10-28-2022, 02:24 PM
Last Post: presire
  Mobian external display woes Hiraghm 4 371 10-22-2022, 06:29 PM
Last Post: Hiraghm
Wink Pinephone lost graphic during mobian system upgrade cmpin 0 259 10-18-2022, 12:55 AM
Last Post: cmpin
  Latest Reliable Mobian Build Confirmation Thread Katsujinken 5 771 09-27-2022, 08:41 AM
Last Post: Katsujinken
  low disk space on file system root revisited benedikt55 2 359 09-24-2022, 10:16 AM
Last Post: benedikt55
  Rescue Your Mobian post Update Aug22 faster fix to working guide biketool 9 1,350 09-05-2022, 12:10 AM
Last Post: biketool
  Lot of issues after flashing mobian to emmc with tow-boot benedikt55 5 691 08-30-2022, 01:14 PM
Last Post: benedikt55
  How to check which mobian build I am running jojuma 0 242 08-29-2022, 04:44 AM
Last Post: jojuma

Forum Jump:


Users browsing this thread: 1 Guest(s)