Is there an encryption package missing from mobian?
#1
Hi everyone,

I just tried to access a luks sdcard and a luks usb stick from a pinephone loaded with the last encrypted installer image of mobian.

I ran nemo and saw the new drive on the left pane, but when I clicked on it and entered the luks password, it came up with this error:

"Unable to mount 31Gb encrypted  Error unlocking /dev/-mmcblk0p3 - The function bd_crypto_luks_open_blob called but not implemented"

I did some web searching and found instructions to do the following, which I tried:

sudo apt install libblockdev-crypto2
systemctl restart udisks2.service

This seems to work, and both the sdcard and the usb stick seemed to mount sucessfully in nemo.

Has the package libblockdev-crypto2 been forgotten, or maybe been left out for a reason?

Any feedback much appreciated?

Regards!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Why do you use mobian? unrealb2 14 385 Yesterday, 04:30 PM
Last Post: ryo
  Mobian September 13 Nightly bcnaz 1 118 09-14-2021, 03:50 PM
Last Post: bcnaz
  Updating old Mobian installation? SocialNetworkingWasAMistake 1 49 09-14-2021, 03:41 PM
Last Post: bcnaz
  Installing Mobian --> "Resizing file system" forever Anna 13 2,795 09-09-2021, 04:26 AM
Last Post: spaetz
  Axolotl on PinePhone / Mobian arno_nuehm 111 32,059 09-06-2021, 02:29 PM
Last Post: arno_nuehm
  I'd like to have a Discord client on Mobian lsitongia 2 134 09-03-2021, 06:56 PM
Last Post: ryo
  Mobian September 01, 2021 bcnaz 2 288 09-01-2021, 11:45 AM
Last Post: bcnaz
  Mobian 'HotSpot" bcnaz 2 349 08-29-2021, 07:34 AM
Last Post: bcnaz
  mobile data on mobian not working synaption 10 772 08-29-2021, 07:22 AM
Last Post: bcnaz
  Hot Spot on Mobian/Bookworm ? bcnaz 1 148 08-29-2021, 02:47 AM
Last Post: bcnaz

Forum Jump:


Users browsing this thread: 1 Guest(s)