wifi not working
#1
i installed the latest arch image from (iirc) 23.12 but i am not able to connect to my wifi.
it is found but when i hit connect it asks for the password, i enter it, the wheel is spinning, then it asks again, in a loop.
i used the same password for ubports and on my tablet, so it is 100% the correct password.
anyone an idea what could cause that or how to debug that to get more information?
  Reply
#2
(01-02-2021, 05:26 AM)someGermanGuy Wrote: i installed the latest arch image from (iirc) 23.12 but i am not able to connect to my wifi.
it is found but when i hit connect it asks for the password, i enter it, the wheel is spinning, then it asks again, in a loop.
i used the same password for ubports and on my tablet, so it is 100% the correct password.
anyone an idea what could cause that or how to debug that to get more information?

I have that same build from December 23rd from this page. https://github.com/dreemurrs-embedded/Pi...h/releases  My wifi works fine. Maybe re-flash the image again and see if it works. That is probably the first step I'd do since it works for everyone else except you. 

Secondly, maybe do a dmesg and see if all your hardware is starting up properly. I'm pretty confident this is either a user error or your hardware has gone bad. What version of Pine Phone do you have?
  Reply
#3
I've never been able to connect using WPA2/AES on my old Netgear router AP with any PinePhone OS that I've tried. Thus, I have no secure connection available, other than Ethernet copper via the dock! Huh

https://forum.manjaro.org/t/pinephone-ca...fi/35556/8
  Reply
#4
i found a workaround. i connected manually. when i tried to use the detected AP it did not work. when i configured it manually and selected WPA2 it worked.
i *guess* this is because my AP provides wpa3 AND wpa2
  Reply
#5
(01-05-2021, 03:49 PM)someGermanGuy Wrote: i found a workaround. i connected manually. when i tried to use the detected AP it did not work. when i configured it manually and selected WPA2 it worked.
i *guess* this is because my AP provides wpa3 AND wpa2
Did you still use the GUI to disable autoconnect or did you use the CLI? I tried using the GUI, but it still fails (acts like the password is incorrect) and pops up a box to retype the password, but of course the password is correct and it still won't connect. I only have WEP and WPA2 however. I've never tried WEP because it's old and insecure (not quite as bad as using my "guest" wifi channel that is open) but at least I can keep my home network protected under WPA2.

Thanks for your report though!
  Reply
#6
i did not use the CLI at all, i was only using the GUI - to disable and manually connect to it
  Reply
#7
(01-14-2021, 08:12 AM)someGermanGuy Wrote: i did not use the CLI at all, i was only using the GUI - to disable and manually connect to it
Thanks for the clarification and, again, thanks for your report!
  Reply
#8
I've had this problem with my ubiquiti AP. 
I fixed it quite trivially by connecting to internet via the USB convergence kit to Ethernet, and then running:
sudo pacman -Syu

After that, wifi worked fine.  I never can get the GUI software update to work quite right.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)