Java Installations and Compatibility
Hello everyone, 

This is my first post here so if I am posting in the wrong location or format please let me know. I hope to start to become active in these forums as I learn more about the Pinebook Pro. 

I have been testing various relatively simple programs on the PBP to get myself acquainted with it. I decided to see how old school Runescape works/runs and if I would encounter any problems. Of all the things I have done with the PBP since it arrived a week or so ago this has by far given me the most difficulty, and unless I missed something in the requirements to play I believe it boils down to a java problem. I have downloaded various forms of java, java web apps to attempt to get it to run in the browser, and tried switching between default versions to get it to run. The launchers crash or never show a GUI, and the browser remains blank. 

Has anyone encountered similar difficulties with other java based programs? I recognize the answer here may be relatively obvious but as an enthusiastic beginner I cant help but feel there is something I am missing. 

I really appreciate any help, insight, or pointers in advance, thanks!
Hi, did you find out more about this?

I use two java programs: the Arduino IDE, and a hardware interface written by the hardware device's manufacturer. Both take more than a minute to start, but then work ok.

Earlier on, the Arduino IDE would take a similarly long time to react to each input, making it unusable. It has since gotten better without me knowingly doing anything, so some system update affected it. I didn't have the hardware interface back then to compare.
I can add a few things I learned today. The hardware interface I was using wasn't recognizing the serial-to-usb cable though Linux was correctly loading the driver and assigning it to ttyUSB0. I asked the company about it and they said they've had trouble with openjdk and could I try the official Oracle version?

That led me to learn how to switch the java runtime in Arch/Manjaro: the archlinux-java command. It showed that my default Manjaro installation had openjre versions 8 and 15 and that 8 was set to default.

Opening that hardware program take 5 minutes 48 seconds using the default version 8. Version 15 takes just 22 seconds! That's still slow to open a program, but wow what a difference!

I tried installing the Oracle version from the AUR. It isn't for aarch64, but in my experience adding 'aarch64' to the build file often works. For the Oracle JRE, it compiles after adding that, but the java program wouldn't run.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Openjdk-11-jdk / Java on Arm64 AJN 2 2,504 01-25-2020, 01:57 AM
Last Post: xmixahlx

Forum Jump:

Users browsing this thread: 1 Guest(s)