Modem can't dial out
#1
Finally took the plunge and moved phone service to my pinephone, time to get on the cutting edge of Open Source.... ouch.

Can send and receive SMS, can receive calls.  Can't call out.

Here is what showed in .xsession-errors
Code:
** (sm.puri.Calls:3442): WARNING **: 12:55:03.573: Error starting outgoing call ModemManager call to `13374636217': GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Failed: Couldn't start the call: Unhandled response '+QLWURC: "pdp active","failed","nxtgenphone"

+QLWURC: "deregister",0'
** Message: 12:55:03.606: Removing call `/org/freedesktop/ModemManager1/Call/0'
** Message: 12:55:03.607: Call `/org/freedesktop/ModemManager1/Call/0' removed
And logread:

Code:
Nov 20 12:55:03 pinephone daemon.info [2839]: <info>  [modem0/call0] user request to start call
Nov 20 12:55:03 pinephone daemon.info [2839]: <info>  [modem0/call0] call state changed: unknown -> dialing (outgoing-started)
Nov 20 12:55:03 pinephone daemon.warn [2839]: <warn>  [modem0/call0] couldn't start call: Couldn't start the call: Unhandled response '+QLWURC: "pdp active","failed","nxtgenphone"^M ^M +QLWURC: "deregister",0'
Nov 20 12:55:03 pinephone daemon.info [2839]: <info>  [modem0/call0] call state changed: dialing -> terminated (unknown)

Have the AT Command Reference for the modem, +QLWURC is not anywhere in it so digging there is going to be fun.  I'm on a paygo plan and it is charging me for two minutes of use on every attempt.  Occasionally I hear a fraction of a second of what sounds like the greeting for the called number.  So it isn't just failing instantly, something happens first.

Random bits that might matter.   The phone has no data plan so data is disabled in the control panel.  The APN settings have been set to what defaulted after the SIM went active and then to what www.bestmvno.com recommended for H2O Wireless... or would if the UI allowed input of most of the recommended settings.  Even though the subscribed plan has "LTE" in the name, the phone insists on connecting to 3G, forcing 4G Only gets no service.  There IS 4G service from AT&T in the area.
#2
(11-20-2020, 01:07 PM)jmorris Wrote: Finally took the plunge and moved phone service to my pinephone, time to get on the cutting edge of Open Source.... ouch.

Can send and receive SMS, can receive calls.  Can't call out.

Here is what showed in .xsession-errors
Code:
** (sm.puri.Calls:3442): WARNING **: 12:55:03.573: Error starting outgoing call ModemManager call to `13374636217': GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Failed: Couldn't start the call: Unhandled response '+QLWURC: "pdp active","failed","nxtgenphone"

+QLWURC: "deregister",0'
** Message: 12:55:03.606: Removing call `/org/freedesktop/ModemManager1/Call/0'
** Message: 12:55:03.607: Call `/org/freedesktop/ModemManager1/Call/0' removed
And logread:

Code:
Nov 20 12:55:03 pinephone daemon.info [2839]: <info>  [modem0/call0] user request to start call
Nov 20 12:55:03 pinephone daemon.info [2839]: <info>  [modem0/call0] call state changed: unknown -> dialing (outgoing-started)
Nov 20 12:55:03 pinephone daemon.warn [2839]: <warn>  [modem0/call0] couldn't start call: Couldn't start the call: Unhandled response '+QLWURC: "pdp active","failed","nxtgenphone"^M ^M +QLWURC: "deregister",0'
Nov 20 12:55:03 pinephone daemon.info [2839]: <info>  [modem0/call0] call state changed: dialing -> terminated (unknown)

Have the AT Command Reference for the modem, +QLWURC is not anywhere in it so digging there is going to be fun.  I'm on a paygo plan and it is charging me for two minutes of use on every attempt.  Occasionally I hear a fraction of a second of what sounds like the greeting for the called number.  So it isn't just failing instantly, something happens first.

Random bits that might matter.   The phone has no data plan so data is disabled in the control panel.  The APN settings have been set to what defaulted after the SIM went active and then to what www.bestmvno.com recommended for H2O Wireless... or would if the UI allowed input of most of the recommended settings.  Even though the subscribed plan has "LTE" in the name, the phone insists on connecting to 3G, forcing 4G Only gets no service.  There IS 4G service from AT&T in the area.
Let's start with the simple stuff - how many bars do you have? Is your signal strong? Next, did you set data on and 4g in the network settings? You indicated you did. But it's always good to check. You did not specify OS, some of the OS require you to set that manually. Next, please load Mobian onto an SD card and try again with it. Mobian is the most complete OS so far. Let us know whether it works on Mobian.

I have to say, several people have reported having trouble wirh AT&T based services these days. One even said they refused to let him on the network claiming it was not an at&t approved device. So, if you have another service to compare with, that would be good.
#3
(11-20-2020, 03:11 PM)rocket2nfinity Wrote:
(11-20-2020, 01:07 PM)jmorris Wrote: Can send and receive SMS, can receive calls.  Can't call out.
Next, please load Mobian onto an SD card and try again with it.
or try out a bunch of different distros:  
https://forum.pine64.org/showthread.php?tid=11347
for me UBPorts is the most functional and reliable as a daily driver.
If it isn't broken, take it apart and fix it.
#4
(11-20-2020, 03:11 PM)rocket2nfinity Wrote: Let's start with the simple stuff - how many bars do you have? Is your signal strong? Next, did you set data on and 4g in the network settings? You indicated you did. But it's always good to check. You did not specify OS, some of the OS require you to set that manually. Next, please load Mobian onto an SD card and try again with it. Mobian is the most complete OS so far. Let us know whether it works on Mobian.

I have to say, several people have reported having trouble wirh AT&T based services these days. One even said they refused to let him on the network claiming it was not an at&t approved device. So, if you have another service to compare with, that would be good.

Have the multidistribution in the SD slot, hadn't booted Mobian in a bit.  Good grief.  450+ updates later.......  No go, no better than PMOS.  So tried Plasma Neon.  Nope, same stuff.   How about UBPorts?  Looked like audio routing was broke but it took the number and started counting out a call duration so better.  Better still, it seems to have reprogrammed the modem because now PMOS is getting a 4G connection.  Before it only showed two bars of signal on 3G, now most places show three bars on 4G.  Calls still don't work any better though.

AT&T's logo might be the Death Star, and the rep well deserved, but H2O seems to be working.  SMS works both directions and inbound calls work.  Don't have data but I don't want it, if it accidentally gets turned on it would charge about $0.30/MB on this super basic paygo plan.  Think data has to be configured at some point anyway though, everything I have read says MMS requires it.

Spotted this in the logread output:

Code:
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: Failed to enable VoLTE profile auto selecting: Usage: atinout <input_file> <modem_device> <output_file>
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup:
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: <input_file> is a file with AT commands to be executed. Value '-' means standard input.
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: <input_file> is the device file for the modem (e.g. /dev/ttyACM0, /dev/ttyS0, etc).
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: <output_file> is a file the responses to the AT commands are saved. Value '-' means standard output.
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup:
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: In addition the program supports the following options:
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup:
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: -h|--help
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: -V|--version
Nov 21 00:57:13 pinephone user.notice postmarketOS:modem-setup: --usage
Nov 21 00:57:14 pinephone authpriv.info : pam_unix(autologin:session): session opened for user user(uid=10000) by (uid=0)
Wondering where this is supposed to be getting its input file from.
#5
I have several phones on the ATT PrePaid network,  they work great for talk & text,  NO APN is required for those operations.

  BUT, even with the paid data service they do not "ALLOW" me to access the internet.

I do "connect"  but I get an ATT gateway message stating that I do "not have a data account"..

ATT abuses the 'Covid Excuse' to give Crap help, after spending 3 days talking (and Holding) to their service reps and Techs
   They said in early March they were sending me a new sim card, but it would be delayed by the Covid, it is now mid November, still no sim card ! 

Meanwhile I do have other Pine phones using ATT Resellers (MVNO's) those do work and access the internet just fine. (TracFone and Pure Talk )


Note :  I am using Mobian and Arch operating systems on Brave Heart, Post Market, and Manjaro phones ... I do not have a UBPorts phone.

*
ADD-ON :
T-Mobile MVNO's (like Simple Mobile) do work, but where I live and where I visit most often their service is too weak to be dependable,
but if you live in an area they serve,  you could give them a try.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#6
*
*
You do not need any APN information for the sms text.

You do need APN information for mms text, but mms text is not yet supported on any Pine phone operating systems I have seen.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#7
Well, time to close this one. modemmanager just updated and outbound calls work.

Collecting logs though, got another bug report soon. Unlocking sometimes stops working, looks like the session manager is dying off.
#8
(11-21-2020, 08:35 PM)bcnaz Wrote: *
*
You do not need any APN information for the sms text.

You do need APN information for mms text, but mms text is not yet supported on any Pine phone operating systems I have seen.
Yup, no reason to be in any hurry.  Been digging.  nmcli has a ton of options to configure an APN, the control panel exposes name, username and password.  So the command line wins again.
#9
(11-20-2020, 04:27 PM)MonCon Wrote:
(11-20-2020, 03:11 PM)rocket2nfinity Wrote:
(11-20-2020, 01:07 PM)jmorris Wrote: Can send and receive SMS, can receive calls.  Can't call out.
Next, please load Mobian onto an SD card and try again with it.
or try out a bunch of different distros:  
https://forum.pine64.org/showthread.php?tid=11347
for me UBPorts is the most functional and reliable as a daily driver.
then why is this phone shipped with this dysfunctional pmos???!!!
#10
Have you updated the modem firmware?  There was another post that shared a modem update.
https://forum.pine64.org/showthread.php?tid=11815

I tried calling out today and it worked.  I am also with Bell on PMOS which might also make a different in that regard.

And do you know which Bands that your carrier use vs which are compatible with the pine phone?  I'm not sure it would make a difference since you can already text.


Possibly Related Threads…
Thread Author Replies Views Last Post
Thumbs Up Modem Shutdown/Startup Scripts big_fluff 0 473 05-08-2021, 12:59 AM
Last Post: big_fluff
  PMOS test image: failed EG25 test broke modem fw MtnSk8 4 1,436 02-28-2021, 02:20 PM
Last Post: MtnSk8
Question Can't figure out audio routing for modem strake 4 2,766 05-22-2020, 04:46 AM
Last Post: nieral

Forum Jump:


Users browsing this thread: 1 Guest(s)