Sound defaults to Headset
#1
Bug 
The fix is listed in this reply.



Is there any way to prevent the Sound Output and Input resetting to using the Headset?

In earlier builds, the Sound would default to the Internal speaker and microphone, and route audio through the earpiece when making a call.

After an indeterminate upgrade, Output and Input persistently reset to the Headset - despite being changed in the Sound (Settings) menu, or pavucontrol.
#2
Check out this discussion about checking and setting default devices in Pulseaudio.

Related question: were your headphones plugged in while this upgrade took place?
#3
@ThrillGates Thanks.

I'm using a Braveheart edition; I've only used headphones a couple of times for testing purposes, removing the jack immediately afterwards. So, probably not.
#4
(10-18-2020, 01:00 PM)jed Wrote: @ThrillGates Thanks.

I'm using a Braveheart edition; I've only used headphones a couple of times for testing purposes, removing the jack immediately afterwards. So, probably not.
I have the CE UBports edition. I never plug headphones and also it is always set at the headset. Very annoying because even if you changes, it goes back to headset. So no way to have a conversation the mic and audio are set to headphones.

@jed have you fixed? does @ThrillGates link works? I will try later.
#5
Thanks for the bump @natasha , I've been putting this off... PulseAudio is the bane of GNU/Linux.

The Internal and Headset ports are available via a single sink and source. The Headset has priority, you can evaluate this using pactl:

Code:
pactl list sources
pactl list sinks



Installing the 5.8 kernel solves this issue (comment).

Code:
sudo apt update && sudo apt install linux-image-5.8-sunxi64
sudo reboot

Headset now correctly manifests as 'Headset (Unplugged)'. The Internal speaker and Internal microphone are now the default.

Priorities are unchanged, meaning the active source and sink ports can change when a Headset is plugged in.
#6
(10-21-2020, 03:44 PM)jed Wrote: Thanks for the bump @natasha , I've been putting this off... PulseAudio is the bane of GNU/Linux.

The Internal and Headset ports are available via a single sink and source. The Headset has priority, you can evaluate this using pactl:

Code:
pactl list sources
pactl list sinks



Installing the 5.8 kernel solves this issue (comment).

Code:
sudo apt update && sudo apt install linux-image-5.8-sunxi64
sudo reboot

Headset now correctly manifests as 'Headset (Unplugged)'. The Internal speaker and Internal microphone are now the default.

Priorities are unchanged, meaning the active source and sink ports can change when a Headset is plugged in.
I was realizing that the headset problem was solved a few updates ago, but couldn't find the exact update that fixed it. 
now 'uname -a' gets me: Linux mobian 5.8-sunxi64 #6 SMP Sun Oct 18 12:56:04 UTC 2020 aarch64 GNU/Linux

for a while in the Setting - Output Device, the Test doesn't say "Front Right", and "Front Left" any more. Instead, it would have one of the 4 sounds for both channel. So then  just now, the 2nd time I hit test, and the woman's voice is back saying Front Right, Front Left.  The default is on the Internal mic.  Incoming calls have been working fine. No complaint about voice quality.
#7
I'm glad to read the newer kernel is working for you too @HLing Smile
#8
(10-21-2020, 03:44 PM)jed Wrote: Thanks for the bump @natasha , I've been putting this off... PulseAudio is the bane of GNU/Linux.

The Internal and Headset ports are available via a single sink and source. The Headset has priority, you can evaluate this using pactl:

Code:
pactl list sources
pactl list sinks



Installing the 5.8 kernel solves this issue (comment).

Code:
sudo apt update && sudo apt install linux-image-5.8-sunxi64
sudo reboot

Headset now correctly manifests as 'Headset (Unplugged)'. The Internal speaker and Internal microphone are now the default.

Priorities are unchanged, meaning the active source and sink ports can change when a Headset is plugged in.
yes, it fixed it!
thanks!
#9
(10-21-2020, 05:18 PM)jed Wrote: I'm glad to read the newer kernel is working for you too @HLing Smile

@jed , Thanks for clearing up the mystery.  I really should keep a  Mobian calendar so I know what happened when, and how something got fixed...
#10
Credit to Parthiv Seetharaman who opened the issue and closed it with the above fix.

I'll be keeping a closer eye on the Mobian issue tracker from now on! Blush


Possibly Related Threads…
Thread Author Replies Views Last Post
  No Sound After Reboots LMalilil 1 757 09-23-2020, 06:14 AM
Last Post: bobblestiltskin
  earpiece sound setting Gobelin 3 1,221 08-13-2020, 01:46 PM
Last Post: Gobelin

Forum Jump:


Users browsing this thread: 1 Guest(s)