noob with non booting rock64 4g
#1
Hi

ive read other posts and im trying to establish if my board has a HW issue.
ive flashed some raspberry pi (32 bit) previously so i believe im flashing my sd card ok.
i gave a green led on longside the power connector
i have a solid red and a while led on by the gpio pins.
the activity led on the nic port (on the usb side of the port) is solid amber regardless of cable in or out
the other nic led is always off.
the power button longside the white led turns all but the green led off.
there is no hdmi output .


what do i do next to determine if its a brick or not
#2
What image are you trying to boot?
#3
Hi

the last image i tried was Armbian_20.08.1_Rock64_bionic_current_5.8.6_desktop

regards
#4
Can't be certain but I think the Rock64 struggles with newer versions of Linux 5x. I'm using the following version


____ ___ ____ _ ____ _ _
| _ \ / _ \ / ___| |/ / /_ | || |
| |_) | | | | | | ' / '_ \| || |_
| _ <| |_| | |___| . \ (_) |__ _|
|_| \_\\___/ \____|_|\_\___/ |_|

Welcome to Debian Buster with Armbian Linux 4.4.192-rockchip64
System load: 0.01 0.02 0.00 Up time: 12 days
Memory usage: 14 % of 3988MB IP: 192.168.0.206
CPU temp: 47°C
Usage of /: 7% of 58G

[ General system configuration (beta): armbian-config ]



See if you grab the above version as I can confirm it works.
#5
IIRC i never managed to boot Buster in mainline, however it booted Focal with GUI. 5.8 6.
#6
(10-11-2020, 06:36 PM)Rocklobster Wrote: Can't be certain but I think the Rock64 struggles with newer versions of Linux 5x. I'm using the following version


____  ___  ____ _  ____  _  _ 
|  _ \ / _ \ / ___| |/ / /_ | || | 
| |_) | | | | |  | ' / '_ \| || |_
|  _ <| |_| | |___| . \ (_) |__  _|
|_| \_\\___/ \____|_|\_\___/  |_| 
                                   
Welcome to Debian Buster with Armbian Linux 4.4.192-rockchip64
System load:  0.01 0.02 0.00  Up time:      12 days         
Memory usage:  14 % of 3988MB  IP:            192.168.0.206
CPU temp:      47°C           
Usage of /:    7% of 58G       

[ General system configuration (beta): armbian-config ]



See if you grab the above version as I can confirm it works.

thanks

more of the same im afraid :-)
the lack of output from hdmi doesn't help.
#7
(10-12-2020, 01:58 PM)john72carter Wrote:
(10-11-2020, 06:36 PM)Rocklobster Wrote: Can't be certain but I think the Rock64 struggles with newer versions of Linux 5x. I'm using the following version


____  ___  ____ _  ____  _  _ 
|  _ \ / _ \ / ___| |/ / /_ | || | 
| |_) | | | | |  | ' / '_ \| || |_
|  _ <| |_| | |___| . \ (_) |__  _|
|_| \_\\___/ \____|_|\_\___/  |_| 
                                   
Welcome to Debian Buster with Armbian Linux 4.4.192-rockchip64
System load:  0.01 0.02 0.00  Up time:      12 days         
Memory usage:  14 % of 3988MB  IP:            192.168.0.206
CPU temp:      47°C           
Usage of /:    7% of 58G       

[ General system configuration (beta): armbian-config ]



See if you grab the above version as I can confirm it works.

thanks

more of the same im afraid :-)
the lack of output from hdmi doesn't help.

So connected up to HDMI you are seeing nothing. Make sure you have a good quality HDMI cable connected to the monitor and the board before you power up the Rock64

The only other thing to check I can think of is a bad SD card or a flaky power supply. Try substituting both and see if that helps.


Possibly Related Threads…
Thread Author Replies Views Last Post
  OpenWRT on the Rock64 CanadianBacon 5 895 03-31-2022, 01:29 PM
Last Post: CT456
  Rock64 bricked shawwwn 6 1,589 01-29-2022, 05:49 AM
Last Post: shawwwn
  Rock64 board not working, no HDMI no Ethernet. EDited 2 779 01-26-2022, 08:46 AM
Last Post: TRS-80
  Rock64 <--> Rock64 Serial Connection mark1250 1 599 12-23-2021, 09:27 PM
Last Post: barray
  Are you guys still using Ayufan's OMV on your Rock64? AkiraSensei 0 601 11-26-2021, 07:01 PM
Last Post: AkiraSensei
  Rock64 kernel panics clay 15 4,154 10-17-2021, 06:30 PM
Last Post: Rocklobster
  Pine Rock64 eMMC lifespan moonspell79 3 1,730 08-19-2021, 06:46 PM
Last Post: bcnaz
  Rock64 No Audio - Solved wbecks 12 21,683 08-13-2021, 01:23 PM
Last Post: blakeadam
  Trustzone support for Rock64 capablegh 1 1,230 07-17-2021, 10:15 AM
Last Post: capablegh
  Python GPIO Library for the Rock64 (R64.GPIO) Leapo 37 46,875 07-02-2021, 03:20 PM
Last Post: klausfelix

Forum Jump:


Users browsing this thread: 1 Guest(s)