libertine and desktop apps
#1
Just got my Pinetab, seriously impressed with build quality and usability out of the box, but has anyone had success with libertine?  I just started poking around it and I'm looking for good sources of information on lxc and lxd containers.  I could be missing something but I've been trying to get FireFox to work with little success as of yet.  I'm going to spend a bit of time on it today to see what I can sort out from the console output.
  Reply
#2
(09-12-2020, 10:33 AM)m4xx3d0ut Wrote: Just got my Pinetab, seriously impressed with build quality and usability out of the box, but has anyone had success with libertine?  I just started poking around it and I'm looking for good sources of information on lxc and lxd containers.  I could be missing something but I've been trying to get FireFox to work with little success as of yet.  I'm going to spend a bit of time on it today to see what I can sort out from the console output.

I am just trying it today from a command line. I couldn't get the GUI to work but the CLI works OK -- maybe.

From a terminal:

libertine-container-manager create -i TEST
libertine-container-manager install-package -i test -p gimp

I do get some kind of proot warning about /run/shm too many levels of symbolic links.

That puts a Gimp icon on the launcher but doesn't seem to want to run from the GUI or using libertine-launch that I can figure out yet.

Update:
So there appear to be multiple ways to run:

libertine-launch -i test gimp
ubuntu-app-launch test_gimp_0.0 # tab completion works
libertine-container-manager exec -i test -c "gimp"

None of these work because they can't find Xmir (or libertine-xmir) running. But you can do something like:
dbus-launch libertine-launch -i test ls /etc

The dbus part seems critical, though. Without it, you can't find the maliit input method stuff. Not sure why. But if you replace the ls with gimp, you can't find the Xmir display. The Wayland socket appears to be in /var/run/user/####/wayland-0 and the ##### part is always 32011 for me, but not sure if that's always true....

Update 2. As far as I can tell, the issue is that Xmir expects Mir and we have Wayland. So while it is looking for mir_socket, we have wayland-0. I doubt just plumbing them together would do anything.
  Reply
#3
I think it was one of the ubports devs that said in the telegram/discord/irc/matrix chat that gui won't be possible for the moment, because there are missing parts for the gui as you encountered.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Important apps stopped working yurievitch 2 399 03-30-2021, 08:34 AM
Last Post: kimiles
  PineTab Mobian LXDE desktop fjord 0 215 02-24-2021, 06:32 PM
Last Post: fjord
  Arch, Plasma desktop and wayland peperjohnny 48 12,947 02-02-2021, 06:14 AM
Last Post: wd5gnr

Forum Jump:


Users browsing this thread: 1 Guest(s)