Wifi not working
#1
I just received my Postmarket Edition of the PinePhone.  Got it all setup everything was working great but the wifi stopped working.

When I try to reload the wifi kernel module I'm seeing this error in dmesg.  Any insight to what might be going on here?
#2
(09-02-2020, 09:41 AM)dbrandon Wrote: I just received my Postmarket Edition of the PinePhone.  Got it all setup everything was working great but the wifi stopped working.

When I try to reload the wifi kernel module I'm seeing this error in dmesg.  Any insight to what might be going on here?

I also want to make sure it is clear I removed the sticker blocking the battery contacts.
#3
I do not see the message attached to your post. But if you could give me a little more detail on how to entered this state and discovered an issue with wifi I am interested in trying to recreate your issue.

Here is a doc that I use when trying to write up steps for others.

Let me know stuff like timeline.
#4
(09-02-2020, 11:04 AM)plainenough Wrote: I do not see the message attached to your post. But if you could give me a little more detail on how to entered this state and discovered an issue with wifi I am interested in trying to recreate your issue.

Here is a doc that I use when trying to write up steps for others.

Let me know stuff like timeline.
I didn't add the error message from dmesg

```rtl8723cs: probe of mmc1:0001:1 failed with error -110```

I just rebooted the phone and now the device isn't showing up.  There isn't a clear path to reproduce.
#5
I'm going to guess that this is a timeout while initializing the driver.

Here are my thoughts.
https://www-numi.fnal.gov/offline_softwa...rrors.html
https://github.com/ayufan-pine64/rtl8723cs

Looks like you are timing out, I would bet it is related to something in the suspend functionality. Does wifi work after reboot?
#6
(09-02-2020, 03:32 PM)plainenough Wrote: I'm going to guess that this is a timeout while initializing the driver. 

Here are my thoughts.
https://www-numi.fnal.gov/offline_softwa...rrors.html
https://github.com/ayufan-pine64/rtl8723cs

Looks like you are timing out, I would bet it is related to something in the suspend functionality. Does wifi work after reboot?
It doesn't work after a reboot.
#7
I did notice in my wifi menu that it said something like "wifi adapter not found"  My solution was to tap the switch at the top of the screen to turn Wifi on.  

I know this solution won't help everybody; but at first I didn't find the UI to be the clearest so I hope this may help someone.
#8
I let the battery get below 20% on the device and it has been stuck at 16% plugged in for several hours. Based on other posts, the wifi must not be working because of a bad battery. I'm not sure since I don't have a second battery to test that hypothesis.
#9
The wifi chip uses some power directly from the battery, so if the battery level is too low or there's no battery inserted the chip won't start causing this error.
#10
I seem to have same problem. I have 90+% battery and bluetooth seems to work.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Physical keyboard symbols not working again vgnmnky 2 499 07-25-2022, 11:46 AM
Last Post: explit
Question No connection to internet without wifi :/ elode 3 1,043 03-16-2022, 04:15 PM
Last Post: bcnaz
  Wifi and bluetooth disabled after upgrading to PMOS kernel 5.9.1 aithal 0 1,390 11-09-2020, 01:17 AM
Last Post: aithal
  Working Mailprogram with IMAP pine_sw 6 5,010 10-06-2020, 02:02 AM
Last Post: hiimtye
  Online account (google) not working RodMyers 6 5,831 09-18-2020, 03:58 AM
Last Post: mactoni
Question WiFi looks to be working, but ... vidarr 2 2,334 09-08-2020, 04:21 PM
Last Post: vidarr
  Angelfish on Plasma Mobile not working fernando_c_m 4 4,163 09-06-2020, 10:31 PM
Last Post: bcnaz
  Is it possible to pre-configure wifi and ssh with pmbootstrap? kelbot 2 3,221 07-06-2020, 01:55 AM
Last Post: ChriChri

Forum Jump:


Users browsing this thread: 1 Guest(s)