Dropbox cannot be installed
#1
Hi

I tried to install dropbox but the installation failed.


Quote:mobian@mobian:~/mobshare$ sudo apt install ./dropbox*.deb
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Note, selecting 'dropbox:amd64' instead of './dropbox_2020.03.04_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
dropbox:amd64 : Depends: python3-gi:amd64 (>= 3.12) but it is not installable
                Depends: python3:amd64 (>= 3.4.0) but it is not installable
                Depends: libatk1.0-0:amd64 (>= 2.10) but it is not installable
                Depends: libc6:amd64 (>= 2.19) but it is not installable
                Depends: libcairo2:amd64 (>= 1.13) but it is not installable
                Depends: libglib2.0-0:amd64 (>= 2.40) but it is not installable
                Depends: libgtk-3-0:amd64 (>= 3.10.8) but it is not going to be installed
                Depends: libpango1.0-0:amd64 (>= 1.36.3) but it is not installable
                Depends: gir1.2-gdkpixbuf-2.0:amd64 (>= 2.30.7) but it is not installable
                Depends: gir1.2-glib-2.0:amd64 (>= 1.40.0) but it is not installable
                Depends: gir1.2-gtk-3.0:amd64 (>= 3.10.8) but it is not going to be installed
                Depends: gir1.2-pango-1.0:amd64 (>= 1.36.3) but it is not installable
E: Unable to correct problems, you have held broken packages.

Any chance this will be available?

thanks
  Reply
#2
I think the problem is you are trying to install a package compiled for amd64 architecture. This doesn't work because the PinePhone is an arm architecture.
  Reply
#3
I see... so, I guess many software has to be moved to arm
  Reply
#4
The open source software is mostly fine already, and any remaining problems can be fixed. The problem is the closed software - if they don't provide a binary for the architecture you want then the best you can do is ask them nicely and hope.
  Reply
#5
there's a dropbox uploader script that makes use of the dropbox API. it's probably in your repositories, or at least available through a repo. it exists on the AUR for example as dropbox-uploader-git
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobian snd_seq not installed Hiraghm 2 151 07-22-2020, 12:08 AM
Last Post: Hiraghm

Forum Jump:


Users browsing this thread: 1 Guest(s)