IDE megathread - please contribute
Hi, information about IDE's are quite scattered around web and it'd be cool if you shared your experiences with what works, and what does not. I'll start, I'm using Manjaro.

- VS Code -
works, though it's a bit choppy. It's my IDE of choice for C++ together with the "clangd" extension, which provides good autocompletion/find references/find implementation functionalities. Official C++ extension doesn't support ARM, but it's in progress. Clangd is a good replacement.

- KDevelop - I've installed it, though I don't remember how. I've messed with it a bit and then found out about clangd

- RStudio - I'm not aware of anyone installing it on Manjaro due to missing dependencies(whole Haskell, I think). It's possible it works on Debian, though.
I am happily banging away on VSCodium (VS Studio with a lot of the MS stuff yanked out) and sometimes I use Thonny as well for Python.   VSCodium has worked great.
I also have Pyzo installed as well, but other than opening it and poking around in the settings I have not used it. Oh and Arduino IDE is also installed...I have not fired it up yet though.

On Manjaro, VSCodium is available to be built out of AUR
Pyzo is in the Official manjaro Repository
Arduino IDE is in the Official Manjaro Repository

One thing I want to add for anybody thinking of the PBP as a dev machine. I find the PBP a wonderful light dev machine (light not because it could not do moderate or heavy dev, it is just that my needs are light). Keep in mind I am purely using it for Python...if you are using a compiled language...your mileage may vary. The other one thing that kept this from being a near perfect dev machine for me is the trackpad, the palm rejection and at times difficult behavior can drive you mad. I solved this completely by using a small wireless mouse when a mouse is absolutely needed.
I use the ide's from jetbrains.
Pycharm, webstorm, goland, intelliJ idea with rust plugin. I know i could install all the other language plugins into intelliJ.

Only the terminal tab doesn't work. (a java bug?).

Verzonden vanaf mijn iPhone met Tapatalk
Getting atom running is on this message:

Qt Creator is available directly with pacman. I've used it a bit and it works quite nicely.

Forum Jump:

Users browsing this thread: 1 Guest(s)