My NetBSD on Pinebook Pro journey
Thumbs Up 
First, thank you to all involved in developing these solutions.  I could not design and build a Pinebook, and likely couldn't port NetBSD to it.

A few months ago, I dug out an old laptop to use as a portable VNC terminal to operate and administer the various computers (some "headless") that I have, which run NetBSD and Debian/Raspbian Linux. After finding out that the hard drive was quickly dying, I sought out another cheap, used laptop.  I also found out about the Pinebook which seemed more lucrative, since I wouldn't need to buy new obsolete batteries.  I then found out that it would be quicker to get a Pinebook Pro.  So I ordered one.  A few covid months went by but then one day I got a tracking number.  Two days later I had the Pinebook Pro in my hands, all the way from Hong Kong!  I can't get things that quickly from a hundred miles away.  What an amazing machine.  It seems very well engineered and built, especially considering the price.

I thought I would use the Pinebook Pro to download NetBSD.  I quickly discovered an error in my DHCP server.  The Debian that came with the Pinebook Pro would always clobber /etc/resolv.conf, even though I was using a static IP.  Oddly, I have two other machines running Debian Buster, which do not have this problem.  But I fixed the server, and was able to download a NetBSD image.  I could not boot from the SD card though.  When the SD card was inserted, the eMMC would not boot, but neither did the SD card. 

So I took the bottom off the Pinebook and switched off the eMMC, and switched it back on immediately after the SD card started to boot.  This turned out to be pretty straightforward and not as scary as I had read.  The trick is to open the lid 90°, and lay the Pinebook on its keyboard, with the display overhanging the edge of a table, for disassembly.  I carefully stood the Pinebook up on its side to operate it.  Of course, I made sure to remove the plastic standoffs first.  A speaker did fall out, but I pressed it back in.  When picking up the Pinebook to stand it on edge, I picked it up by the display half so as not to put any load on the hinges.

I tried for several days to use sysinst to install with small partitions.  There is something wrong with sysinst, going back to at least version 8, on every platform I've used it on.  The partitioning barely works and does some very bad things.  I never did get it to give me a working, bootable setup on the Pinebook Pro.  I only tried this because I like to have small partitions so that I can quickly make uncompressed images that easily fit on USB memory sticks.  So rather than try to partition and install manually, I put the installation image on the eMMC and let it grow itself.  When doing this, you can link /targetroot to / and still use sysinst to configure the system and install pkgsrc.

I initially did have some hiccups with the wifi.  I used FTP to retrieve the NetBSD image from a local server.  I had the "flood of checksum errors" problem.  But I rebooted and tried again, and did not have the issue again.  In fact, except for sysinst occasionally crashing, I'm finding NetBSD-current to be very stable.  Right now, it's compiling kde4, and has been doing this for over twelve hours.
I had my first lockup. I've never had NetBSD do this so I'm not sure what to make of it. Did I run out of swap compiling kde4? Or did something happen with a power outage? The power did go out briefly last night. I lose internet connectivity during power outages.

Edit: most unusual: one of my Debian machines was locked frozen too.
(06-23-2020, 01:30 PM)KC9UDX Wrote: I had my first lockup.  I've never had NetBSD do this so I'm not sure what to make of it.  Did I run out of swap compiling kde4?  Or did something happen with a power outage?  The power did go out briefly last night.  I lose internet connectivity during power outages.

Edit: most unusual: one of my Debian machines was locked frozen too.

hi KC9UDX, welcome to netbsd pinebooking :-)

i've never tried using sysinst on my pine64 systems.  i've either used the arm64.img which is pre-installed and self-expanding, or manually installed by hand.  sorry, i can't help with those questions.  the original debian emmc vs. netbsd in sd is some incompatibility with the older uboot shipped not properly understanding the netbsd sd card, but i've heard that the newer manjaro one can boot netbsd in sd.  glad you figured out the emmc switch, etc.

what version of netbsd is it?  older -current (march/april) was more likely to hang if using the builtin wifi, but it seems to have been fixed now.  i had perhaps one hang (but in a month, vs daily), and i haven't seen the checksum errors very much (often not for days). it's possible that running out of swap can hang, though it usually at least is responsive enough to see something is alive.  if you have something that calls itself less than 9.99.55 or so, i strongly recommend updating to a newer version.

you can get binary packages from though i'm not finding the path currently. (you can trust, it is hosted by a netbsd developer, one of the major netbsd arm64 contributors.)  ah, i found the netbsd-9 ones here, but i can't find the ones for -current.

Thank you!

I haven't had a chance to keep trying kde4. I've been without internet for a while. I was counting on being able to USB tether my phone, but this doesn't work with my particular phone apparently (I'm not the only one reporting this). So having not gotten that working, I may go back to trying to get smaller disk slices first, but not via sysinst. I'm toying with the idea of booting with an sd card and repartitioning the already installed and working eMMC. I'm pretty sure that the problem with sysinst is not Pinebook Pro related. The biggest issue is keeping it from clobbering the /boot partition. I've had this same problem on x64, amd64, and ARM (for RPi). I'm surprised other people aren't reporting trouble with this. I would assume that installing Linux/Windows and NetBSD on the same drive is pretty common.

The version I've been using is 9.99.67. I got it from (if I recall correctly). I have increased swap to 8G. I haven't done enough testing to see if that helps. On everything else I've installed NetBSD on, I have a ton of swap, just because I'm used to having swap=2×RAM (which I understand isn't necessary in NetBSD).
There is a thread in the netbsd-arm mailing list talking about creating a wiki or something wrt NetBSD on the pinebook pro I guess this post is a good start?

Enviado desde mi ONEPLUS A5010 mediante Tapatalk
I've had a couple more lockups.  Previously, I was logging in at the "console" (keyboard and monitor, not RS232) and using sh by itself.  So when it locked up, I couldn't even tell if anything was working.  The last few times, I've been running X11 with twm.  So when it locks, I can say that X11 and twm still work, but all XTerms lock up.  One of these days I'll build a headphone -> RS232 cable so at least I can do some poking round and maybe see what's happening.

I don't think it's a memory/swap issue.  The last two times I saw it happen, make was in the middle of an ftp download.  I can't imagine that it could run out of memory at that point.
It's been compiling for 3 days without a hitch until I ran out of space on /.  So I had to delete my swap file, which I really don't think I need anyway.  But it looks like I might have to spring for a larger eMMC. Sad
I'm starting to see a pattern here: I get much, much more uptime when X11 isn't running.
I got my PBP back. My wife's new PBP arrived. So I have time to play with NetBSD again.

I installed 9.99.72. (I think that's what it is, can't look right now.) I'm on my third try. This version, for me, is much, much less stable than the previous. I'm not sure why. I have been getting WiFi checksum errors, usually followed by lack of response from keyboard, and apparent total system lock. It happens very frequently. Most recently it happened whilst installing a bunch of packages. Even though I have journaling turned on, /tmp got severely hosed. Unfortunately the system automatically trying to clear that on boot-up really did a number on the filesystem. I may have to start over again. fsck has been finding DUPs for about six hours now. If I fail again, I'll be back to the previous version.
For what it's worth, I can say with confidence that dd is fastest with bs=64k transferring from a 32Gb SanDisk Ultra HC1 to the eMMC.

Possibly Related Threads…
Thread Author Replies Views Last Post
  NetBSD and pinebook keyboard/trackpad firmware updater mrgtwentythree 5 6,159 05-16-2021, 07:37 PM
Last Post: mrgtwentythree
  NetBSD Der Geist der Maschine 76 72,242 05-16-2021, 02:43 PM
Last Post: mrgtwentythree
Question OpenBSD 6.7 on Pinebook Pro SKG 27 34,225 05-07-2021, 04:03 PM
Last Post: bigtreeman
Music NetBSD and USB "sound cards" KC9UDX 2 2,831 05-07-2021, 12:11 PM
Last Post: elimark1
  OpenBSD on the pinebook pro e-minguez 5 7,813 04-27-2021, 04:06 AM
Last Post: dreamer_
  PINEBOOK Pro USB-C Docking Deck on FreeBSD S199pWa1k9r 2 2,538 03-04-2021, 01:53 PM
Last Post: Arwen
Question Issues Installing NetBSD on a PineBook Pro ReleaseTheGeese 14 8,027 01-31-2021, 11:20 AM
Last Post: KC9UDX
  NetBSD -Current binaries BronzeBeard 8 6,585 12-31-2020, 08:38 PM
Last Post: BronzeBeard

Forum Jump:

Users browsing this thread: 1 Guest(s)